LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-04-2008, 11:55 AM   #1
liamkincaid25
Member
 
Registered: Apr 2002
Location: puerto rico
Posts: 70

Rep: Reputation: 15
Question How to finish a double boot installation?


Greetings!
I am quite new at Linux and as expected has been having a few problems. I was using Ubuntu 8.04 in one desktop and wanted to try Open Suse. I just inserted the live cd and went for the installation. It went ok but at the end of the process went the computer rebooted only Open Suse was the only Operating system present. I did some reading and found that for some reason you must first install Open Suse and then install Ubuntu not allowing ubunto boot loader to be installed. I also read that after that you configure GRUB from Suse to allow the dual booting. So I installed Ubuntu 8.04 without the boot loader in the desk top with Suse (and this took A VERY LONG TIME) at the end of the installation the computer asked for a reboot to finish the process. I rebooted and the pc went straight to open suse. I assume tha Ubuntu is installed somewhere in the partition and that I need to configure GRUB to acces it upon booting. But I really do not know how to do this. If anyone can explain it I will be thankful (is just I do not want to be messing around and then have to start all over again). What appear in the partition table is the following /dev/sda 37.2gb ,dev/sda1 949.1mb ,dev/sd2 14.6bg ,dev/sda3 604.0 mb , dev/sda4 21.1gb ,dev/sda5 20.2gb ,dev/sda6 941.2mb ( sorry but as parte of being a newbbie I did not know how to cut and paste from the expert partitoner window ) Thank you for your time and help
 
Old 06-04-2008, 12:44 PM   #2
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 6,983

Rep: Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295
It doesn't matter if Ubuntu is installed first or Opensuse is. During your installation, you will have the option to install the bootloader to the mbr or the boot directory. What you did when you installed Opensuse is install Grub to the mbr which wrote over the Ubuntu entry in the mbr. The best think to do is boot up Opensuse and run the 'fdisk -l' command as root (that is a lower case L not a one (1)in the fdisk command. Post the results of this command indicating which partitions Ubuntu and Opensuse are on. You will then need to edit (as root) the Opensuse /boot/grub/menu.lst file to place an entry for Ubuntu.

This information is needed so that you can make a correct entry in this file. If you have Ubuntu on sda2 you will need an entry like this in the Opensuse menu.lst file:
title Ubuntu
root (hd0,2)
configfile /boot/grub/menu.lst

If you don't understand just post the output of the 'fdisk -l' command and also your Opensuse menu.lst file.
 
Old 06-04-2008, 12:52 PM   #3
saikee
Senior Member
 
Registered: Sep 2005
Location: Newcastle upon Tyne UK
Distribution: Any free distro.
Posts: 3,398
Blog Entries: 1

Rep: Reputation: 112Reputation: 112
You have been told wrong. (in the 1st post not by yancek !)

Always install the boot loader! but not to the MBR. Instead you instruct the 2nd to the 1999th Linux to install the boot loader inside its root partition. Thereafter you edit the /boot/grub/menu.lst (of the 1st Linux) to add this 3 lines, assuming your 2nd Linux (or its /boot partition) is the 5th partition of the 1st disk known to Grub as (hd0,4), as Frub counts everything from zero.

Code:
title My Linux in partition sda5 or (hd0,4)
root (hd0,4)
chainloader +1
Repeat the same until you hit 1999th Linux. The MBR is for the first Linux. You can install them in any order.

Satisfaction guaranteed or your money back.

Last edited by saikee; 06-04-2008 at 12:53 PM.
 
Old 06-04-2008, 01:34 PM   #4
liamkincaid25
Member
 
Registered: Apr 2002
Location: puerto rico
Posts: 70

Original Poster
Rep: Reputation: 15
Stuck

Quote:
Originally Posted by yancek View Post
It doesn't matter if Ubuntu is installed first or Opensuse is. During your installation, you will have the option to install the bootloader to the mbr or the boot directory. What you did when you installed Opensuse is install Grub to the mbr which wrote over the Ubuntu entry in the mbr. The best think to do is boot up Opensuse and run the 'fdisk -l' command as root (that is a lower case L not a one (1)in the fdisk command. Post the results of this command indicating which partitions Ubuntu and Opensuse are on. You will then need to edit (as root) the Opensuse /boot/grub/menu.lst file to place an entry for Ubuntu.

This information is needed so that you can make a correct entry in this file. If you have Ubuntu on sda2 you will need an entry like this in the Opensuse menu.lst file:
title Ubuntu
root (hd0,2)
configfile /boot/grub/menu.lst

If you don't understand just post the output of the 'fdisk -l' command and also your Opensuse menu.lst file.
I opened the shell console and tried your command 'fdisk -l' ( I cut and pasted it because sometimes a space in this things is important) but I only get "command not found". I am doing it from the desktop once suse has finished loading .Obviously I am doing something wrong. Also where do I get the info that you ask ( Opensuse menu.lst file )?. Sorry for so many "not so smart" questions but it is all Bill Gates fault!!! lol . Thank you for your help and time once more

Last edited by liamkincaid25; 06-04-2008 at 01:39 PM.
 
Old 06-04-2008, 01:46 PM   #5
liamkincaid25
Member
 
Registered: Apr 2002
Location: puerto rico
Posts: 70

Original Poster
Rep: Reputation: 15
Than you

Quote:
Originally Posted by saikee View Post
You have been told wrong. (in the 1st post not by yancek !)

Always install the boot loader! but not to the MBR. Instead you instruct the 2nd to the 1999th Linux to install the boot loader inside its root partition. Thereafter you edit the /boot/grub/menu.lst (of the 1st Linux) to add this 3 lines, assuming your 2nd Linux (or its /boot partition) is the 5th partition of the 1st disk known to Grub as (hd0,4), as Frub counts everything from zero.

Code:
title My Linux in partition sda5 or (hd0,4)
root (hd0,4)
chainloader +1
Repeat the same until you hit 1999th Linux. The MBR is for the first Linux. You can install them in any order.

Satisfaction guaranteed or your money back.
Thank you for your answer, but you seem to think that I know a little more about linux than I really know. I just wanted to see how it work out of curiosity. I like the programs and the presentation.The only thing I have been able to do is put the disk to boot in a clean hard disk But to a newbie newbie like me it is quite difficult to follow your suggestions. Do not take me wrong I am grateful for your suggestions but if you break down a little more I might be able to do as you say. Than you
 
Old 06-04-2008, 02:09 PM   #6
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 6,983

Rep: Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295
You need to run the 'fdisk -l' command as root as I indicated in my original post.

You need to open the menu.lst file as root also so logged in as root:

cd /boot/grub/
cat menu.lst

Post these results.
 
Old 06-04-2008, 02:22 PM   #7
liamkincaid25
Member
 
Registered: Apr 2002
Location: puerto rico
Posts: 70

Original Poster
Rep: Reputation: 15
fdisk result

Disk /dev/sda: 20.0 GB, 20003880960 bytes
255 heads, 63 sectors/track, 2432 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x0000b53c

Device Boot Start End Blocks Id System
/dev/sda1 * 1 82 658633+ 83 Linux
/dev/sda2 83 2432 18876375 5 Extended
/dev/sda5 2330 2432 827316 82 Linux swap / Solaris
/dev/sda6 2230 2329 803218+ 82 Linux swap / Solaris
/dev/sda7 83 941 6899854+ 83 Linux
/dev/sda8 942 2229 10345828+ 83 Linux

Partition table entries are not in disk order

This is the result of the f disk gives me a momento I will post the other you asked for
 
Old 06-04-2008, 02:25 PM   #8
liamkincaid25
Member
 
Registered: Apr 2002
Location: puerto rico
Posts: 70

Original Poster
Rep: Reputation: 15
The other part

linux:/boot/grub # cat menu.lst
# Modified by YaST2. Last modification on Mon Jun 2 00:09:12 BST 2008
default 0
timeout 8
gfxmenu (hd0,6)/boot/message

###Don't change this comment - YaST2 identifier: Original name: linux###
title openSUSE
root (hd0,6)
kernel /boot/vmlinuz-2.6.22.5-31-default root=/dev/disk/by-id/scsi-SATA_HTC426020G5CE00_L6VP1U-part7 vga=0x317 resume=/dev/sda5 splash=silent showopts
initrd /boot/initrd-2.6.22.5-31-default

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe -- openSUSE
root (hd0,6)
kernel /boot/vmlinuz-2.6.22.5-31-default root=/dev/disk/by-id/scsi-SATA_HTC426020G5CE00_L6VP1U-part7 vga=normal showopts ide=nodma apm=off acpi=off noresume nosmp noapic maxcpus=0 edd=off 3
initrd /boot/initrd-2.6.22.5-31-default


Hope this is what you needed. Thank you
 
Old 06-04-2008, 02:39 PM   #9
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 6,983

Rep: Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295
You have two swap partitions which is unecessary and a waste of space but doesn't really cause a problem. You could probably delete one of them.

Your Opensuse is on sda7. The Grub entry in your menu.lst shows Opensuse as (hd0,6) which is the same as sda7 in Linux. In Opensuse as root, run this command: mkdir /mnt/ubuntu

Then to determine which partition your Ubuntu is do the following as root:
"mount /dev/sda1 /mnt/ubuntu" (without quotes)
Then: cd /mnt/ubuntu/ and do: ls -l
If you see directories/files your Ubuntu is on sda1
If you see nothing run the above commands again replacing sda1 with sda8.
Your entry in the menu.lst will depend upon the results of these commands. If it is sda1 the entry below would be "root (hd0,0)
If it is sda8 the entry below would be "root (hd0,7)
Either entry should work.


title Ubuntu
root (hd0,2)
configfile /boot/grub/menu.lst

title My Linux in partition sda5 or (hd0,4)
root (hd0,4)
chainloader +1
 
Old 06-08-2008, 06:21 PM   #10
liamkincaid25
Member
 
Registered: Apr 2002
Location: puerto rico
Posts: 70

Original Poster
Rep: Reputation: 15
Sorry reinstallation was needed

I am sorry I was forced to do a reinstallation of Suse and this seems to have changed some parameters. I am posting the new values to see if you can point me once more to be able to do a dual boot.


Disk /dev/sda: 40.0 GB, 40000000000 bytes
255 heads, 63 sectors/track, 4863 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x000cf95b

Device Boot Start End Blocks Id System
/dev/sda1 1 121 971901 82 Linux swap / Solaris
/dev/sda2 * 122 2028 15317977+ 83 Linux
/dev/sda3 2029 2105 618502+ 83 Linux
/dev/sda4 2106 4863 22153635 5 Extended
/dev/sda5 2106 4743 21189703+ 83 Linux
/dev/sda6 4744 4863 963868+ 82 Linux swap / Solaris


linux:/boot/grub # cat menu.lst
# Modified by YaST2. Last modification on Sat Jun 7 11:21:45 BST 2008
default 0
timeout 8
gfxmenu (hd0,1)/boot/message
##YaST - activate

###Don't change this comment - YaST2 identifier: Original name: linux###
title openSUSE
root (hd0,1)
kernel /boot/vmlinuz-2.6.22.5-31-default root=/dev/disk/by-id/scsi-SATA_ST340014A_5JXKVW3K-part2 vga=0x317 resume=/dev/sda1 splash=silent showopts
initrd /boot/initrd-2.6.22.5-31-default

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe -- openSUSE
root (hd0,1)
kernel /boot/vmlinuz-2.6.22.5-31-default root=/dev/disk/by-id/scsi-SATA_ST340014A_5JXKVW3K-part2 vga=normal showopts ide=nodma apm=off acpi=off noresume nosmp noapic maxcpus=0 edd=off 3
initrd /boot/initrd-2.6.22.5-31-default

linux:~ # mount /dev/sda1 /mnt/ubuntu
/dev/sda1 looks like swapspace - not mounted
mount: you must specify the filesystem type

linux:~ # ls-l
total 48
-rw------- 1 root root 171 Jun 9 03:13 .bash_history
-rw-r--r-- 1 root root 1332 Nov 23 2005 .exrc
drwxr-xr-x 2 root root 4096 Jun 7 12:28 .fvwm
drwx------ 2 root root 4096 Oct 13 2007 .gnupg
drwxr-xr-x 2 root root 4096 Jun 7 12:28 .kbd
-rw------- 1 root root 50 Jun 8 20:44 .xauth9ydRA1
-rw------- 1 root root 50 Jun 9 03:14 .xauthIJAd57
-rw------- 1 root root 50 Jun 9 03:17 .xauthOe4TSz
-rw------- 1 root root 50 Jun 8 20:40 .xauthR6tFt6
-rw------- 1 root root 50 Jun 9 03:03 .xauthryjFdr
-rw------- 1 root root 50 Jun 9 03:07 .xauthuKXZ4C
drwxr-xr-x 2 root root 4096 Sep 21 2007 bin

I hope you can continue tutoring me in this stuff . THANK YOU for your time an patience.
 
Old 06-08-2008, 08:08 PM   #11
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 6,983

Rep: Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295
If you look at your last post - the results of the fdisk-l command show that sda1 and sda6 are swap partitions. As I indicated earlier, you don't need two. Any number of operating systems (Linux) can use the same swap space if necessary.

I don't know what sda3 partition is but it is too small to have an OS on it and sda4 is an extended partition which contains logical partitions. You can't install an operating system on an extended partition so these two are eliminated. If you look at your menu.lst post from opensuse it shows root as (hd0,1) which is the equivalent of sda2. Grub numbers from zero (0) and Linux drives number from one (1). So this means your Ubuntu is on sda5 or in Grub (hd0,4).

So, do the mount command again but this time do, as root in opensuse:

mkdir /mnt/ubuntu
mount /dev/sda4 /mnt/ubuntu

Then change directories:
cd /mnt/ubuntu/boot/

Run the ls -l command in this directory:

You should see files named initrd and vmlinuz with numbers after them. If you get this far and this works you will just need to make entries for Ubuntu in the opensuse menu.lst file. Post back with further questions or if you are not clear.
 
Old 06-08-2008, 11:22 PM   #12
liamkincaid25
Member
 
Registered: Apr 2002
Location: puerto rico
Posts: 70

Original Poster
Rep: Reputation: 15
Root

From the root console I tried to follow your directions but got this , which seems to be wrong according to your instructions.

linux:~ # mkdir /mnt/ubuntu
mkdir: cannot create directory `/mnt/ubuntu': File exists
linux:~ # mount /dev/sda4 /mnt/ubuntu
mount: you must specify the filesystem type
linux:~ # cd /mnt/ubuntu/boot/
-bash: cd: /mnt/ubuntu/boot/: No such file or directory
linux:~ # cd /mnt/ubuntu/boot/ ls-l
-bash: cd: /mnt/ubuntu/boot/: No such file or directory

The command of ls-l was done by me just trying to find a working combination ( you did not say to do it this way , just to be clear and people do not start to say it is not done that way)
 
Old 06-09-2008, 12:02 AM   #13
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 6,983

Rep: Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295
OK, you had already created the /mnt/ubuntu directory so do this:

mount -t ext3 /dev/sda4 /mnt/ubuntu

Do this as root and then proceed with the other commands.
 
Old 06-09-2008, 11:27 PM   #14
liamkincaid25
Member
 
Registered: Apr 2002
Location: puerto rico
Posts: 70

Original Poster
Rep: Reputation: 15
Getting there

linux:~ # mount /dev/sda4 /mnt/ubuntu mount -t ext3 /dev/sda4 /mnt/ubuntu
Usage: mount -V : print version
mount -h : print this help
mount : list mounted filesystems
mount -l : idem, including volume labels
So far the informational part. Next the mounting.
The command is `mount [-t fstype] something somewhere'.
Details found in /etc/fstab may be omitted.
mount -a [-t|-O] ... : mount all stuff from /etc/fstab
mount device : mount device at the known place
mount directory : mount known device here
mount -t type dev dir : ordinary mount command
Note that one does not really mount a device, one mounts
a filesystem (of the given type) found on the device.
One can also mount an already visible directory tree elsewhere:
mount --bind olddir newdir
or move a subtree:
mount --move olddir newdir
One can change the type of mount containing the directory dir:
mount --make-shared dir
mount --make-slave dir
mount --make-private dir
mount --make-unbindable dir
One can change the type of all the mounts in a mount subtree
containing the directory dir:
mount --make-rshared dir
mount --make-rslave dir
mount --make-rprivate dir
mount --make-runbindable dir
A device can be given by name, say /dev/hda1 or /dev/cdrom,
or by label, using -L label or by uuid, using -U uuid .
Other options: [-nfFrsvw] [-o options] [-p passwdfd].
For many more details, say man 8 mount .

inux:~ # cd /mnt/ubuntu/boot/
-bash: cd: /mnt/ubuntu/boot/: No such file or directory
linux:~ # cd /mnt/ubuntu/boot/
-bash: cd: /mnt/ubuntu/boot/: No such file or directory
linux:~ # ls-l
total 68
-rw------- 1 root root 635 Jun 9 08:23 .bash_history
-rw-r--r-- 1 root root 1332 Nov 23 2005 .exrc
drwxr-xr-x 2 root root 4096 Jun 7 12:28 .fvwm
drwx------ 2 root root 4096 Oct 13 2007 .gnupg
drwxr-xr-x 2 root root 4096 Jun 7 12:28 .kbd
-rw------- 1 root root 50 Jun 8 20:44 .xauth9ydRA1
-rw------- 1 root root 50 Jun 9 08:05 .xauthCJk0S5
-rw------- 1 root root 50 Jun 9 03:14 .xauthIJAd57
-rw------- 1 root root 50 Jun 9 03:17 .xauthOe4TSz
-rw------- 1 root root 50 Jun 8 20:40 .xauthR6tFt6
-rw------- 1 root root 50 Jun 9 08:47 .xauthciym98
-rw------- 1 root root 50 Jun 9 08:10 .xauthk8kOrx
-rw------- 1 root root 50 Jun 10 08:09 .xauthl88IAJ
-rw------- 1 root root 50 Jun 9 03:03 .xauthryjFdr
-rw------- 1 root root 50 Jun 9 03:07 .xauthuKXZ4C
-rw------- 1 root root 50 Jun 9 07:49 .xauthza9JFP
drwxr-xr-x 2 root root 4096 Sep 21 2007 bin
linux:~ #
Well I have tried to follow your commands and this is what I am getting . I am guessing I am not there yet. Reading this at the office I think that I made an error in linux:~ # mount /dev/sda4 /mnt/ubuntu mount -t ext3 /dev/sda4 /mnt/ubuntu ( should I take out the word MOUNT and paste only from -text3 on?)

Last edited by liamkincaid25; 06-10-2008 at 10:41 AM. Reason: possible mistake
 
Old 06-10-2008, 11:12 AM   #15
liamkincaid25
Member
 
Registered: Apr 2002
Location: puerto rico
Posts: 70

Original Poster
Rep: Reputation: 15
Post Thank you

I just want to thank you Yancek for taking from your time to help me with this issue.(the same goes to Saikee)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Ubuntu won't boot after it tells me to remove install. disc to finish installation Baddox Ubuntu 2 07-16-2005 11:05 AM
how to get on redhat 7.2's desktop screen after installation finish laptop Red Hat 3 02-11-2005 09:35 AM
i cant finish the installation of fedora. it cant read a file phreaker808 Linux - Newbie 1 02-12-2004 01:41 AM
can't finish licq installation ismanpa Linux - Software 0 09-22-2003 11:09 AM
Please help me to finish this Oracle 8 for Linux installation. yuzuohong Linux - General 5 08-22-2002 03:46 PM


All times are GMT -5. The time now is 05:37 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration