LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   how to find cdrom mount point (http://www.linuxquestions.org/questions/linux-newbie-8/how-to-find-cdrom-mount-point-601789/)

walterj 11-22-2007 10:18 PM

how to find cdrom mount point
 
i'm trying out the instant opengroup software. it comes with suse server. i installed it, and am try to get it running, but i keep running into walls. the suse server boots to a terminal - no gui. i downloaded gnome 2.2, and created a cd, but i can't get the cdrom working. tried mount cdrom, dvd as per other posts, but get no mount point error. i checked fstab and mtab but they have no entries for cdrom. how can i find the mount point (if there is one)?

i need explicit instuctions: i'm a newbie. i'm also running kubuntu 7.11, and like that os! i tried setting u a ubuntu server, but also got a terminal screen there at boot. my next challenge is to get the server running with windows network. i installed samba on kubuntu and am making some headway with the firewall. hopefully i can give windows the boot

walter

gilead 11-22-2007 10:36 PM

It's not a fixed thing - convention often has a cdrom or dvd directory under /mnt or /media so you could look there first.

Otherwise, try mounting and specifying the mount point after creating your own (you'll need to be root or use sudo):
Code:

mkdir -p /mnt/cdrom && mount -t iso9660 -o ro /dev/cdrom /mnt/cdrom
PS You may also find that the device is different - on my system the DVD is /dev/hdc and the cdrom is /dev/hdd

walterj 11-22-2007 10:44 PM

thanks for your reply. i created a directory, and tried to mount to it, but get the no mount point error. i didn't notice anything close to what could be a mount point either.

jaseka 11-23-2007 07:03 AM

Did you see the /media/cdrom directory?


In suse cdrom by default mounted in this directory.

gilead 11-23-2007 01:11 PM

Quote:

Originally Posted by walterj (Post 2968046)
thanks for your reply. i created a directory, and tried to mount to it, but get the no mount point error. i didn't notice anything close to what could be a mount point either.

Can you post the commands you've been using? The no mount point error means that the directory you're using as a mount point doesn't exist. It could be that the mkdir command didn't work or that you're not referring to it properly in the mount command.

bigrigdriver 11-23-2007 01:39 PM

Check /dev to see if cdrom exists. In one version of Suse that I've used, cdrom is a symlink to /dev/hdc; in another, cdrom was symlinked to /dev/st0.

From the command line, run /usr/sbin/hwinfo --cdrom. That should tell you the device. Look for something like this ' Device File: /dev/hdc ' in the output. If you get an error that /dev/cdrom doesn't exist, then you know why you can't mount it. Just make a symlink to the correct device, and mount it.

walterj 11-25-2007 11:16 AM

Quote:

Originally Posted by bigrigdriver (Post 2968673)
Check /dev to see if cdrom exists. In one version of Suse that I've used, cdrom is a symlink to /dev/hdc; in another, cdrom was symlinked to /dev/st0.

From the command line, run /usr/sbin/hwinfo --cdrom. That should tell you the device. Look for something like this ' Device File: /dev/hdc ' in the output. If you get an error that /dev/cdrom doesn't exist, then you know why you can't mount it. Just make a symlink to the correct device, and mount it.

thanks.

/usr/sbin/hwinfo --cdrom returns 'no such file or directory. i tried other variants of cdrom - cdrw, cdwriter, cdwriter-rw, cdrom-hdc with same results.

media directory is empty.

qstn: is it possible to install gnome? is there a reason suse does not have gnome as part of the package?

if i can install gnome, then can i install it directly from the internet through the command line?

walter

walterj 11-27-2007 03:29 PM

cdrom issue solved
 
i'm not sure why, but i managed to get the cdrom running in /mnt/cdrom

I still can't get x windows running. tried run xorgconfig but get no such file.

can't see the suse pc on the windows net yet either

yuehchung 03-18-2012 02:13 AM

auto mount /dev/dvd and avoid bad superblock
 
A. config [/etc/fstab] by yourself

1.Step 1 : mkdir -p /mnt/cdrom
2.Step 2 : modify /etc/fstab
(1) vim /etc/fstab
(2) add(or modify)
/dev/dvd /mnt/cdrom auto defaults 0 0
(3) save it.
3.Step 3 : reboot the server.

B. Burn the files into the disk by using win7-->Burn to VCD/DVD drive.
(To avoid : bad superblock
ex : the error information -- mount: wrong fs type, bad option, bad superblock on /dev/cdrom)

if you want to get printscreen doc file, please mail to
yuehchung.su@gmail.com


YuehChung.Su
SD, DBA, System owner


All times are GMT -5. The time now is 03:26 PM.