LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-12-2009, 04:58 PM   #1
applefox
LQ Newbie
 
Registered: Mar 2009
Posts: 12

Rep: Reputation: 0
How to Exit X-Server ?!


My problem is, that whenIi try to install the new nvidia driver on my Knoppix linux, the installation tells me, that I have to exit x-server. Well how is that a good Idea? X is my desktop envirment. Oh by the way If you need it my specs are as fallows

G-Card is a Nvidia ge force 9600.
Motherbord is an Asus (Sorry but I just forgot the Model number lol)
My prosesser is an Intell 10.64 GHZ Core 2 quad
And I have 2 MB of ram. Hope that helps.
 
Old 03-12-2009, 05:24 PM   #2
x_terminat_or_3
Member
 
Registered: Mar 2007
Location: Plymouth, UK
Distribution: Fedora Core, RHEL, Arch
Posts: 342

Rep: Reputation: 38
Your X server runs on top of your operating system.

What NVidia is saying is that it is unwise to update/install the driver when the X server is running.

So to proceed, save all your unsaved data.

Reboot, and when you get to the GRUB prompt, press the E key to edit the command line, then choose the line that begins with kernel, press E again, and append a space and the number 3 to that line, press ENTER, then b for boot.

You are now booting into runlevel 3. Log on as root, then run your NVidia installer again. When it finishes, reboot normally.
 
Old 03-12-2009, 05:32 PM   #3
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,527

Rep: Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898
Press CTRL_ALT_F1
login as root
type
Code:
/etc/init.d/gdm stop
for GNOME or
Code:
/etc/init.d/kdm stop
for KDE
Do your thing

To restart X

Code:
/etc/init.d/gdm start
or
Code:
/etc/init.d/kdm start
 
Old 03-12-2009, 05:59 PM   #4
ArfaSmif
Member
 
Registered: Oct 2008
Location: Brisbane Australia
Distribution: Always back to Fedora
Posts: 263

Rep: Reputation: 51
Or, press CTRL-ALT-F1 (or CTRL-ALT-F2) at your normal login screen (runlevel 5). Login as root and type "init 3" without the quotes. This will put the machine into runlevel 3. Navigate to your nvidia stuff and away you go. Good luck.
 
Old 03-12-2009, 06:17 PM   #5
applefox
LQ Newbie
 
Registered: Mar 2009
Posts: 12

Original Poster
Rep: Reputation: 0
I am usuing the newest version of Knoppix. The thing is when I booted I did what x_terminat_or_3 said to do. But after I did this it took me to a screen that shows a list of boot options. Here is what it looks like. http://www.aptgetupdate.de/wp-conten...1/bild-738.jpg (Sorry fot the different language it is the only one I found) In order for me to boot I have to scroll down to shell and type startx. The thing is doesn't this defeat the purpose of what I did before with the Linux kernel? Also I have no log in screen. Once I hit enter after typing startx it goes directly to my desk top. What should I do?
 
Old 03-12-2009, 06:19 PM   #6
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,527

Rep: Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898
go to shell
login as root
instead of typing startx,
install the nvidia drivers.
then reboot and type startx

Last edited by repo; 03-12-2009 at 06:21 PM.
 
Old 03-12-2009, 07:21 PM   #7
applefox
LQ Newbie
 
Registered: Mar 2009
Posts: 12

Original Poster
Rep: Reputation: 0
I did try to do that. It didn't work. It didn't install the package. it said the command was unrecognized. Oh and also. I don't have a root account on here. It is automaticly root without a password.

Last edited by applefox; 03-12-2009 at 07:22 PM.
 
Old 03-12-2009, 07:23 PM   #8
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,527

Rep: Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898
Quote:
I did try to do that. It didn't work. It didn't install the package. it said the command was unrecognized.
Could you tell us what you tried?
which command ?
what do you need to do ?
 
Old 03-12-2009, 09:50 PM   #9
applefox
LQ Newbie
 
Registered: Mar 2009
Posts: 12

Original Poster
Rep: Reputation: 0
I did every Suggestion but was talking about this one
"go to shell
login as root
instead of typing startx,
install the nvidia drivers.
then reboot and type startx"
 
Old 03-13-2009, 03:57 AM   #10
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,527

Rep: Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898
what did you typed?
Quote:
install the nvidia drivers.
means, follow the instructions you have to install the drivers, once X is disabled.
 
Old 03-22-2009, 01:09 AM   #11
frqs37
LQ Newbie
 
Registered: Mar 2009
Posts: 10

Rep: Reputation: 1
Do the following:

logon into your desktop (you should have root authority since you said you did not need password)
CTRL-ALT-F1 (you will probably need a root password - no choice)
/etc/init.g/gdm stop
init 3
wait until all major processes have stopped
checked that you have no more gnome gdm processes running (there should not be)
sh NVIDIA-Linux-x86_64-180.29-pkg2.run
init 5
log back in into your upgraded XServer Display
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
how to exit x server phoenix_wolf Linux - Newbie 16 01-11-2008 01:37 PM
how do i exit out of X Server Rangerboy567 Linux - Hardware 5 04-26-2005 12:44 AM
How do I exit the X server dimsun Linux - Newbie 5 11-17-2004 04:07 PM
trying to exit x server HOW Abvolt Linux - Newbie 7 07-06-2003 04:18 AM
Exit the X Server DaDdY SnEb Linux - Newbie 3 10-26-2002 04:10 PM


All times are GMT -5. The time now is 09:01 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration