LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 11-23-2004, 02:29 PM   #1
Kropotkin
Member
 
Registered: Oct 2004
Location: /usr/home
Distribution: Fedora, Mint, FreeBSD, Android
Posts: 346

Rep: Reputation: 31
How to enter high-ascii chars in a Linux editor?


Hi all,

How does one enter high ASCII and/or control characters in a Linux editor (I use gedit mostly but also gvim sometimes). Under DOS/WIN/OS2, one could use Alt-### for this purpose, provided you knew the ASCII number. What is the equivalent under Linux?

Thanks.
 
Old 11-23-2004, 04:21 PM   #2
nhs
Member
 
Registered: Aug 2003
Location: Edinburgh, Scotland
Distribution: Gentoo
Posts: 246

Rep: Reputation: 30
I don't know of a generic method for all character codes however you may want to look at enabling the compose key. The command "setxkbmap -option compose:rwin" will use the right windows key as a compose key. With this enabled the sequence RWin,a," produces . AltGr can also be used with a number of keys to generate symbols. Unfortunately I don't know of a document which lists all the combinations so some trial and error is required to figure out what does what.
 
Old 11-23-2004, 04:39 PM   #3
Kropotkin
Member
 
Registered: Oct 2004
Location: /usr/home
Distribution: Fedora, Mint, FreeBSD, Android
Posts: 346

Original Poster
Rep: Reputation: 31
Actually, I have so-called "dead keys" activated with the Gnome Keyboard program, so I can enter many accented characters -- but not everything.
 
Old 11-23-2004, 04:45 PM   #4
nhs
Member
 
Registered: Aug 2003
Location: Edinburgh, Scotland
Distribution: Gentoo
Posts: 246

Rep: Reputation: 30
In that case I have no idea. Sorry.
 
Old 11-27-2004, 10:28 AM   #5
Kropotkin
Member
 
Registered: Oct 2004
Location: /usr/home
Distribution: Fedora, Mint, FreeBSD, Android
Posts: 346

Original Poster
Rep: Reputation: 31
partial solution

I solved this partially. Under Preferences/Keyboard, there is a tab page, Advanced Layout Ooptions, where one can define the right Alt as a "compose" key for entering accented characters, like ''.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
KDE Konsole and CUPS problems with high ASCII OokamiNoKaze Linux - Software 0 12-09-2004 03:02 PM
typing high-ascii characters gerrym Linux - Newbie 1 08-12-2004 12:38 AM
ASCII Codes in linux slackmagic Linux - Newbie 2 12-22-2003 09:25 AM
man pages and 'high bit' foreign chars leesweet Linux - Software 4 09-29-2003 11:21 PM
Ximian crashes when I enter "special chars" into message borbjo Linux - Software 0 01-28-2003 07:31 AM


All times are GMT -5. The time now is 03:31 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration