LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 10-28-2006, 03:53 PM   #1
jo.angel
LQ Newbie
 
Registered: Oct 2006
Distribution: Suse 10.1
Posts: 13

Rep: Reputation: 0
How to enable sound module in SUSE 10.1 ?


Does anyone know of a good tutorial/description of enabling a module under SUSE 10.1 ?
I have just upgraded my kernel - now the sound has disappeared! Everything points to enabling the sound module in the kernel. As I am still quite a graphical users, and I am not too familiar with textbased applications: Your help is greatly appreciated:

S
Quote:
hell command modinfo soundcore gives me this result:
Quote:

# modinfo soundcore
filename: /lib/modules/2.6.16.21-0.25-smp/kernel/sound/soundcore.ko
description: Core sound module
author: Alan Cox
license: GPL
alias: char-major-14-*
vermagic: 2.6.16.21-0.25-smp SMP 586 REGPARM gcc-4.1
supported: yes
depends:
srcversion: DD426F1CCA2CC5F060F6F92
A bit more info: When trying to re-install the soundcard with YAST, it tells me:

Quote:
Y
Quote:
AST
"kernel module snd-fm801 for sound support could not be loaded. This can be caused by incorrect module parameters including invalid IO or IRQ parameters."
And here some more info:
KDE (configuration) gives me the following info:
Quote:
Quote:
(...)audio devices, synth devices, midi devices, mixer devices...
NOT ENABLED IN CONFIG
All this means bohemian viallges to me...
As well I have taken out the card physically - no result.
Please help

Woulld anybody out there be so kind and give me a hint what to do?

Many thanx,
jo

Last edited by jo.angel; 10-28-2006 at 03:57 PM.
 
Old 10-30-2006, 06:16 AM   #2
stress_junkie
Senior Member
 
Registered: Dec 2005
Location: Massachusetts, USA
Distribution: Ubuntu 10.04 and CentOS 5.5
Posts: 3,873

Rep: Reputation: 331Reputation: 331Reputation: 331Reputation: 331
You almost never have to use the command line to configure SuSE. You can log on as root and start YaST. Then you click on the hardware icon in the left column. Click on the sound card icon in the right hand column. This will start a wizard to configure your sound card.

I have always taken an additional step after the sound card is working. When I start KDE or Gnome I run the configuration utility. Then I find the section that controls the sound software. There is a check box on that page labeled "Start the sound daemon". I always disable this.

You may find that some sound applications work while others don't work. I don't bother trying to make some application work if another application that does the same thing already works. So for me I don't use Amarok because it doesn't produce sound for me. I can use XMMS and KCD player and numerous other sound applications. (Timidity, Firefox with Flash Player, etc.)
 
Old 10-30-2006, 08:37 AM   #3
jo.angel
LQ Newbie
 
Registered: Oct 2006
Distribution: Suse 10.1
Posts: 13

Original Poster
Rep: Reputation: 0
Thanks for taking some time to look into my problem
Quote:
Originally Posted by stress_junkie
You almost never have to use the command line to configure SuSE. You can log on as root and start YaST. Then you click on the hardware icon in the left column. Click on the sound card icon in the right hand column. This will start a wizard to configure your sound card.
I have spent hours to configure the sound card with yast - hardware - sound. Here you can play a test sound which will not happen...Funnily enough, I had the sound card working earlier with a previous installation.
Quote:
I have always taken an additional step after the sound card is working. When I start KDE or Gnome I run the configuration utility. Then I find the section that controls the sound software. There is a check box on that page labeled "Start the sound daemon". I always disable this.
I found the sound configuration in KDE, but I cant find the "sound daemon" box. Am I in the same configuration u r talkin about. In my configuration ("Configure KDE Control Module") I have options like "Enable the sound system" "Select the audio device = auto", "Full duplex" and more.
Quote:
You may find that some sound applications work while others don't work. I don't bother trying to make some application work if another application that does the same thing already works. So for me I don't use Amarok because it doesn't produce sound for me. I can use XMMS and KCD player and numerous other sound applications. (Timidity, Firefox with Flash Player, etc.)
When my soundcard worked, I noticed some devices function and some dont amarok seemd to be fine for me. But I cant get any sound at all, whatever application. Configuring my sound card, I can not play a test sound.
 
Old 10-30-2006, 09:54 AM   #4
stress_junkie
Senior Member
 
Registered: Dec 2005
Location: Massachusetts, USA
Distribution: Ubuntu 10.04 and CentOS 5.5
Posts: 3,873

Rep: Reputation: 331Reputation: 331Reputation: 331Reputation: 331
Quote:
Originally Posted by jo.angel
But I cant get any sound at all, whatever application. Configuring my sound card, I can not play a test sound.
The key here is the button in YaST for creating the test sound. Back in SuSE 9.1 I had a lot of trouble getting the sound card to work. I finally got it working by changing the number of the sound card in the YaST sound card configuration applet. It had been set up as sound card number zero. I changed it to sound card number one and it started working.

You should have the ALSA sound system start when Linux starts. Do not use the esound sound daemon. These services are configured in YaST. When you start YaST you click on the left hand column icon labeled "System". Then you click in the right hand side of the window on the icon labeled "System Services (Runlevel)". This will display a list of system services and it will say whether they are enabled or not. Find the esound service and click on the "Disable" button at the bottom of the screen. Then find the ALSA service and click on the "Enable" button at the bottom of the window. Then click the "Finish" button. The changes should take effect immediately but you may want to restart Linux just to be sure.

You can look in the /var/log/messages or /var/log/boot.msg files to see if ALSA and Esound are started. You want ALSA. You do not want Esound.

The configuration setting that I mentioned for KDE is found by starting kcontrol. This is also called "Personal Settings" in the KDE start menu. Then you click on "Sound and Multimedia". Then you click on "Sound System". You will see the right hand side of the window has two tabs. The first one is labeled "General". This tab has a box at the top left side labeled "Enable the sound system". This is in KDE 3.5.5 but I also used this setting in previous versions of KDE. Make sure that the box is cleared. Then click on the Apply button at the bottom of the page. Close the KDE configuration utility. The change should take place immediately but you may want to restart the X server by pressing the control-alt-backspace keys simultaneously or by restarting Linux.

Last edited by stress_junkie; 10-30-2006 at 10:08 AM.
 
Old 10-30-2006, 05:08 PM   #5
jo.angel
LQ Newbie
 
Registered: Oct 2006
Distribution: Suse 10.1
Posts: 13

Original Poster
Rep: Reputation: 0
Quote:
The key here is the button in YaST for creating the test sound. Back in SuSE 9.1 I had a lot of trouble getting the sound card to work. I finally got it working by changing the number of the sound card in the YaST sound card configuration applet. It had been set up as sound card number zero. I changed it to sound card number one and it started working.
I could not find a way to change this number...

Quote:
You should have the ALSA sound system start when Linux starts. Do not use the esound sound daemon. These services are configured in YaST. When you start YaST you click on the left hand column icon labeled "System". Then you click in the right hand side of the window on the icon labeled "System Services (Runlevel)". This will display a list of system services and it will say whether they are enabled or not. Find the esound service and click on the "Disable" button at the bottom of the screen. Then find the ALSA service and click on the "Enable" button at the bottom of the window. Then click the "Finish" button. The changes should take effect immediately but you may want to restart Linux just to be sure.
ALSA was already enabled (Yes). Esound was "No" (disabled.

You can look in the /var/log/messages or /var/log/boot.msg files to see if ALSA and Esound are started. You want ALSA. You do not want Esound.

This is the only reference to ALSA, I could find with "Search document in/var/log/boot.msg
Quote:
<4>via_ircc: module not supported by Novell, setting U taint flag.
<6>agpgart: Detected VIA P4M266x/P4N266 chipset
<6>agpgart: AGP aperture is 128M @ 0xd0000000
<6>via82xx: Assuming DXS channels with 48k fixed sample rate.
<6> Please try dxs_support=5 option
<6> and report if it works on your machine.
<6> For more details, read ALSA-Configuration.txt.
As well I can find in /var/log/boot.msg:
Quote:
Inspecting /boot/System.map-2.6.16.21-0.25-default
Loaded 21308 symbols from /boot/System.map-2.6.16.21-0.25-default.
Symbols match kernel version 2.6.16.
No module symbols loaded - kernel modules not enabled.
You wrote:
Quote:
The configuration setting that I mentioned for KDE is found by starting kcontrol. This is also called "Personal Settings" in the KDE start menu. Then you click on "Sound and Multimedia". Then you click on "Sound System". You will see the right hand side of the window has two tabs. The first one is labeled "General". This tab has a box at the top left side labeled "Enable the sound system". This is in KDE 3.5.5 but I also used this setting in previous versions of KDE. Make sure that the box is cleared. Then click on the Apply button at the bottom of the page. Close the KDE configuration utility. The change should take place immediately but you may want to restart the X server by pressing the control-alt-backspace keys simultaneously or by restarting Linux.
The box was not cleared , it is now...
still no change...

May the problem be a conflict of sound cards?

I have a "Builtin" sound card VIA AC97. If configured, this sound card "jumps" (hangs), when I play the test sound. It never worked properly. I then added a PCI sound card CMI8738/C3DX . When configuring the cards and changing around, the PCI card sometimes gets assigned the configuration of the "builtin". If I play the test sound for VIAAC97 it hangs, as I said, but when I then play the test sound for my PCI card, the "jumping" stops, and the test sound is played properly to the end.

And here is some more info:


Quote:
Soundcard: Genius soundmaker 5.1 - CMI87 38/C3DX PC Audio Device

#
Quote:
modinfo soundcore
filename: /lib/modules/2.6.16.21-0.25-smp/kernel/sound/soundcore.ko
description: Core sound module
author: Alan Cox
license: GPL
alias: char-major-14-*
vermagic: 2.6.16.21-0.25-smp SMP 586 REGPARM gcc-4.1
supported: yes
depends:
srcversion: DD426F1CCA2CC5F060F6F92
And even motre info:
Quote:
YAST
"kernel module snd-fm801 for sound support could not be loaded. This can be caused by incorrect module parameters including invalid IO or IRQ parameters."
Quote:
KDE (configuration) gives me the following info:
(...)audio devices, synth devices, midi devices, mixer devices...
NOT ENABLED IN CONFIG
I know this is pretty much stuff, but maybe you can find a hint where the problem is. By the way, as well I disabled the VIA card in BIOS, rebooted, enabled it back, but still no success.
Thanks for taking the trouble and brain effort mate, I appreciate it. cheeers
 
Old 11-15-2006, 11:23 AM   #6
stress_junkie
Senior Member
 
Registered: Dec 2005
Location: Massachusetts, USA
Distribution: Ubuntu 10.04 and CentOS 5.5
Posts: 3,873

Rep: Reputation: 331Reputation: 331Reputation: 331Reputation: 331
I just remembered. I used FreqTweak to change the sound card number from 0 to 1.
 
Old 11-16-2006, 10:52 AM   #7
jo.angel
LQ Newbie
 
Registered: Oct 2006
Distribution: Suse 10.1
Posts: 13

Original Poster
Rep: Reputation: 0
Cheeers

Quote:
Originally Posted by stress_junkie
I just remembered. I used FreqTweak to change the sound card number from 0 to 1.
Thanks, I will try it....
...next time
cause I have converted to UBUNTU now and I am very pleased with it.
I will check Freq Tweak anyway.

All the best 4 u,

J
 
  


Reply

Tags
kernel, module, packman, suse


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to enable sound(MP3) in Suse 10.0 raxxal Suse/Novell 1 11-05-2005 07:37 AM
enable module support in RH9 realized Linux - Newbie 1 10-12-2004 09:18 AM
Compiling a Module into bare.i to Enable RAID Support EnigmaPhoenix Slackware 4 05-27-2004 12:14 AM
Enable module support help! robson8112 Linux - General 1 02-29-2004 12:18 PM
Where do I enable ide-scsi module in kernel config? TheOneAndOnlySM Slackware 3 12-12-2003 09:43 PM


All times are GMT -5. The time now is 04:11 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration