LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 02-18-2009, 10:42 AM   #1
cygan
LQ Newbie
 
Registered: Feb 2009
Posts: 9

Rep: Reputation: 0
How to edit "/etc/udev/rules.d/40-basic-permissions.rules" file


Hi,

Just dual boot my Acer Aspire 5551 laptop with Ubuntu 8.10.

Have encountered some problem when trying to get by Brother MFC-260C to perform scanning. I've managed to get it to print. From the Brother web site, it was mentioned that I would need to edit the 40-basic-permissions.rules file and change "0664" to "0666". However, the text editor does not allow me to save the file. Any advise.

Also, I also encounter problem accessing a particular web site : www.ura.gov.sg
Not sure if i have missed out add-on to my firefox browser. Pls kindly advise.

Thanks a million,
cygan
 
Old 02-18-2009, 11:27 AM   #2
MensaWater
Guru
 
Registered: May 2005
Location: Atlanta Georgia USA
Distribution: Redhat (RHEL), CentOS, Fedora, Debian, FreeBSD, HP-UX, Solaris, SCO
Posts: 6,028
Blog Entries: 5

Rep: Reputation: 791Reputation: 791Reputation: 791Reputation: 791Reputation: 791Reputation: 791Reputation: 791
The directory and the file (if it already exists) are owned by root. If you can't save your edit then it means you're not doing the edit as root.
 
Old 02-18-2009, 01:17 PM   #3
Udi
Member
 
Registered: Jan 2009
Posts: 165

Rep: Reputation: 44
When you browse to the directory where that file is, don't just open the directory by double-clicking on it. Instead, right-click on the directory (rules.d) and choose "open as root". Then open the file in a text editor and it will run as root and you can save your changes.
 
Old 02-18-2009, 01:22 PM   #4
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,036

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
Quote:
Also, I also encounter problem accessing a particular web site : www.ura.gov.sg
Not sure if i have missed out add-on to my firefox browser. Pls kindly advise.
Well, this was a difficult one to track down, but I was sure I had read something like this recently, but it took me an age to track down the thread.

There's nothing wrong with your firefox, there's something wrong with their firewall.

Here's the relevant thread:
http://www.linuxquestions.org/questi...47#post3442547

The solution is in post #6, and it works.

At first I couldn't load the link you posted, but after giving the command
Code:
sysctl -w net.ipv4.tcp_window_scaling=0
(and you'll need to be root to do this) the site loaded fine.

To become root on an ubuntu system, in a terminal, issue the command
Code:
sudo -i
and give your login password when asked. Then give the comand as above. Please check your spelling / copying very carefully before you press <RETURN>

While I'm here, to edit that file for your printer, you need to give the following commands in a terminal:
Become root (as above). Notice how your terminal prompt has changed.
Back up the original file:
Code:
cp  /etc/udev/rules.d/40-basic-permissions.rules  /etc/udev/rules.d/40-basic-permissions.rules.BAK
Open the file with the nano editor:
Code:
nano  /etc/udev/rules.d/40-basic-permissions.rules
Edit the file.
Save the changes with "WriteOut" which is <CTRL><o> and then "Exit" which is <CTRL><x>
You'll need to restart udev so the changes are noticed:
Code:
/etc/init.d/udev  restart
Close the terminal.
Plug your printer in and see if you can configure it.

Welcome to LQ!
 
Old 02-18-2009, 03:44 PM   #5
SuperDude123
Member
 
Registered: Nov 2008
Posts: 158

Rep: Reputation: 30
if your not logged in as root, you may need to do

sudo nano "file" OR use sudo vi "file", except don't write the ".

In nano, to save and exit, do Control + X, then you will be asked if you want to save y(yes) or n(no), then what to save the file as (just hit enter to keep the same name) and then your done
 
Old 02-19-2009, 12:50 AM   #6
cygan
LQ Newbie
 
Registered: Feb 2009
Posts: 9

Original Poster
Rep: Reputation: 0
Smile Problem Solved

Dear friends,

Your advices are really wonderful. All my stated problems have been solved! Thank a million!!!!

Just to understand a bit more, what does the command "sysctl -w net.ipv4.tcp_window_scaling=0" do?

Cheers,
cygan
 
Old 02-19-2009, 12:58 AM   #7
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,628

Rep: Reputation: Disabled
The above command will turn off the tcp window scaling. For more info on what is tcp window scaling visit
http://en.wikipedia.org/wiki/TCP_window_scale_option
 
Old 03-04-2009, 03:45 AM   #8
cygan
LQ Newbie
 
Registered: Feb 2009
Posts: 9

Original Poster
Rep: Reputation: 0
Dear Friends,

Its me again. After accessing the site (www.ura.gov.sg) on several different occasion, I realise that I need to key in the command / code (sysctl -w net.ipv4.tcp_window_scaling=0) every time I re-boot/power up my computer. Is there a way to set this as default?

There is also another web site that I recently encounter problem accessing : www.myhomepage.singtel.com/
The code (sysctl -w net.ipv4.tcp_window_scaling=0) did not help. Any advise on what is missing?

Thanks,
cygan
 
Old 03-04-2009, 03:52 AM   #9
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,628

Rep: Reputation: Disabled
You can do that by setting off scaling in /etc/sysctl.conf file.
 
Old 03-09-2009, 06:12 AM   #10
cygan
LQ Newbie
 
Registered: Feb 2009
Posts: 9

Original Poster
Rep: Reputation: 0
Hi,

Can someone advise on another web site that I recently encounter problem accessing : www.myhomepage.singtel.com/
The code (sysctl -w net.ipv4.tcp_window_scaling=0) did not help. Any advise on what is missing?

Thanks in advance,
cygan
 
Old 03-09-2009, 06:19 AM   #11
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,036

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
That page loads perfectly. Maybe the site was down.
 
Old 03-09-2009, 06:22 AM   #12
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,628

Rep: Reputation: Disabled
Yeah loads for me too.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
what is Special number with file in /etc/udev/rules.d raj_hcl1986@rediffma Linux - Newbie 2 10-20-2008 11:44 AM
cat: /etc/udev/rules.d/70-persistent-net.rules: No such file or directory rcg1984 Linux From Scratch 2 09-17-2008 08:02 AM
Using udev rules to modify floppy permissions Woodsman Slackware 3 08-22-2008 03:46 AM
LXer: N. Dakota Judge rules that "host -l" command constitutes hacking LXer Syndicated Linux News 0 01-19-2008 03:20 AM
need help fixing my udev rules or ivman rules hedpe Linux - Hardware 2 03-18-2006 11:07 AM


All times are GMT -5. The time now is 11:15 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration