LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 05-01-2003, 02:04 AM   #1
icy-flame
LQ Newbie
 
Registered: May 2003
Distribution: RH9
Posts: 9

Rep: Reputation: 0
How to disable that annoying BEEP?


newbie here... just got RH9 up and running.

The system warning/alarm BEEP is too loud and tooooo anoying, I suppose I am not the only one who think in this way...

So, please, if anyone knows, could you please tell me how to disable it?

(Dont ask me to unplug my sound card nor mute the sound, I still want my music to play.)

Thanks
 
Old 05-01-2003, 02:08 AM   #2
soothsayer
Member
 
Registered: Apr 2003
Location: Tampabay Area
Distribution: redhat 6.2-9
Posts: 33

Rep: Reputation: 15
Are you talking about the pc speaker beep? If so, open your case, and unplug the PC speaker from the mother board, it won't do anything else to your system other then get rid of the starting beep. You can still play your music, and your sound will still function properly.

The system will give beep codes to let you know if it is working or not. There are so many beeps for video problems, memory, and so on. You don't need the pc speaker until you have a problem, then just plug it back in for an easier time diagnosing.
 
Old 05-01-2003, 02:12 AM   #3
icy-flame
LQ Newbie
 
Registered: May 2003
Distribution: RH9
Posts: 9

Original Poster
Rep: Reputation: 0
too bad that I am

What can I say.. I am using a laptop...

So even I am brave enough to disassemble my baby, I hold no chance to get rid of that BEEP while keeping my music.

Was wondering if there is any software approach to this problem.

Hummm.. since Micro$oft has this feature, I believe Linux has too.
 
Old 05-01-2003, 02:18 AM   #4
soothsayer
Member
 
Registered: Apr 2003
Location: Tampabay Area
Distribution: redhat 6.2-9
Posts: 33

Rep: Reputation: 15
try going into the bios and look for a feature to disable the beeps.

some laptops have such a feature, some don't.
 
Old 05-01-2003, 02:32 AM   #5
icy-flame
LQ Newbie
 
Registered: May 2003
Distribution: RH9
Posts: 9

Original Poster
Rep: Reputation: 0
it that suggesting disabling the BEEP is not in RH's function list?

thanks
 
Old 05-01-2003, 03:01 AM   #6
nakkaya
Guru
 
Registered: Jan 2003
Location: Turkey&USA
Distribution: Emacs and linux is its device driver(Slackware,redhat)
Posts: 1,398

Rep: Reputation: 45
i dont think unpluging the cable will work for laptop cause sound comes from normal speakers not like a pc oc have a extra speaker for this matter
 
Old 05-01-2003, 03:04 AM   #7
moses
Senior Member
 
Registered: Sep 2002
Location: Arizona, US, Earth
Distribution: Slackware, (Non-Linux: Solaris 7,8,9; OSX; BeOS)
Posts: 1,152

Rep: Reputation: 46
It really depends on the beep you are talking about. If it's the beep when the system boots, turn the volume down until you need to hear things. If it's a problem while you are working, and you are using a desktop environment like KDE or Gnome, or just about any window manager, you can usually disable the warning beeps within the configuration tool for that WM/DE. If you are using the console, you can usually disable the beep by putting the following in your setup scripts: "set nobeep".
 
Old 05-01-2003, 03:25 AM   #8
icy-flame
LQ Newbie
 
Registered: May 2003
Distribution: RH9
Posts: 9

Original Poster
Rep: Reputation: 0
After a long saerch... found something in the KDE control center.

there are probably 2 ways of doing it...

Ctrl Center => Regional & Accessibility => Accessibility => Bell => untick use system bell

or

Ctrl Center => Sound & Multimedia => System bell => use system bell instead of system notification (Dont forget to turn the volume to 0%)

the second one is a trick... but working.

hope this helps for anyone who uses KDE and annoyed by that BEEEP.

Thank you every one who gave advice above.

RedHat 9
KDE 3.1-10
 
Old 05-02-2003, 04:11 PM   #9
lectraplayer
Member
 
Registered: Mar 2003
Location: a little west of Birmingham, AL, USA.
Distribution: SuSE 10
Posts: 915

Rep: Reputation: 30
Your only choice for disabling the beap (unless you can change code and fix it) if your CMOS don't have it is to unsolder the beaper from inside your laptop. This is dangerous and is not advised, but if you pull it off, you just won't have any beeps unless you're under KDE or something. You can't take the system bell out of your kernel? Maybe you can change it under Kontrol Center... Dunno though...
 
Old 10-17-2006, 07:04 AM   #10
rbp
LQ Newbie
 
Registered: Feb 2006
Location: Melbourne, Australia
Distribution: Crunchbang
Posts: 6

Rep: Reputation: 0
motherboards, soldering, removing cables - WTF??!
use xset b off
 
Old 04-18-2007, 10:01 AM   #11
mattiatomasoni
LQ Newbie
 
Registered: Apr 2007
Posts: 3

Rep: Reputation: 0
xset works for the Xserver, but what if I am working in text mode?
My slackware has the command line shut-down; it BEEEPS very loudly and xset won't obviusly work there!
Thanx
 
Old 04-18-2007, 09:02 PM   #12
IBall
Senior Member
 
Registered: Nov 2003
Location: Perth, Western Australia
Distribution: Ubuntu, Debian, Various using VMWare
Posts: 2,088

Rep: Reputation: 61
For Slackware, I believe that you can edit the file /etc/inputrc and find the following line
Code:
set bell-style audible
and chenge the audible to none.

--Ian
 
Old 04-19-2007, 09:09 AM   #13
mattiatomasoni
LQ Newbie
 
Registered: Apr 2007
Posts: 3

Rep: Reputation: 0
the noise is (almost!) gone

...almost!
All the beeps are gone except the reboot/turn-off one!

Somebody suggested me setterm -blength 0. it works but its effect is lost at shut-down.
Somethiong like a script??? somewhere???
Closer to the final solution, though...
Thanks everybody
 
Old 04-25-2007, 08:44 PM   #14
lectraplayer
Member
 
Registered: Mar 2003
Location: a little west of Birmingham, AL, USA.
Distribution: SuSE 10
Posts: 915

Rep: Reputation: 30
A thought just occurred to me...

You said it's a laptop, didn't you?

Many laptops (except the Stone-Aged ones) have a Fn+F? key combination that handles the PC-speaker volume. Maybe you can beat that key combination a few times, and each time, you should hear a beep. Do it until you get the beep the volume you like. I've often seen this on an F4 or F6 key, and it will either say "speaker" or have a symbol of a speaker somewhere on the key (sometimes the front side), and a lot of times the label will be blue in color. Your laptop often will remember this setting between boot to boot unless you change it in CMOS (and often there is no option to do that, so it usually just remembers the last volume you had it at). I've seen this option in CMOS before!
 
Old 04-26-2007, 09:51 AM   #15
mattiatomasoni
LQ Newbie
 
Registered: Apr 2007
Posts: 3

Rep: Reputation: 0
Yap, I do have the Fn+Fx-combination,
but it doesn't seems to be recognized under (slackware) linux at all!
---!!!---
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to turn off the annoying beep puzz_1 Linux - Hardware 3 02-22-2009 12:46 AM
That annoying beep zchoyt Linux - Newbie 6 01-05-2007 08:38 PM
Incredibly annoying pc speaker beep on error in MySql in Windows XP nazdrowie Programming 2 07-15-2005 01:26 AM
Disable the console beep? csvke Linux - General 6 03-01-2004 04:00 AM
Annoying beep in slackware Havox Slackware 2 02-04-2003 11:37 PM


All times are GMT -5. The time now is 04:04 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration