LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-20-2003, 08:33 PM   #1
mairul
Member
 
Registered: Sep 2003
Location: In front of my LAN
Distribution: Redhat
Posts: 82

Rep: Reputation: 15
Unhappy How to disable Serial Line IP ( sl0 )


I am using Debian GNU Linux 3.0 and I don't have any serial card at my PC....but it detects an serial card ( I think ) "sl0" and set an IP for it...after disabling it...when I restart it detects the serial card ( sl0 ) again..and set an IP for it ....which IP I have set to my eth0 also....How can I disable it permanently.....

Thanks in Advance....
 
Old 12-20-2003, 09:10 PM   #2
2damncommon
Senior Member
 
Registered: Feb 2003
Location: Calif, USA
Distribution: Debian Wheezy
Posts: 2,872

Rep: Reputation: 88
Just a guess. Is Linux detecting a modem?
Modems can be on any of the serial ports-/dev/ttyS* (*=0 through 3)
Can you post the lines from the "ifconfig" command that refer to this device?
 
Old 12-20-2003, 09:22 PM   #3
mairul
Member
 
Registered: Sep 2003
Location: In front of my LAN
Distribution: Redhat
Posts: 82

Original Poster
Rep: Reputation: 15
I do have a modem..and it is external...zyxel modem...

But I don't think it is for modem...cause at another PC where I don't have any modem...there also I saw the configuration for sl0....

Is serial Line IP ( sl0 ) automatically installs with debian...

cause I install redhat again...but it was not detecting any serial card...

anyway my ifconfig command shows me.....

debian:/# ifconfig
eth0 Link encap:Ethernet HWaddr 00:00:21:14:51:7B
inet addr:192.168.0.2 Bcast:192.168.0.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:276 errors:0 dropped:0 overruns:0 frame:0
TX packets:1492 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:40627 (39.6 KiB) TX bytes:96994 (94.7 KiB)
Interrupt:11 Base address:0xec00

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:3924 Metric:1
RX packets:749 errors:0 dropped:0 overruns:0 frame:0
TX packets:749 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:58535 (57.1 KiB) TX bytes:58535 (57.1 KiB)

sl0 Link encap:Serial Line IP
inet addr:192.168.0.2 P-t-P:192.168.0.3 Mask:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:10
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
 
Old 12-20-2003, 09:58 PM   #4
2damncommon
Senior Member
 
Registered: Feb 2003
Location: Calif, USA
Distribution: Debian Wheezy
Posts: 2,872

Rep: Reputation: 88
Is the "sl0" device listed by "ifconfig" if you boot up with the power off on the modem?
 
Old 12-20-2003, 11:25 PM   #5
mairul
Member
 
Registered: Sep 2003
Location: In front of my LAN
Distribution: Redhat
Posts: 82

Original Poster
Rep: Reputation: 15
Yes..Modem is always off.....

but sl0 is listed by ifconfig command....

Last edited by mairul; 12-20-2003 at 11:27 PM.
 
Old 12-20-2003, 11:52 PM   #6
2damncommon
Senior Member
 
Registered: Feb 2003
Location: Calif, USA
Distribution: Debian Wheezy
Posts: 2,872

Rep: Reputation: 88
That rules out the easy answers.
I am assuming there is nothing else plugged into a serial/com port. No other cards or external devices that could be causing this?
What version of Debian? The little I have worked with my 3.0 I always find COM1 refered to as /dev/ttyS0. It was only in a Google search that I saw COM1 refered to as sl0.
Does "ifdown /dev/sl0(or ttyS0)" shut it down?
 
Old 12-21-2003, 01:02 AM   #7
mairul
Member
 
Registered: Sep 2003
Location: In front of my LAN
Distribution: Redhat
Posts: 82

Original Poster
Rep: Reputation: 15
when I give ifdown /dev/sl0 command......it shows......
ifdown: interface /dev/sl0 not configured

when I give ifdown /dev/ttys0 command.....it shows.....
ifdown: interface /dev/ttys0 not configured

I am using Debian GNU Linux 3.0

I think my modem is not creating the problem.....I assume that debian "by default" detects an SL ( Serial Line ) IP and sets an IP for it...which is set to eth0 also....

How can I disable it permanently.....to detects any serial card..and get any IP against the serial card....

I can give "ifconfig sl0 down" command......then it is disabled.....but after reboot.....it comes again...

I just want to disable the sl0 permanently.....
 
Old 12-21-2003, 06:02 AM   #8
2damncommon
Senior Member
 
Registered: Feb 2003
Location: Calif, USA
Distribution: Debian Wheezy
Posts: 2,872

Rep: Reputation: 88
A Google search shows you're not the only one with this problem.
Here is "sl0 problem" with a reply (towards the end of the page) and one post without a reply.
I am not familar with "diald". If it is running on your system "man diald" should give you some info on it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to disable beep in command line Backstander Linux - General 6 09-12-2004 02:11 PM
How to disable serial line eaglegst Debian 2 05-28-2004 03:10 AM
Disable Hardware Flow Control at serial port DJ_Cyberdance Linux - Hardware 0 11-27-2003 02:00 AM
Serial line for headless server jvannucci Linux - General 1 06-21-2003 07:01 PM
serial line is not 8 bit clean thunderrooster Linux - General 0 01-31-2002 08:17 AM


All times are GMT -5. The time now is 04:00 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration