LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-25-2013, 02:16 PM   #1
jearl28
LQ Newbie
 
Registered: Apr 2013
Posts: 4

Rep: Reputation: Disabled
How to disable screen blank / screen saver on Red Hat Enterprise


Hello:

I've got a problem here that has been driving me crazy.

We recently updated our Red Hat Linux Enterprise OS from version 4 to version 5. We did all the updates, and it is now stamped version 5.9. We are running this on a Dell PowerEdge 830 server.

uname -r shows: 2.6.18-348.3.1.el5PAE

We are running the GNOME desktop Version 2.16.0

Since the install, the screen keeps blanking after a couple of hours. This is frustrating, as we use this as an alarm monitoring station. We constantly look at alarms, and never want the screen to blank.

Here is what I've tried to keep this from happening:

1) Click on System->Preferences->Screensaver and make sure the "Activate screensaver when computer is idle" is UNCHECKED

2) In my ~/.xinitrc, I've got 'setterm -blank 0 -powersave off -powerdown 0'. Also have 'xset s off' in same file.

3) I put the follow lines in /etc/X11/xorg.conf:

Section "ServerFlags"
Option "blank time" "0"
Option "standby time" "0"
Option "suspend time" "0"
Option "off time" "0"
Option "dpms" "false"
EndSection

Even after all this, it STILL blanks the screen after a couple of hours. I have not timed the exact duration. I don't know what else to try.

I remember having a program that I ran on an MS Windows machine that simulated the SHIFT key press every minute that kept screen savers from activating. But I don't have such a program on Red Hat.

It doesn't appear to be the screen saver. It appears to be more of a power save thing. I don't think it is the monitor, as I can't find anything in the monitor set up that addresses this. And the old version of Red Hat didn't have this issue.

Any help/ideas would be greatly appreciated.
 
Old 04-25-2013, 03:50 PM   #2
yowi
Member
 
Registered: Dec 2002
Location: Au
Distribution: Debian
Posts: 209

Rep: Reputation: 54
try 'xset -dpms'
 
Old 04-25-2013, 08:57 PM   #3
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.8, Centos 5.10
Posts: 17,240

Rep: Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324
I'm curious why you wouldn't go to v6.4 ie the latest? V5.x is getting old.
Also, when you say 'updated', I hope you mean 'replaced as fresh install', as RH does not support in-place upgrades across major versions https://access.redhat.com/site/docum...ted_Notes.html
 
Old 04-25-2013, 11:54 PM   #4
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,825

Rep: Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408
that is set for every user in the gnome preferences

for each user
from the gnome desktop
/System/Preferences/Screensaver

now if one of the ss's are running uncheck the checkbox
"Activate the screensaver after the computer is idle for..."

for the "black screen"
click on the "powerManager" button
under "On AC power"
select "never" for both

and if that dose not work ( in ScientificLinux 6.4 it dose not any more -- it did in 5.9 )

install gconf-editor
-- not installed by default
Code:
su -
yum install gconf-editor
then run it as root
Code:
su -
gconf-editor
under the "Apps" on the left
select "gnome-screensaver"
and uncheck " idle_Activation_Enabled"
or set "Idle_Delay" to say 60 min or 360 min.
 
1 members found this post helpful.
Old 05-01-2013, 10:27 AM   #5
jearl28
LQ Newbie
 
Registered: Apr 2013
Posts: 4

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by chrism01 View Post
I'm curious why you wouldn't go to v6.4 ie the latest? V5.x is getting old.
Also, when you say 'updated', I hope you mean 'replaced as fresh install', as RH does not support in-place upgrades across major versions https://access.redhat.com/site/docum...ted_Notes.html
Chris:

We just upgraded from v4 to v5 (not my choice, I have to do what management decides, they weren't ready to go to v6 yet).

v5 was acceptable as RH still supports it. We did not go to v6 because the custom software we run hasn't been tested on v6 yet.

When I say "updated", I just mean that we installed v5, then ran the Package Updater to make sure we had the "latest" of everything.
 
Old 05-01-2013, 10:28 AM   #6
jearl28
LQ Newbie
 
Registered: Apr 2013
Posts: 4

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by yowi View Post
try 'xset -dpms'
yowi:

Thanks! I added your command above to my ~/.initrc file. I'll let you know if it works. I assume I have to log out and back in again afterwards?
 
Old 05-01-2013, 10:41 AM   #7
jearl28
LQ Newbie
 
Registered: Apr 2013
Posts: 4

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by John VV View Post
that is set for every user in the gnome preferences

for each user
from the gnome desktop
/System/Preferences/Screensaver

I've already done this, as I said in my original post.

now if one of the ss's are running uncheck the checkbox
"Activate the screensaver after the computer is idle for..."

for the "black screen"
click on the "powerManager" button
under "On AC power"
select "never" for both

Where is this "powerManager" button? I don't see it on the System->Preferences->Screen Saver screen.

and if that dose not work ( in ScientificLinux 6.4 it dose not any more -- it did in 5.9 )

install gconf-editor
-- not installed by default
Code:
su -
yum install gconf-editor
then run it as root
Code:
su -
gconf-editor
under the "Apps" on the left
select "gnome-screensaver"
and uncheck " idle_Activation_Enabled"
or set "Idle_Delay" to say 60 min or 360 min.
I'm unable to install this, as yum is complaining that my Python API version doesn't match the module struct version. Yet another thing to check.
 
Old 05-01-2013, 12:39 PM   #8
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,825

Rep: Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408
Quote:
i'm unable to install this, as yum is complaining that my Python API version doesn't match the module struct version. Yet another thing to check.
if the version of python dose NOT match what is in the RHN update ( or base repo)
yum and part of Gnome -( as in a lot ) will not work .

yum and Gnome BOTH depend on that VERY specific version of python

now
you can install a second NEWER version of python " side by side" with the required version

with a busted yum you will have to manually replace the mismatched version of python with the correct version using " rpm and -force "

and for the older 5.9 that will be "python-2.4.3" from the RHN base repo
manually grab it from RHN and force reinstall it with rpm

then if you need the current python 2.7 or Python 3.3
you can install it side by side with the "must use" 2.4 version
 
Old 05-03-2013, 11:41 AM   #9
yowi
Member
 
Registered: Dec 2002
Location: Au
Distribution: Debian
Posts: 209

Rep: Reputation: 54
Quote:
Originally Posted by jearl28 View Post
yowi:

Thanks! I added your command above to my ~/.initrc file. I'll let you know if it works. I assume I have to log out and back in again afterwards?
I'm not sure, but you may have to enable dpms in your xorg.conf. Yeah, enable it to turn it off, there's logic in there somewhere.

"xset -q" gives you status info and check "man xorg.conf", there's more dpms options.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Red Hat 5 - Default Screen Saver for All Users with Password required mccartjd Linux - Security 1 02-24-2010 02:43 PM
Blank screen after Red Hat 9 install witebuddha Red Hat 2 11-26-2004 05:43 PM
blank screen on red hat 9 startup snoop24 Linux - Software 1 09-15-2003 11:56 AM
red hat 7.2 screen blank pfunck123 Linux - General 1 02-20-2003 11:54 AM
red hat 6.2 and no screen saver thescribe7 Linux - General 2 09-30-2000 12:12 AM


All times are GMT -5. The time now is 11:02 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration