LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 12-19-2006, 06:29 AM   #1
jjamesis
LQ Newbie
 
Registered: Nov 2006
Posts: 12

Rep: Reputation: 0
How to disable power management and screen saver?


Hi people

I'm doing some project work for school and help would be very very much apperciated.

I'm got a box running Fedora 5 with gnome as the desktop manager. I written some java code which will start vlc and play videos from other machines.

This box just plays videos (no keyboard or mouse present) so after a while the screen will go to screen saver. Its pretty important I get this to stop. What i've done is diabled apic in setup -> services. and disable screensaver in system -> preferences.
The screensaver stops but the monitor just goes blank, until I put in a mouse and move it around.

Is this a power management issue or a screen saver issue? Can anybody please help because I gotta get this done before my deadline!?!

Thanks
jjamesis
 
Old 12-19-2006, 06:59 AM   #2
nx5000
Senior Member
 
Registered: Sep 2005
Location: Out
Posts: 3,307

Rep: Reputation: 53
Could be DPMS:
Whats the result of
xset -q

http://www.linuxquestions.org/questi...highlight=dpms

And this for making it permanent on reboot:
http://www.linuxquestions.org/questi...highlight=dpms
 
Old 12-19-2006, 08:14 AM   #3
jjamesis
LQ Newbie
 
Registered: Nov 2006
Posts: 12

Original Poster
Rep: Reputation: 0
Thanks for the reply.

I had Option "DPMS" "True" inside my xorg.conf file and changed to false. It still didn't help though. After about 10 mins the minitor will blank until I move the mouse.

I've played around with a view BIOS settings so I think its a linux screensaver problem. Do you have anymore ideas?
 
Old 12-19-2006, 08:17 AM   #4
nx5000
Senior Member
 
Registered: Sep 2005
Location: Out
Posts: 3,307

Rep: Reputation: 53
Quote:
Originally Posted by jjamesis
Thanks for the reply.

I had Option "DPMS" "True" inside my xorg.conf file and changed to false. It still didn't help though. After about 10 mins the minitor will blank until I move the mouse.
You did restart X Window to make it take effect? Just to be sure..
Quote:
I've played around with a view BIOS settings so I think its a linux screensaver problem. Do you have anymore ideas?
Well, if gnome or kde has the screensaver disabled then no, the screensaver will not turn on. So its not a "linux screensaver" problem if its disabled in your Window Manager.

Could be a BIOS thing but then you have to look in your bios settings.
 
Old 12-19-2006, 08:25 AM   #5
jjamesis
LQ Newbie
 
Registered: Nov 2006
Posts: 12

Original Poster
Rep: Reputation: 0
Here is the output of the xset -q command.

Keyboard Control:
auto repeat: on key click percent: 0 LED mask: 00000002
auto repeat delay: 500 repeat rate: 30
auto repeating keys: 00ffffffdffffbbf
fadfffdfffdfe5ef
ffffffffffffffff
ffffffffffffffff
bell percent: 50 bell pitch: 400 bell duration: 100

Pointer Control:
acceleration: 2/1 threshold: 4

Screen Saver:
prefer blanking: yes allow exposures: yes
timeout: 0 cycle: 0

Colors:
default colormap: 0x20 BlackPixel: 0 WhitePixel: 16777215

Font Path:
/usr/share/X11/fonts/misc/,/usr/share/X11/fonts/TTF/,/usr/share/X11/fonts/Type1/,/usr/share/X11/fonts/100dpi/,/usr/share/X11/fonts/75dpi/

Bug Mode: compatibility mode is disabled

DPMS (Energy Star):
Standby: 1200 Suspend: 1800 Off: 2400
DPMS is Disabled

Font cache:
Server does not have the FontCache Extension

File paths:
Config file: /etc/X11/xorg.conf
Modules path: /usr/lib/xorg/modules
Log file: /var/log/Xorg.0.log
 
Old 12-19-2006, 08:39 AM   #6
nx5000
Senior Member
 
Registered: Sep 2005
Location: Out
Posts: 3,307

Rep: Reputation: 53
Ooops you were right, I had forgotten about the X screensaver which is something seperate from WM screensaver. sorry.

xset s noblank
xset s off

?

I'm running short on ideas now

Last edited by nx5000; 12-19-2006 at 08:41 AM.
 
Old 12-19-2006, 08:52 AM   #7
jjamesis
LQ Newbie
 
Registered: Nov 2006
Posts: 12

Original Poster
Rep: Reputation: 0
I typed in xset s noblank and then xset -q to make sure it did something.

This is what I got

Keyboard Control:
auto repeat: on key click percent: 0 LED mask: 00000002
auto repeat delay: 500 repeat rate: 30
auto repeating keys: 00ffffffdffffbbf
fadfffdfffdfe5ef
ffffffffffffffff
ffffffffffffffff
bell percent: 50 bell pitch: 400 bell duration: 100
Pointer Control:
acceleration: 2/1 threshold: 4
Screen Saver:
prefer blanking: no allow exposures: yes
timeout: 0 cycle: 0
Colors:
default colormap: 0x20 BlackPixel: 0 WhitePixel: 16777215
Font Path:
/usr/share/X11/fonts/misc/,/usr/share/X11/fonts/TTF/,/usr/share/X11/fonts/Type1/,/usr/share/X11/fonts/100dpi/,/usr/share/X11/fonts/75dpi/
Bug Mode: compatibility mode is disabled
DPMS (Energy Star):
Standby: 1200 Suspend: 1800 Off: 2400
DPMS is Disabled
Font cache:
Server does not have the FontCache Extension
File paths:
Config file: /etc/X11/xorg.conf
Modules path: /usr/lib/xorg/modules
Log file: /var/log/Xorg.0.log

Will I lose these changes when the machine is reboot though? Is there any way to make these changes permanent.

Thanks for all the help
mucho gracias
 
Old 12-19-2006, 09:08 AM   #8
nx5000
Senior Member
 
Registered: Sep 2005
Location: Out
Posts: 3,307

Rep: Reputation: 53
You should put the lines in
~/.xsession

or
~/.Xsession

(can't remember for gnome, I think its Xsession)
 
Old 12-19-2006, 10:11 AM   #9
jjamesis
LQ Newbie
 
Registered: Nov 2006
Posts: 12

Original Poster
Rep: Reputation: 0
bad news it is still doing the same old thing. about 10 mins and it goes to a blank screen until
I move the mouse.
 
Old 12-19-2006, 10:23 AM   #10
nx5000
Senior Member
 
Registered: Sep 2005
Location: Out
Posts: 3,307

Rep: Reputation: 53
http://www.cyberciti.biz/tips/linux-...ing-blank.html

?

On my machine just stopping DPMS did the trick so I have no idea anymore..
 
Old 12-19-2006, 11:32 AM   #11
jjamesis
LQ Newbie
 
Registered: Nov 2006
Posts: 12

Original Poster
Rep: Reputation: 0
Can you post the contents of your xorg.conf and xinitrc file?
 
Old 12-19-2006, 11:44 AM   #12
nx5000
Senior Member
 
Registered: Sep 2005
Location: Out
Posts: 3,307

Rep: Reputation: 53
Quote:
Option "DPMS" "FALSE"
is in /etc/X11/xorg.conf

and xinitrc is not used because I'm using kde
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Disable screen saver in KNOPPIX? esc_5p1d0r Linux - Newbie 4 06-18-2006 05:32 PM
Screen saver/ machine locking up power management proiblem? lesleyb Suse/Novell 0 03-24-2006 02:48 AM
SuSE 9.2 Disable Screen Saver Chandorc Linux - Newbie 1 04-26-2005 10:59 PM
question on disable the screen saver bbmak Linux - Software 2 10-03-2004 09:37 PM
disable screen saver? duaux Linux - General 1 09-05-2002 05:19 PM


All times are GMT -5. The time now is 11:42 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration