LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-25-2010, 01:31 PM   #1
fcfury
LQ Newbie
 
Registered: Apr 2009
Posts: 25

Rep: Reputation: 0
How to disable people from changing the screen saver time


Running RHEL5 and because of the environment that we are in we have to disable the users being able to change the screen saver. I have tried using the gconf-editor to see if I can disable it but don't know if that is the correct way of doing it. I also looked in /etc/xdg/menus and really don't want to miss with that.
 
Old 10-25-2010, 01:38 PM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,066
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
Depending on what WM/DE you're using ... make a change to
your screensaver settings; then run a "find ~ -mmin -3". Check
files that resemble anything screensaver-ish. Then - for all
accounts - make that file & directory it's in owned by root, and
read-only for the users group. That should do the trick.


Cheers,
Tink
 
Old 10-26-2010, 08:17 AM   #3
fcfury
LQ Newbie
 
Registered: Apr 2009
Posts: 25

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Tinkster View Post
Depending on what WM/DE you're using ... make a change to
your screensaver settings; then run a "find ~ -mmin -3". Check
files that resemble anything screensaver-ish. Then - for all
accounts - make that file & directory it's in owned by root, and
read-only for the users group. That should do the trick.


Cheers,
Tink
Thanks Tinkster, but I figured it out. If anyone is interested in the fix here is the answer.

gconftool-2 --direct --config-source xml:readwrite:/etc/gconf/gconf.xml.mandatory/ --set --type bool /apps/gnome-screensaver/idle_activation_enabled true

gconftool-2 --direct --config-source xml:readwrite:/etc/gconf/gconf.xml.mandatory/ --set --type int /apps/gnome-screensaver/idle_delay 15
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
how to disable screen-saver angelo_maci Linux - Software 1 05-17-2010 02:03 PM
about disable screen saver andrias DamnSmallLinux 0 04-16-2008 10:22 AM
Cant disable screen saver.. madspikes Linux - General 1 04-13-2007 06:45 AM
question on disable the screen saver bbmak Linux - Software 2 10-03-2004 09:37 PM
disable screen saver? duaux Linux - General 1 09-05-2002 05:19 PM


All times are GMT -5. The time now is 08:33 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration