LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-02-2005, 09:54 AM   #1
TDABN77
LQ Newbie
 
Registered: Dec 2005
Posts: 1

Rep: Reputation: 0
How to disable characters wich are added by the unix system after FTP a file


When I FTP a file to a Linix system, the system adds "garbage" data to the file(at top of the file). I'm not a Linux expert but I do now that Linux adds info to each file for it's own interpertation. Does anyone now how to disable this feature when I FTP the file.

Example
File used befor ftp:
$SOH$2003101211430620031012114306108980685401O3$EOH$
UNB+GGOL:2+1089378044:55+ABNANL2A:55+031110:1407+PAY1T1C1DB'
UNH+1+PAYMUL:96A:UN:AAB'
BGM+452+33354+9'
DTM+137:20050201:102'


After FTP:

@^&%$SOH$2003101211430620031012114306108980685401O3$EOH$
UNB+GGOL:2+1089378044:55+ABNANL2A:55+031110:1407+PAY1T1C1DB'
UNH+1+PAYMUL:96A:UN:AAB'
BGM+452+33354+9'
DTM+137:20050201:102'

Could anyone inform me about this?

Thanx
 
Old 12-02-2005, 10:09 AM   #2
jeremy
root
 
Registered: Jun 2000
Distribution: Debian, Red Hat, Slackware, Fedora, Ubuntu
Posts: 11,957

Rep: Reputation: 3113Reputation: 3113Reputation: 3113Reputation: 3113Reputation: 3113Reputation: 3113Reputation: 3113Reputation: 3113Reputation: 3113Reputation: 3113Reputation: 3113
Moved: This thread is more suitable in Linux - Newbie and has been moved accordingly to help your thread/question get the exposure it deserves.

--jeremy
 
Old 12-02-2005, 02:54 PM   #3
beeblequix
Member
 
Registered: Oct 2005
Location: Tierra Firma, Earth
Distribution: Debian of course...
Posts: 196

Rep: Reputation: 30
maybe it's the way you're ftp'ing.

Are you ftp'ing from a windows system? It may be because you're doing something like:
start-run-cmd
ftp 66.666.66.6
user me
passwd me2
cd some/subdirectory/on/a/remote/linus/machine
put filename.txt
bye

And then you find out your file is $h!tE.

BIN. ftp defaults to ASCII, so you may be describing the ASCII corruption.

Log into the linux machine with ftp but before you put the file type "bin" to set binary as the way you're sending the file. See if that works.

 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
disable write in file system jobless_joe Linux - Newbie 4 01-13-2005 08:23 AM
9.2 partitions not added into a 10.1 file system choco66 Mandriva 1 12-10-2004 06:09 PM
Unix file system Swift&Smart General 4 02-17-2003 11:45 AM
File system upset by added IDE drive jerrymc Linux - Hardware 6 07-11-2002 01:53 AM
UNIX file system changes Micha Agovic Linux - General 6 07-31-2001 07:07 PM


All times are GMT -5. The time now is 07:05 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration