LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-23-2015, 08:40 AM   #1
aavika
Member
 
Registered: Dec 2014
Posts: 82

Rep: Reputation: Disabled
How to disable boot messages to be printed on screen during boot up


hello all,
i am using Centos 6. i want to disable boot log messages at the time of boot-up even after pressing any key like.. Esc,Alt+d,any arrow keys..

i tried to disable keys by using the command:
xmodmap -e "remove Escape = Escape" and all...
but its not working.
what should i do?? boot messages like this:

iptables: Applying firewall rules: [ OK ]
Bringing up loopback interface: [ OK ]
Bringing up interface eth0:
Determining IP information for eth0... done.
[ OK ]
Starting system logger: [ OK ]
Starting system message bus: [ OK ]
Retrigger failed udev events[ OK ]
Starting snmpd: netlink: 12 bytes leftover after parsing attributes.
[ OK ]
Starting snmptrapd: [ OK ]
Starting sshd: [ OK ]
Starting mysqld: [ OK ]
Starting Dovecot Imap: [ OK ]
Starting postfix: [ OK ]
Starting mailgraph: [ OK ]
Starting httpd: [ OK ]
Starting crond: [ OK ]
Starting squid: .[ OK ]
Starting fail2ban: [ OK ]
Starting atd: [ OK ]
 
Old 04-23-2015, 10:17 AM   #2
veerain
Senior Member
 
Registered: Mar 2005
Location: Earth bound to Helios
Distribution: Custom
Posts: 2,524

Rep: Reputation: 319Reputation: 319Reputation: 319Reputation: 319
Didn't understand your meaning?. Kernel boot messages can be disabled using 'quiet=1' kernel parameter in grub config.
 
Old 04-23-2015, 10:42 AM   #3
aavika
Member
 
Registered: Dec 2014
Posts: 82

Original Poster
Rep: Reputation: Disabled
what i mean to say is,the end user should be unable to see the services/boot log messages during boot-up. if the administrator wants to see the messages, then he should be able to see by pressing combo keys which he would be assigning to view the services

i also added quiet=1 and tested it.
but still after pressing the keys (arrows,esc,alt+d), it shows the boot messages.

thank u for the reply
 
Old 04-24-2015, 06:41 PM   #4
jpollard
Senior Member
 
Registered: Dec 2012
Location: Washington DC area
Distribution: Fedora, CentOS, Slackware
Posts: 4,604

Rep: Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241
I don't understand your problem. The keys you indicate ARE the "combo keys".
 
Old 07-08-2015, 06:07 AM   #5
aavika
Member
 
Registered: Dec 2014
Posts: 82

Original Poster
Rep: Reputation: Disabled
permanently disable keys.. even after pressing any keys
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Don't show boot messages during Clonezilla boot-up. Splash screen? Perd Linux - Newbie 4 07-18-2010 03:49 PM
DMA boot screen error messages jukebox55 Linux - General 0 08-10-2007 07:42 PM
Either boot messages are off screen or KDE is? M$ISBS Linux - Hardware 1 04-03-2006 06:16 AM
Disable messages printed just after login kaon Linux - General 1 09-06-2004 08:27 AM
boot screen messages 9nine9 Linux - General 2 01-06-2003 03:50 PM


All times are GMT -5. The time now is 07:44 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration