LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-23-2007, 04:42 PM   #1
jmorgan324
LQ Newbie
 
Registered: Jul 2007
Posts: 8

Rep: Reputation: 0
how to detect USB devices like MP3 players


I'm trying to connect my sansa e250 to my computer but I don't know where to find it in the options.

if someone could help me I would appreciate it a lot
 
Old 07-23-2007, 04:47 PM   #2
pljvaldez
LQ Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Wheezy (x86)
Posts: 6,094

Rep: Reputation: 271Reputation: 271Reputation: 271
Usually it will get mounted automatically under a certain directory. What distribution (Suse, ubuntu, pclinux os, etc) are you using? And what desktop (KDE, gnome, xfce, etc)? That'll help a bit more.
 
Old 07-23-2007, 04:51 PM   #3
jmorgan324
LQ Newbie
 
Registered: Jul 2007
Posts: 8

Original Poster
Rep: Reputation: 0
USB devices

i am using ubuntu and gnome for a desktop
 
Old 07-23-2007, 05:15 PM   #4
pljvaldez
LQ Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Wheezy (x86)
Posts: 6,094

Rep: Reputation: 271Reputation: 271Reputation: 271
I think in Gnome, you use Nautilis. The device should get mounted someplace like /media/sda1 or the like.
 
Old 07-23-2007, 05:22 PM   #5
jmorgan324
LQ Newbie
 
Registered: Jul 2007
Posts: 8

Original Poster
Rep: Reputation: 0
i went to computer and then i went to file system all i see in media is cdrom and cdrom0
 
Old 07-23-2007, 05:30 PM   #6
saikee
Senior Member
 
Registered: Sep 2005
Location: Newcastle upon Tyne UK
Distribution: Any free distro.
Posts: 3,398
Blog Entries: 1

Rep: Reputation: 112Reputation: 112
In Ubuntu terminal type
Code:
sudo su
fdisk -l
Repeat the command until it shows up.

To mount it manually, assuming sda1 is needed
Code:
mkdir /media/sda1
mount /dev/sda1 /media/sda1
ls /mnt/sda1
 
Old 07-23-2007, 05:40 PM   #7
jmorgan324
LQ Newbie
 
Registered: Jul 2007
Posts: 8

Original Poster
Rep: Reputation: 0
i tried to mount it but when the sda1 folder comes up in media i clicked it and it just brought me back to the file system menu
 
Old 07-23-2007, 05:47 PM   #8
oskar
Senior Member
 
Registered: Feb 2006
Location: Austria
Distribution: Ubuntu 12.10
Posts: 1,142

Rep: Reputation: 49
you can see if it is being recognized when you connect it with:
Code:
$ lshal -h
and see where the kernel put it with:
Code:
$ dmesg | tail -n 20
The tail part just shows you the last 20 lines which is all you need.
If it doesn't get mounted automatically, you can mount it with
Code:
$ pmount [device]
Which is nicer, because it doesn't give you any trouble with permissions... It get's mounted in /media/'device-name'.
 
Old 07-23-2007, 05:49 PM   #9
oskar
Senior Member
 
Registered: Feb 2006
Location: Austria
Distribution: Ubuntu 12.10
Posts: 1,142

Rep: Reputation: 49
Quote:
Originally Posted by jmorgan324
i tried to mount it but when the sda1 folder comes up in media i clicked it and it just brought me back to the file system menu

Because in your case sda1 is obviously the root file system. That's why you should check dmesg or look for it in "$ fdisk -l"
btw... you usually don't have to be root to see removable devices with "fdisk -l"... and you certainly don't have to become root permanently "sudo su"... As root there are so many ways to do permanent damage just with typos.

Last edited by oskar; 07-23-2007 at 05:53 PM.
 
Old 07-23-2007, 05:49 PM   #10
saikee
Senior Member
 
Registered: Sep 2005
Location: Newcastle upon Tyne UK
Distribution: Any free distro.
Posts: 3,398
Blog Entries: 1

Rep: Reputation: 112Reputation: 112
I have left in Post #6 this line
Code:
ls /mnt/sda1
It is supposed to show you the inside of sda1 to make sure you have mounted the right partition. Well was it the right one?

If Ubuntu disallows you to see it then you don't have owner permission to access the files. To change it you need to type this line in the "root" terminal
Code:
chown -R your_username /mnt/sda1/*
where your_username is you logged on username
 
Old 07-23-2007, 05:52 PM   #11
jmorgan324
LQ Newbie
 
Registered: Jul 2007
Posts: 8

Original Poster
Rep: Reputation: 0
this is what it shows me:

josh@josh-laptop:~$ dmesg | tail -n 20
[ 83.188000] Using specific hotkey driver
[ 83.240000] pcc_acpi: loading...
[ 87.020000] [drm] Initialized drm 1.1.0 20060810
[ 87.020000] ACPI: PCI Interrupt 0000:00:02.0[A] -> GSI 16 (level, low) -> IRQ 17
[ 87.020000] [drm] Initialized i915 1.6.0 20060119 on minor 0
[ 87.504000] ppdev: user-space parallel port driver
[ 88.360000] apm: BIOS not found.
[ 88.492000] Bluetooth: Core ver 2.11
[ 88.492000] NET: Registered protocol family 31
[ 88.492000] Bluetooth: HCI device and connection manager initialized
[ 88.492000] Bluetooth: HCI socket layer initialized
[ 88.512000] Bluetooth: L2CAP ver 2.8
[ 88.512000] Bluetooth: L2CAP socket layer initialized
[ 88.684000] Bluetooth: RFCOMM socket layer initialized
[ 88.684000] Bluetooth: RFCOMM TTY layer initialized
[ 88.684000] Bluetooth: RFCOMM ver 1.8
[ 199.828000] ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
[ 215.644000] eth1: no IPv6 routers present
[ 3968.696000] usb 5-3: new high speed USB device using ehci_hcd and address 2
[ 3970.028000] usb 5-3: configuration #128 chosen from 1 choice


where does it tell me the device is
 
Old 07-23-2007, 06:01 PM   #12
oskar
Senior Member
 
Registered: Feb 2006
Location: Austria
Distribution: Ubuntu 12.10
Posts: 1,142

Rep: Reputation: 49
wait 15 seconds and try again... (you did this right after you connected, right? ) This should show up almost instantly though.
If not, post the output of "fdisk -l" and "sudo fdisk - l" if the first one returned nothing.
 
Old 07-23-2007, 06:05 PM   #13
jmorgan324
LQ Newbie
 
Registered: Jul 2007
Posts: 8

Original Poster
Rep: Reputation: 0
well now it tells me this:

josh@josh-laptop:~$ dmesg | tail -n 20
[ 87.020000] ACPI: PCI Interrupt 0000:00:02.0[A] -> GSI 16 (level, low) -> IRQ 17
[ 87.020000] [drm] Initialized i915 1.6.0 20060119 on minor 0
[ 87.504000] ppdev: user-space parallel port driver
[ 88.360000] apm: BIOS not found.
[ 88.492000] Bluetooth: Core ver 2.11
[ 88.492000] NET: Registered protocol family 31
[ 88.492000] Bluetooth: HCI device and connection manager initialized
[ 88.492000] Bluetooth: HCI socket layer initialized
[ 88.512000] Bluetooth: L2CAP ver 2.8
[ 88.512000] Bluetooth: L2CAP socket layer initialized
[ 88.684000] Bluetooth: RFCOMM socket layer initialized
[ 88.684000] Bluetooth: RFCOMM TTY layer initialized
[ 88.684000] Bluetooth: RFCOMM ver 1.8
[ 199.828000] ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
[ 215.644000] eth1: no IPv6 routers present
[ 3968.696000] usb 5-3: new high speed USB device using ehci_hcd and address 2
[ 3970.028000] usb 5-3: configuration #128 chosen from 1 choice
[10017.300000] usb 5-3: USB disconnect, address 2
[10043.908000] usb 5-3: new high speed USB device using ehci_hcd and address 3
[10044.916000] usb 5-3: configuration #128 chosen from 1 choice
 
Old 07-23-2007, 06:27 PM   #14
oskar
Senior Member
 
Registered: Feb 2006
Location: Austria
Distribution: Ubuntu 12.10
Posts: 1,142

Rep: Reputation: 49
hmmm...
What it should say is "blah blah attached removeable device [dev] blah blah"
But it doesn't...
Well... check fdisk. this is odd though.

Quote:
Originally Posted by saikee
I have left in Post #6 this line
Code:
ls /mnt/sda1
It is supposed to show you the inside of sda1 to make sure you have mounted the right partition. Well was it the right one?

If Ubuntu disallows you to see it then you don't have owner permission to access the files. To change it you need to type this line in the "root" terminal
Code:
chown -R your_username /mnt/sda1/*
where your_username is you logged on username
... can't you just change the ownership of the mountpoint? I have nothing to try this now, but wouldn't
Code:
$ sudo chown user:group [mountopoint]
do it?

Another way to do this would be by mounting it directly with user permissions... If pmount doesn't work... Well I'll get to that IF pmount doesn't work

Last edited by oskar; 07-23-2007 at 06:30 PM.
 
Old 07-23-2007, 06:43 PM   #15
oskar
Senior Member
 
Registered: Feb 2006
Location: Austria
Distribution: Ubuntu 12.10
Posts: 1,142

Rep: Reputation: 49
found this http://www.mail-archive.com/linux-us.../msg17595.html
Apparently the problem is that the mp3 player is in MTB-mode, and you have to switch it to MSC-mode -- looks like you have to adjust that on the player.

Quote:
I had
forgotten I connected it to a Windows machine which forces it to use MTP
mode versus MSC mode. All that and a bag of chips, plus FUN.

The Sansa e250 is auto-mounting perfectly since I changed the setting.

Last edited by oskar; 07-23-2007 at 06:49 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
mp3 usb players/sticks unihiekka Linux - Hardware 1 12-01-2005 01:32 PM
Can't detect usb devices?? CM019 Debian 5 06-09-2005 02:43 PM
USB services / mp3 players LucasN Mandriva 1 01-04-2005 06:02 AM
Can Hotplug detect USB devices in a certain order? SAM_site Linux - General 0 07-10-2004 08:27 AM
how is the hardware support for usb mp3 players under linux? LavaDevil94 Linux - Hardware 9 05-05-2004 05:06 PM


All times are GMT -5. The time now is 06:19 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration