LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-03-2012, 06:33 PM   #1
charlottew
LQ Newbie
 
Registered: Sep 2012
Posts: 3

Rep: Reputation: Disabled
how to deal with a problem says ".bashrc: Too many levels of symbolic links"


Every time I open a terminal, it says:
"bash: /home/xxx/.bashrc: Too many levels of symbolic links"
and after I typed in "ls -ali",
I found a ".bashrc -> .bashrc",
How can I remove this symbolic link?
If I type “rm .bashrc”, will this command reomve the original .bashrc?
Thank you guys for the help.
 
Old 09-03-2012, 06:35 PM   #2
suicidaleggroll
LQ Guru
 
Registered: Nov 2010
Location: Colorado
Distribution: OpenSUSE, CentOS
Posts: 5,258

Rep: Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947
It looks like there is no original .bashrc. .bashrc on your system is a symlink to itself.
 
Old 09-03-2012, 06:50 PM   #3
charlottew
LQ Newbie
 
Registered: Sep 2012
Posts: 3

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by suicidaleggroll View Post
It looks like there is no original .bashrc. .bashrc on your system is a symlink to itself.
Then how to deal with that? just rm it?
 
Old 09-03-2012, 07:14 PM   #4
suicidaleggroll
LQ Guru
 
Registered: Nov 2010
Location: Colorado
Distribution: OpenSUSE, CentOS
Posts: 5,258

Rep: Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947
Just remove it, and maybe grab a default one from one of the other users on the system to replace it. There shouldn't be much in the default one anyway.
 
Old 09-03-2012, 07:42 PM   #5
charlottew
LQ Newbie
 
Registered: Sep 2012
Posts: 3

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by suicidaleggroll View Post
Just remove it, and maybe grab a default one from one of the other users on the system to replace it. There shouldn't be much in the default one anyway.
Done. Thank you very much!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] HELP! "The target doesn't support symbolic links." joint Ubuntu 33 09-21-2012 10:20 AM
tar: "preserve the symbolic links" julian16 Linux - Newbie 3 02-05-2012 12:24 AM
"Too many levels of symbolic links" Problem Corallis Linux - Newbie 5 07-12-2004 02:18 PM
ProFTPD - "Too many levels of symbolic links" orange400 Linux - Software 5 04-29-2004 07:55 AM
Can't mount CDROM: "Too many levels of symbolic links" wycolorado Linux - Newbie 10 08-15-2003 11:56 PM


All times are GMT -5. The time now is 04:19 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration