LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-17-2008, 04:43 AM   #1
redlynch
LQ Newbie
 
Registered: Dec 2007
Location: milan
Posts: 10

Rep: Reputation: 0
How to Copy and Past ? I cannot do anything


Hello
I have mandriva 2008 on my toshiba satellite notebook in dual boot with windows and I have been using it for 4 days (ex windows user)
I go in "home" folder trying to create a new folder, or to paste a file but it says "access denied"
so, i think i need to change user and enter as administrator,but i tried it and it says as well , cannot access to the root.
I can only enter as Paolo (my name) , a user, and cannot do anything
So i don't know how the hell creat a folder inside home! i thought it was simpler
Anyone could give me a clue?

Thanks in advance

Paolo
 
Old 07-17-2008, 04:58 AM   #2
shahz
Member
 
Registered: Sep 2006
Location: Quetta, Pakistan
Distribution: RHEL 4
Posts: 363

Rep: Reputation: 29
if you have a user login and password then I think you are should be able to writte on your home directory.


thanks
 
Old 07-17-2008, 05:22 AM   #3
Greenfuse
Member
 
Registered: Nov 2004
Distribution: gentoo, arch centos
Posts: 164

Rep: Reputation: 22
The folder named "home" contains the personal home folders of each user account on your computer. A normal user cannot write to the folder named "home".

A user called 'paulo' has a home folder named "paulo" inside the folder named "home". Paulo can copy and create files in the folder "paulo" and into all subfolders in this folder.

In mandriva you are probably looking around the filesystem of your computer with the browser 'konqueror'. If you click on the picture of a house, then you will be in your home folder.

TIP - with Linux we call a folder a 'directory'

Last edited by Greenfuse; 07-17-2008 at 05:31 AM.
 
Old 07-17-2008, 05:48 AM   #4
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,811
Blog Entries: 1

Rep: Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191
Have you tried sudo for administrative priviliges? Perhaps, it works.

Is it your home computer? If so, I'd suggest reinstalling the system (or somehow getting the root password) as without the root password, your linux experience will be very limited. You won't be able to update the system or install many programs. Besides if you'd like to learn new things about the system, sooner or later you will need the root password.
 
Old 07-17-2008, 05:51 AM   #5
mrrangerman
Member
 
Registered: Oct 2007
Location: MI
Distribution: Debian Slackware
Posts: 528

Rep: Reputation: 50
Quote:
Greenfuse

TIP - with Linux we call a folder a 'directory'
In the computing world to my knowledge it was always called a directory until win95 MS thought to change what it was called.
 
Old 07-17-2008, 07:22 AM   #6
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
The easiest way to setup folders** and permissions is in a terminal. To have complete control, simply enter "su" to take on root (administrator) powers.

If you don't have the root password, there is no need to re-install. Simply boot into single-user mode and enter "passwd root".

To boot into single-user mode:
When the GRUB menu appears, hit any key to stop the count, the "e" for edit. Select the kernel line, "e" again, and add the word "single" (no quotes) at the end of the line. It will now boot into a root terminal with no password required.

**It is OK to say "folder" in Linux. Just look at the icons in any of the various GUIs---Do you see pictures of folders or directories?....
 
Old 07-21-2008, 08:47 AM   #7
redlynch
LQ Newbie
 
Registered: Dec 2007
Location: milan
Posts: 10

Original Poster
Rep: Reputation: 0
I have root password

exactly set during installation, as first option, followed by setting options for user

So, I can switch from user to root with SU command, can't I?
My question is: when i am set as SU, should I be able to create new directories or cancel file also in othere dirs (e.g. lib) not only in "home".
My question is , if I cant' do it also with SU password, what's the issue?

Bye
 
Old 07-21-2008, 02:14 PM   #8
dickgregory
Member
 
Registered: Oct 2002
Location: Houston
Distribution: Arch, PCLinuxOS, Mint
Posts: 257

Rep: Reputation: 34
Try this:

cd /home
ls -l

Do you see a directory named paulo? That should be your home directory. If not, you do not have a standard setup.

When you do "cd ~" or just "cd" does it get you to /home/paulo ? It should.

If the previous tests don't give the desired results, you might want to repost for help. Fixing this isn't hard, but it may require editing the /etc/passwd file, which can lock you out of your system if you mistype something.

If there is a paulo directory, look at the user column on the display. It should have paulo as the owning user, and probably also the group. If not, you can change it by becoming root with "su -" and using the chown command. If you have problems with that, please use "man su" or "man chown" before asking for more help.

Now look at the permissions string for the paulo directory. That's the one that probably starts with "drwx" Make sure that the r, w, and x are all there. If not, use chmod to change it. Once again, use "man chmod" if needed, for your own education.

Hint: If you use the recursive flag for chmod, the files inside will also be changed. But you don't want to put the "x" on your inside files.
 
Old 07-25-2008, 07:23 AM   #9
redlynch
LQ Newbie
 
Registered: Dec 2007
Location: milan
Posts: 10

Original Poster
Rep: Reputation: 0
Hello Dickgregory, Hello e.body!

Just in case I borrowed a linux guide which helped me out to work on it and solve all the issues!! It's all ok now. I entered as root, installed the USB adsl Firmware on a directory I created to host the firmware files.
I understood the "philosophy" of chmod, etcc...

Thanks to everyone , really, for helping me
RedLynch
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
how to copy-past on command line? jameshao Linux - Newbie 5 02-01-2009 04:55 PM
Enabling copy and past Guest Linux, Host Windows XP daffybunny Linux - General 4 03-01-2007 07:02 AM
Qcad copy and past? kalleanka Linux - Software 2 10-07-2006 08:43 AM
Gimp2.2 amd Copy & Past to OpenOffice ReporterX SUSE / openSUSE 1 12-29-2004 05:25 PM


All times are GMT -5. The time now is 04:23 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration