LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 07-29-2009, 02:03 AM   #1
akram
Member
 
Registered: Jul 2009
Posts: 31

Rep: Reputation: 15
How to configure the serial port of my virtual machine with host machine.


Dear Friends,

I successfully installed the virtual box on my fedora 8 system, and also created a virtual machine with windows xp OS, it works nicely, I try to configure the serial port of my virtual machine and try to configure the path for the port "screen shot are attached" it gives me the error message also the "screen shot are attached" for your review.


Is kind of mistake is going on during the path setting, and how to set the path for configuring the serial port of my virtual machine so that I can use the hyper terminal tool of windows.


Thanks in advanced.


Regards,

Akram.
Attached Images
File Type: png Screenshot-Test - Settings.png (48.3 KB, 7 views)
File Type: png Screenshot-VirtualBox - Error.png (14.1 KB, 13 views)
 
Old 07-29-2009, 07:09 PM   #2
foodown
Member
 
Registered: Jun 2009
Location: Texas
Distribution: Slackware
Posts: 609

Rep: Reputation: 218Reputation: 218Reputation: 218
In the port/file path in your VB settings, you have "COM1/dev/ttyS0"

It should probably just be "/dev/ttyS0"

You may need to check "Create Pipe," but probably not.
 
Old 07-30-2009, 12:21 AM   #3
akram
Member
 
Registered: Jul 2009
Posts: 31

Original Poster
Rep: Reputation: 15
Dear foodown

My VM settings according to your guidelines are

I am selecting

1- the Port Number to dropdown menu to"COM1"
2- with Port Mode dropdown menu to "Hostpipe"
3- checked and then unchecked the "create pipe" option (in both case the error message is same, shown below),
4- Port/File Path "/dev/ttyS0", as you saying.

when I start the Virtual machine, ti shows error message as shown below,

"Failed to start the virtual machine
namedPipe#0 failed to connect to local socket /dev/ttyS0
(VERR_ACCESS_DENIED).
Unknown error creating VM (VERR_ACCESS_DENIED)
."

One thing I want to ask you, that When I was created the VM, the I add also the serial port with its default Port mode dropdown menu settings which is "Disconnected", On the creation time, My thought that I will configure it latter,

Is we can add and configure other components for Vmachine, after installation or NOT.


Regards,
Akram
 
Old 07-30-2009, 09:02 PM   #4
foodown
Member
 
Registered: Jun 2009
Location: Texas
Distribution: Slackware
Posts: 609

Rep: Reputation: 218Reputation: 218Reputation: 218
Hmmm . . .

In the drop down, instead of "Host Pipe" select "Host Device"

Before you start VB again, as root do this:
Code:
chmod 666 /dev/ttyS0
That seems to work for me.
 
Old 07-31-2009, 10:39 PM   #5
akram
Member
 
Registered: Jul 2009
Posts: 31

Original Poster
Rep: Reputation: 15
Dear foodown,

Thanks, for helping me serial port of my VM is working nicely.

thanks again my friend for help.


Regards,

Akram
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
file sharing between a virtual machine and the host machine okok Linux - Networking 3 06-21-2013 12:42 AM
Virtual Machine - best distro as host snorkytheweasel Linux - Software 2 09-19-2008 01:52 PM
can't access virtual host from local machine curos Linux - Networking 3 02-06-2006 09:18 PM
How to check if my machine has done a host/port sweep? blur Linux - Security 2 04-23-2004 06:16 AM
Apache SSL - how to virtual host two or more secure websites on the same machine? bjoshi Linux - Networking 0 08-30-2001 07:01 PM


All times are GMT -5. The time now is 11:29 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration