LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-06-2012, 11:58 AM   #1
linuxreza
Member
 
Registered: Jan 2012
Location: Mumbai, India
Distribution: Redhat
Posts: 30
Blog Entries: 1

Rep: Reputation: Disabled
How to configure pppoe connection


Hello Friends
I just take a Internet connection, It a wired connection. But the ISP guy made configuration in Windows 7 and connected to Internet , it is working fine now. He made a pppoe connection . He gave me username : reza , Password = 123456 , and service name : omstartnet. But i tried to connect it in Fedora 16 , i am unable to connect it . In Network Manager i put all the details but still not able to connect. Kindly help me or send me any helpfull link, so i can enjoy Internet in Fedora as well.


Thanks and regards
Md Ahsan Reza
 
Old 05-06-2012, 12:15 PM   #2
t1nm@n
Member
 
Registered: Aug 2009
Location: Trivandrum, Kerala, India.
Distribution: Slackware 14.2 x86_64
Posts: 96
Blog Entries: 3

Rep: Reputation: 25
Check this link out
Also the official fedora pags does have solutions that worked fine with my pppoe needs
 
Old 05-07-2012, 05:37 AM   #3
war49
LQ Newbie
 
Registered: Feb 2012
Location: Indonesia
Distribution: Slackware, Centos, Debian, RHEL
Posts: 13

Rep: Reputation: Disabled
Configure pppoe in linux is quite easy, you must edit file /etc/ppp/pppoe.conf. In pppoe.conf insert your username and password, then insert interface for connect to adsl modem (ex: ethX) and insert primary and secondary DNS. After completing pppoe.conf, run: pppoe-start. Or, you can try: pppoe-setup for simple way.
 
Old 05-07-2012, 06:13 AM   #4
linuxreza
Member
 
Registered: Jan 2012
Location: Mumbai, India
Distribution: Redhat
Posts: 30
Blog Entries: 1

Original Poster
Rep: Reputation: Disabled
i can see the pppoe.conf file in /etc/ppp/ directory
 
Old 05-07-2012, 07:04 AM   #5
linuxreza
Member
 
Registered: Jan 2012
Location: Mumbai, India
Distribution: Redhat
Posts: 30
Blog Entries: 1

Original Poster
Rep: Reputation: Disabled
Hello t1nm@n

i follow your instruction but i still i am not able to connect to internet.

i follow the following instruction kindly check.
Quote:
[root@server1 Documents]# pppoe-setup





Welcome to the PPPoE client setup. First, I will run some checks on
your system to make sure the PPPoE client is installed properly...


LOGIN NAME

Enter your Login Name (default root): reza

INTERFACE

Enter the Ethernet interface connected to the PPPoE modem
For Solaris, this is likely to be something like /dev/hme0.
For Linux, it will be ethX, where 'X' is a number.
(default eth0): p4p1

Do you want the link to come up on demand, or stay up continuously?
If you want it to come up on demand, enter the idle time in seconds
after which the link should be dropped. If you want the link to
stay up permanently, enter 'no' (two letters, lower-case.)
NOTE: Demand-activated links do not interact well with dynamic IP
addresses. You may have some problems with demand-activated links.
Enter the demand value (default no): no

DNS

Please enter the IP address of your ISP's primary DNS server.
If your ISP claims that 'the server will provide dynamic DNS addresses',
enter 'server' (all lower-case) here.
If you just press enter, I will assume you know what you are
doing and not modify your DNS setup.
Enter the DNS information here: 128.139.6.1
Please enter the IP address of your ISP's secondary DNS server.
If you just press enter, I will assume there is only one DNS server.
Enter the secondary DNS server address here: 128.139.4.3

PASSWORD

Please enter your Password:
Please re-enter your Password:

USERCTRL

Please enter 'yes' (three letters, lower-case.) if you want to allow
normal user to start or stop DSL connection (default yes): yes

FIREWALLING

Please choose the firewall rules to use. Note that these rules are
very basic. You are strongly encouraged to use a more sophisticated
firewall setup; however, these will provide basic security. If you
are running any servers on your machine, you must choose 'NONE' and
set up firewalling yourself. Otherwise, the firewall rules will deny
access to all standard servers like Web, e-mail, ftp, etc. If you
are using SSH, the rules will block outgoing SSH connections which
allocate a privileged source port.

The firewall choices are:
0 - NONE: This script will not set any firewall rules. You are responsible
for ensuring the security of your machine. You are STRONGLY
recommended to use some kind of firewall rules.
1 - STANDALONE: Appropriate for a basic stand-alone web-surfing workstation
2 - MASQUERADE: Appropriate for a machine acting as an Internet gateway
for a LAN
Choose a type of firewall (0-2): 0

Start this connection at boot time

Do you want to start this connection at boot time?
Please enter no or yes (default no):no

** Summary of what you entered **

Ethernet Interface: p4p1
User name: reza
Activate-on-demand: No
Primary DNS: 128.139.6.1
Secondary DNS: 128.139.4.3
Firewalling: NONE
User Control: yes
Accept these settings and adjust configuration files (y/n)? y
Adjusting /etc/sysconfig/network-scripts/ifcfg-ppp0
Adjusting /etc/resolv.conf
(But first backing it up to /etc/resolv.conf.bak)
Adjusting /etc/ppp/chap-secrets and /etc/ppp/pap-secrets
(But first backing it up to /etc/ppp/chap-secrets.bak)
(But first backing it up to /etc/ppp/pap-secrets.bak)



Congratulations, it should be all set up!

Type '/sbin/ifup ppp0' to bring up your xDSL link and '/sbin/ifdown ppp0'
to bring it down.
Type '/sbin/pppoe-status /etc/sysconfig/network-scripts/ifcfg-ppp0'
to see the link status.

[root@server1 Documents]# /sbin/if
ifcfg ifconfig ifdown ifenslave ifrename ifup
[root@server1 Documents]# /sbin/ifup pppo
/sbin/ifup: configuration for pppo not found.
Usage: ifup <device name>
[root@server1 Documents]# /sbin/ifup p4p1
/sbin/ifup: configuration for p4p1 not found.
Usage: ifup <device name>
[root@server1 Documents]# /sbin/ifup eth1
/sbin/ifup: configuration for eth1 not found.
Usage: ifup <device name>
[root@server1 Documents]# /sbin/ifup ppp0
^C
[root@server1 Documents]# /sbin/ifup ppp0
[root@server1 Documents]# ifconfig
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:402 errors:0 dropped:0 overruns:0 frame:0
TX packets:402 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:33444 (32.6 KiB) TX bytes:33444 (32.6 KiB)

ppp0 Link encap:Point-to-Point Protocol
inet addr:27.106.113.13 P-t-P:27.106.66.225 Mask:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1492 Metric:1
RX packets:4 errors:0 dropped:0 overruns:0 frame:0
TX packets:3 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:3
RX bytes:34 (34.0 b) TX bytes:30 (30.0 b)

p3p1 Link encap:Ethernet HWaddr 00:E0:4C:39:12:90
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:19 Base address:0x6800

p4p1 Link encap:Ethernet HWaddr 00:E1:1A:35:4A:58
inet6 addr: fe80::2e1:1aff:fe35:4a58/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:80257 errors:0 dropped:7 overruns:0 frame:0
TX packets:46 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:93282716 (88.9 MiB) TX bytes:2979 (2.9 KiB)
Interrupt:16 Base address:0x6c00

[root@server1 Documents]# ping google.com
ping: unknown host google.com
[root@server1 Documents]# ping www.google.com
ping: unknown host www.google.com
[root@server1 Documents]# ping 27.106.113.13
PING 27.106.113.13 (27.106.113.13) 56(84) bytes of data.
64 bytes from 27.106.113.13: icmp_req=1 ttl=64 time=0.157 ms
64 bytes from 27.106.113.13: icmp_req=2 ttl=64 time=0.066 ms
64 bytes from 27.106.113.13: icmp_req=3 ttl=64 time=0.079 ms
64 bytes from 27.106.113.13: icmp_req=4 ttl=64 time=0.058 ms
64 bytes from 27.106.113.13: icmp_req=5 ttl=64 time=0.065 ms
^C
--- 27.106.113.13 ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 4000ms
rtt min/avg/max/mdev = 0.058/0.085/0.157/0.036 ms
[root@server1 Documents]#
kindly help me. since last 1o days i m trying to connect to internet. it is very easy to connect in windows. linux experts kindly help me.

Last edited by linuxreza; 05-07-2012 at 07:06 AM.
 
Old 05-07-2012, 07:28 AM   #6
Satyaveer Arya
Senior Member
 
Registered: May 2010
Location: Palm Island
Distribution: RHEL, CentOS, Debian, Oracle Solaris 10
Posts: 1,415

Rep: Reputation: 305Reputation: 305Reputation: 305Reputation: 305
You can try once through graphical interface also, http://hemenkapadia.somee.com/tutorial/html/rhnet.asp, like this.
 
Old 05-07-2012, 03:53 PM   #7
linuxreza
Member
 
Registered: Jan 2012
Location: Mumbai, India
Distribution: Redhat
Posts: 30
Blog Entries: 1

Original Poster
Rep: Reputation: Disabled
Satyaveer Arya
i am able to see the "Network Device Control " in fedora 16. I am not able to see that graphical interface what you have send to me.
How to open this kindly help me in this.

Md Ahsan Reza

Last edited by linuxreza; 05-07-2012 at 10:20 PM.
 
Old 05-07-2012, 10:26 PM   #8
linuxreza
Member
 
Registered: Jan 2012
Location: Mumbai, India
Distribution: Redhat
Posts: 30
Blog Entries: 1

Original Poster
Rep: Reputation: Disabled
one thing , the name of the Ethernet Cards should be like eth0 or eth1 but in my computer it is showing p4p1 and p3p1.
Can any one help me in this ?
 
Old 05-07-2012, 11:09 PM   #9
war49
LQ Newbie
 
Registered: Feb 2012
Location: Indonesia
Distribution: Slackware, Centos, Debian, RHEL
Posts: 13

Rep: Reputation: Disabled
hi reza,

You must able to ping your adsl modem,
most ethernet name in linux is ethX..

You must enter username and password that given by ISP (for example in Indonesia is: Telkom/speedy).
exp:
USERNAME=ABCDEX12345@telkom.net
PASSWORD=(Given by telkom/speedy)
 
Old 05-08-2012, 05:09 AM   #10
Satyaveer Arya
Senior Member
 
Registered: May 2010
Location: Palm Island
Distribution: RHEL, CentOS, Debian, Oracle Solaris 10
Posts: 1,415

Rep: Reputation: 305Reputation: 305Reputation: 305Reputation: 305
Quote:
I am not able to see that graphical interface what you have send to me.
On the taskbar there would be something like Applications. In that you can browse through System Tools --> Network Device Control, something like that.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How we can configure PPPOE internet connection ? kakil Linux - Networking 3 11-16-2010 08:29 AM
Missing /var/run/pppoe.conf-pppoe.pid.pppoe file acraig Debian 2 11-02-2010 08:24 PM
How to configure PPPoE connection on freebsd? cola *BSD 1 02-23-2010 10:52 AM
how to configure & setup ISP WAN MINIPORT (PPPOE) connection tgh12 Linux - Wireless Networking 1 07-26-2007 10:05 AM
how to configure & setup ISP WAN MINIPORT (PPPOE) connection tgh12 Linux - Wireless Networking 1 07-26-2007 10:05 AM


All times are GMT -5. The time now is 02:48 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration