LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   How to configure LAN and Dial up Connection in Ubuntu 8.04 LTS (http://www.linuxquestions.org/questions/linux-newbie-8/how-to-configure-lan-and-dial-up-connection-in-ubuntu-8-04-lts-660554/)

sethawn 08-05-2008 04:52 AM

How to configure LAN and Dial up Connection in Ubuntu 8.04 LTS
 
Greetings,

I have received a copy of Ubuntu 8.04 LTS Desktop Edition today which arrived at my home completely free. Thanks to the all the persons who made it and to the sponsor Canonical Ltd.

Well, I am very very new to Linux,so new that I do not even know what kind of information I must give to make somebody help me out from my problem. I only could follow installing the OS in both my PC at home and office.

My problem is

1) I have a Broadcom NetXtreme Gigabit Ethernet LAN internet connection using proxy server at my office. I could not connect to internet using this.

2) I have a Modem LG 260 Dial Up connection provided by BSNL (India) through telephone at home. I could not find a driver for the modem and do not know how to configure / install it.

I shall be highly obliged if anybody could help me out from my problem.

Thanks in advance,

Sethawn.

linuxlover.chaitanya 08-05-2008 05:03 AM

The ethernet card you mentioned that is Broadcom is supported by Ubuntu. It is surely a live cd. So just put the cd in you box and let it boot through it. Once it fully up, manually configure the network with correct Ip addresses and net masks. You will have no problems what so ever connecting to local network.
To be on internet, you need to provide more information on this. How do you connect in the office?
If its a transparent proxy, provide the proxy address as the gateway for your system and you should be surfing the net. If not, then configure firefox to connect through proxy.
And as far as LG phone is concerned, I have not seen the phone. But it is possible to connect through dial up connection.

sethawn 08-05-2008 05:55 AM

D/Chaitanya,

Thanks for your prompt reply.
Yes, it is a live cd, I put the Live CD in the tray and run it, it look nice and appealing.

How do I connect to internet? Well, in Win XP, I just configure the firefox connection settings Option>Advance>network>setting manual proxy configuration: I put 'oilproxy' port: '80' , tick 'use this proxy server for all...' OK. Thats all...

My question is I do not find the 'option' windows in firefox when i use the live cd. What more information should I have to give?

Please help.

Thanks a lot

Sethawn

jschiwal 08-05-2008 07:27 AM

In Firefox, Edit -> Preferences -> Advanced -> Network (tab).

Check in Ubuntu's network configuration and see if there is an item for dsl. You may want to google for the Ubuntu forums as well. There are different types of DSL.

From the SuSE Manual:
Quote:

Checklist DSL

There are different types of DSL devices available that use different point-to-point protocol (PPP) methods:

a regular ethernet card connected to the external DSL modem uses PPP over Ethernet (PPPoE). In Austria the Point-to-Point Tunneling Protocol (PPTP) is used. With PPTP the external modem also has a static IP address.

an internal DSL modem uses PPP over ATM (PPPoATM)

an internal ADSL Fritz Card uses CAPI for ADSL
I don't use Ubuntu, but I hope this information supplies some background info that will be useful.

linuxlover.chaitanya 08-05-2008 07:59 AM

Is your LG 260 a cell phone? If yes then you will have to look out for the kind of connection you can make. If it is a bluetooth enabled device then Hardy can connect to it. But it would be helpful for people here if you could post more about the dial up modem like its type, the way you connect using windows etc.

jschiwal, 9999 a nice number...

jschiwal 08-05-2008 03:44 PM

Ohhhh! I missed it.

hpp3 08-07-2008 02:32 PM

for some reason, the Linux version of Firefox has the configuration dialog under "Edit->Preferences" rather than "Tools->Options".
That is where you will find the dialog to use proxies from Firefox.
The Ubuntu Network Configuration dialog should be able to set up and use proxy addresses.

john test 08-07-2008 04:27 PM

all else fails go back to basics and see if the broadcom is talking to the proxy
Go to the command line (terminal from the menu or ctrl alt f1) type ifconfig at the Dollar prompt as see if you are pulling a default gateway and an ip address for inet You could post those ip addresses back here.

sethawn 08-20-2008 01:04 AM

John Test, Thanks for your reply,

Here I go, after typing ifconfig in the terminal\

eth0 Link encap:Ethernet HWaddr 00:0f:fe:26:76:5a
inet addr:172.29.1.203 Bcast:172.29.1.255 Mask:255.255.255.192
inet6 addr: fe80::20f:feff:fe26:765a/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:111 errors:0 dropped:0 overruns:0 frame:0
TX packets:48 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:12009 (11.7 KB) TX bytes:7151 (6.9 KB)
Interrupt:16

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:21440 errors:0 dropped:0 overruns:0 frame:0
TX packets:21440 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1072000 (1.0 MB) TX bytes:1072000 (1.0 MB)

ubuntu@ubuntu:~$

How do I connect internet in Win XP? well, I followed the following lines after installing drivers for the network card etc,----

network > Properties > LAC Property > TCP/IP > Property > DNS > Advance > Register > "oil.dul"

then, Computer name>more>DNS>'oil.dul' (I dont know this is required or not !!!)

firefox>option>advance>network>setting> tick manual proxy, enter oilproxy, port 80. that's all

sethawn

linuxlover.chaitanya 08-20-2008 01:14 AM

You already have the ip address. If you have not configured it manually, then you have dhcp server running in the network. So you should not bother about it if you can ping your squid. And about having to give DNS information, you can go give it either in resolv.conf file in /etc or do it from graphical interface.
System > Administration > Network. You will need to provide your password for changing it.

sethawn 08-20-2008 06:43 AM

linuxlover,

thanks for your advice, but I still could not open any web page, the connection is, I think, OK since two small computer icon on top right conner shows connected. And when giving DNS information etc in System>Admin>Network, no password is asked, I was booting it from live CD, Do i required to install first?

Thanks in advance

Sethawn

linuxlover.chaitanya 08-21-2008 12:59 AM

Can you please tell if you can ping your proxy server? And yes, if you login using a live cd, you do not need to give password. It is mentioned in the previous posts that you provide your proxy information with its FQ hostname. But can you resolve its ip address?

sethawn 08-21-2008 06:18 AM

linuxlover,

thanks for not leaving me behind:-)

I did this,

System>Admin>Network choose the Wired connection (LAN), > Properties> DHCP and in the Firefox I gave my proxy informations including my password and user name inclding the exemptions.

I can neither ping my proxy server nor resolved ip address.

I am very very new to Linux, and I shall be highly obliged if you could kindly give step by step (caption not required) procedure of setting up a connection ?

Thanks in advance

Sethawn

john test 08-21-2008 09:06 AM

At home cal BSNL tech support to get the connection set up
At work your ifconfig shows that you are pulling an IP address and have connectivity.
f you do a "cat /etc/resolv.conf" you should see the dns server addresses.
First ping one of the dns server addresses. If that works ping yahoo.com to see if the dns servers are resolving the urls
If that all works and you have configured the proxy settings in firefox and you still can't surf, then you Need to get some help from the LAN administrator.

linuxlover.chaitanya 08-22-2008 03:16 AM

Well, if you can not ping the squid proxy server in your network, you can not surf the web.( unless you know how to bypass squid ).
If you know what your dns is put it in /etc/resolv.conf.
You might get this information automatically if you take ip address from dhcp server.
If you can give the ip address of your system and your squid once again, and if you can see in the settings how you get the ip address , it will be more useful.


All times are GMT -5. The time now is 06:15 PM.