LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-26-2004, 10:53 AM   #1
Lucinda
Member
 
Registered: May 2004
Location: Atlanta, GA
Distribution: Slackware Current
Posts: 54

Rep: Reputation: 15
How to Configure Keyboard?


I am trying to set up my key mapping in Fluxbox 0.9.9 but I'm unable to get the "F" keys at the top of my keyboard to work. How do I configure my /etc/X11/XF86 config file in Slack 10? I have just a basic Dell keyboard (although is it a "Window" keyboard if it has the Windows-symbol key between the Ctrl and Alt keys?).

My config file is as follows:

Code:
# **********************************************************************
# Core keyboard's InputDevice section
# **********************************************************************

Section "InputDevice"

    Identifier	"Keyboard1"
    Driver	"Keyboard"
# For most OSs the protocol can be omitted (it defaults to "Standard").
# When using XQUEUE (only for SVR3 and SVR4, but not Solaris),
# uncomment the following line.

#    Option     "Protocol"      "Xqueue"

# Set the keyboard auto repeat parameters.  Not all platforms implement
# this.

#    Option     "AutoRepeat"    "500 5"

# Specifiy which keyboard LEDs can be user-controlled (eg, with xset(1)).

#    Option     "Xleds" "1 2 3"

# To disable the XKEYBOARD extension, uncomment XkbDisable.

#    Option     "XkbDisable"

# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults).  For example, for a European
# keyboard, you will probably want to use one of:
#
#    Option     "XkbModel"      "pc102"
#    Option     "XkbModel"      "pc105"
#
# If you have a Microsoft Natural keyboard, you can use:
#
#    Option     "XkbModel"      "microsoft"
#
# If you have a US "windows" keyboard you will want:
#
#    Option     "XkbModel"      "pc104"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
#
#    Option     "XkbLayout"     "de"
#
# or:
#
#    Option     "XkbLayout"     "de"
#    Option     "XkbVariant"    "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
#
#    Option     "XkbOptions"    "ctrl:swapcaps"


# These are the default XKB settings for XFree86
#
#    Option     "XkbRules"      "xfree86"
#    Option     "XkbModel"      "pc101"
#    Option     "XkbLayout"     "us"
#    Option     "XkbVariant"    ""
#    Option     "XkbOptions"    ""

EndSection
Thanks!

 
Old 06-28-2004, 02:01 PM   #2
DropSig
Member
 
Registered: Apr 2004
Location: East of Quebec
Distribution: Ubuntu, Centos
Posts: 208

Rep: Reputation: 30
Is your mapping good in KDE?
 
Old 06-28-2004, 02:10 PM   #3
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
Quote:
Code:
# These are the default XKB settings for XFree86
#
#    Option     "XkbRules"      "xfree86"
#    Option     "XkbModel"      "pc101"
#    Option     "XkbLayout"     "us"
#    Option     "XkbVariant"    ""
#    Option     "XkbOptions"    ""
I'd try uncommenting these lines and change the
layout to 104 since you seem to have windows-keys.

CODE]# These are the default XKB settings for XFree86
#
Option "XkbRules" "xfree86"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"
# Option "XkbVariant" ""
# Option "XkbOptions" ""[/CODE]


Cheers,
Tink
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
howto configure keyboard maloncu Linux - Hardware 2 09-12-2005 01:44 AM
Problem with configure keyboard jnicou Mandriva 0 05-21-2005 04:05 AM
usb keyboard and soundcard conflict (sound set to keyboard?) netsurf Linux - Hardware 2 04-09-2005 07:08 AM
Keyboard and moust not working in linux after configure sound card 012633023 Linux - Newbie 11 01-25-2005 09:57 AM
How to configure my keyboard keys. jrfly Linux - Newbie 7 12-16-2004 03:54 PM


All times are GMT -5. The time now is 08:08 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration