LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-06-2010, 04:24 PM   #1
professorgenival
LQ Newbie
 
Registered: Aug 2010
Posts: 20

Rep: Reputation: 1
How to change runlevel ubuntu 10.04?


Hello guys...

I'm trying to init 3 .. but I can't change te runlevel...

I was reading about upstart.. But I can't understand.. :-(

ubuntu upstart

Why they don't want to use /etc/inittab..it is so easy...


Always I have problems because someone change the way of do things in linux...

Thank in advance
 
Old 08-06-2010, 04:36 PM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154
https://lists.ubuntu.com/archives/ub...ly/087620.html
Quote:
Ubuntu uses the Debian model, and the default runlevel is 2, unless
otherwise configured - so init 3 won't help, I'm afraid, unless you
enjoy reconfiguring runlevels .

If you have the file /etc/X11/default-display-manager you can edit it or
do

echo "false" | sudo tee /etc/X11/default-display-manager

This will disable gdm/kdm/xdm , or whatever you have in that file

You can put it back with a text editor, or do for example

echo "/usr/sbin/gdm" | sudo tee /etc/X11/default-display-manager

Of course, for a temporary disabling of X you can just do

sudo /etc/init.d/gdm stop then use the "restart" option or the
"start" option of that init.d script to restart it.
 
1 members found this post helpful.
Old 08-06-2010, 04:37 PM   #3
dcatiii
LQ Newbie
 
Registered: Apr 2010
Location: Dallas, TX
Distribution: Arch, Ubuntu, Redhat
Posts: 26

Rep: Reputation: 0
I believe a post listed in another thread may help you out...

Quote:
farslayer
Guru

Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: Debian Lenny / Squeeze / Sid
Posts: 7,216
Blog Entries: 5
Thanked: 247

Debian (Ubuntu) starts services in run level 2, so trying to change what starts by editing the run level probably isn't going to get you what you want..

The easy way to do this is to disable gdm (or kdm / xdm depending on your config)
mv /etc/rc2.d/S99gdm /etc/rc2.d/K99gdm
on startup you will then login to a normal text console.


alternately you could install rcconf or sysv-rc-conf and use that to modify the sysv startup..
apt-get install sysv-rc-conf
sysv-rc-conf --level 2345 gdm off


a simple startx will launch your desktop after login, if you so desire.
 
1 members found this post helpful.
Old 08-06-2010, 04:38 PM   #4
dcatiii
LQ Newbie
 
Registered: Apr 2010
Location: Dallas, TX
Distribution: Arch, Ubuntu, Redhat
Posts: 26

Rep: Reputation: 0
lol... 1 minute before mine ;[ but his came from his knowledge... mine was "borrowed"...
 
0 members found this post helpful.
Old 08-06-2010, 04:59 PM   #5
linus72
LQ Guru
 
Registered: Jan 2009
Location: Gordonsville-AKA Mayberry-Virginia
Distribution: PocketWriter/MinimalX
Posts: 5,087

Rep: Reputation: 337Reputation: 337Reputation: 337Reputation: 337
to do so without disabling GDM, etc edit Grub2 kernel line
and add "text" and it will boot to console...
 
1 members found this post helpful.
Old 08-06-2010, 05:14 PM   #6
professorgenival
LQ Newbie
 
Registered: Aug 2010
Posts: 20

Original Poster
Rep: Reputation: 1
I'm having some problem but I think that it's because I'm using vmware...

When a try to stop gdm /etc/init.d/gdm stop... The system halt e show the message:


Checking Battery State... [ok]


Thanks all..
 
Old 08-06-2010, 05:21 PM   #7
tealio
LQ Newbie
 
Registered: Aug 2010
Location: Atlanta, GA
Distribution: Ubuntu 10.04
Posts: 23

Rep: Reputation: 18
Similar issue... I want to init 1 occasionally. When I
Code:
sudo init 1
ubuntu goes to the exit splash screen and gets stuck there. When I do a hard reset at this point, it reboots at run level 2. Would the sysv-rc-conf be the way to go?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Change RunLevel carlosinfl Debian 6 05-09-2006 08:00 PM
Change runlevel jstephens84 Debian 4 01-02-2006 06:25 PM
Change runlevel in ubuntu (Debian) GNUROCKS Linux - Newbie 2 12-12-2005 04:00 PM
Change runlevel Quiber Linux - Software 1 01-11-2005 12:27 AM
how do i change my runlevel pguru Linux - Newbie 5 08-13-2004 02:51 PM


All times are GMT -5. The time now is 10:53 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration