LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-22-2003, 05:06 AM   #1
black
Member
 
Registered: Jul 2002
Location: nowhere
Distribution: GNU
Posts: 118

Rep: Reputation: 15
how to change resolution ?


hi all~

i set the resolution too high when installing redhat system, and i found nowhere to fix it, any suggestions ?
 
Old 11-22-2003, 05:22 AM   #2
linksocc
Member
 
Registered: Jul 2003
Location: US
Distribution: Mandrake 9.0 1st/9.1 2nd/Gentoo 1.4 now
Posts: 313

Rep: Reputation: 30
use ctrl+alt+keypad_minus
 
Old 11-22-2003, 10:55 AM   #3
trallith
LQ Newbie
 
Registered: Nov 2003
Posts: 21

Rep: Reputation: 15
you set the possible resolutions for your screen in /etc/X11/XF86Config-4 under Section "Screen"

Find the Subsection "Display" for the Colordepth you default to, and just add a the resolution you want at the beginning of the line to make it the default resolution for that depth.

If have multiple resolutions for a given screen you can rotate through them by Ctrl+alt+keypad(-/+)
 
Old 11-24-2003, 08:10 AM   #4
black
Member
 
Registered: Jul 2002
Location: nowhere
Distribution: GNU
Posts: 118

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by trallith
you set the possible resolutions for your screen in /etc/X11/XF86Config-4 under Section "Screen"

Find the Subsection "Display" for the Colordepth you default to, and just add a the resolution you want at the beginning of the line to make it the default resolution for that depth.

If have multiple resolutions for a given screen you can rotate through them by Ctrl+alt+keypad(-/+)
one thousand thanx for u i'll try that thanx again
 
Old 11-25-2003, 08:04 AM   #5
black
Member
 
Registered: Jul 2002
Location: nowhere
Distribution: GNU
Posts: 118

Original Poster
Rep: Reputation: 15
gosh i failed...

This is the original "Display" block in that file:

Code:
Subsection "Display"
	Depth	24
	Modes	"1152x864"
EndSubsection
and i tried this:
Code:
Subsection "Display"
	Depth	24
	Modes	"1024x768"
	Modes	"1152x864"
EndSubsection
failed, then i tried this:
Code:
Subsection "Display"
	Depth	24
	Modes	"1024x768"
	Depth	24
	Modes	"1152x864"
EndSubsection
failed again, what on earch should i do ???

Last edited by black; 11-25-2003 at 08:17 AM.
 
Old 11-25-2003, 08:22 AM   #6
jazzyjazz
Member
 
Registered: Oct 2003
Location: Brussels
Distribution: Slackware-current
Posts: 42

Rep: Reputation: 15
Have u tried just to put this ? :

Subsection "Display"
Depth 24
Modes "1024x768"
EndSubsection


U should put modes in one line if u want multiple entries

Like this :

Subsection "Display"
Depth 24
Modes "1024x768" "1152x864"
EndSubsection


Otherwise if u do like u did i think he's gonna try to start too resolution in one time wich causes the failure while in line he switches to the seconds in the first doesnt work


Hope this helps
 
Old 11-25-2003, 08:37 AM   #7
black
Member
 
Registered: Jul 2002
Location: nowhere
Distribution: GNU
Posts: 118

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by jazzyjazz
Have u tried just to put this ? :

Subsection "Display"
Depth 24
Modes "1024x768"
EndSubsection


U should put modes in one line if u want multiple entries

Like this :

Subsection "Display"
Depth 24
Modes "1024x768" "1152x864"
EndSubsection


Otherwise if u do like u did i think he's gonna try to start too resolution in one time wich causes the failure while in line he switches to the seconds in the first doesnt work


Hope this helps
thanx jazzyjazz i tried that but failed either, after that modification nothing happened even if i grabbed Ctrl+Alt+minus and Ctrl+Alt+plus one hundred times. Or should i run something to make it work ?
 
Old 11-25-2003, 09:10 AM   #8
trallith
LQ Newbie
 
Registered: Nov 2003
Posts: 21

Rep: Reputation: 15
Look at the top of that section, and make sure
DefaultColorDepth 24

and make sure the line DontZoom is either commented out, or is not present.
What jazzyjazz said should work.

Just to test it, add another mode to that line like "800x600" and then test switching a couple of times.
 
Old 11-25-2003, 09:37 AM   #9
black
Member
 
Registered: Jul 2002
Location: nowhere
Distribution: GNU
Posts: 118

Original Poster
Rep: Reputation: 15
oh yes i got it, i set this resolution as follows:

Code:
Modes	"800x600" "1024x768" "1152x864"
and after i relogin the system it works, Cheers~~~

but, something looks very strange, ie it defaults to 800x600 and always display part of the whole screen, and the screen scrolls only when mouse reaches one of the edges, how to get a fullscreen plz ???
 
Old 11-25-2003, 10:24 AM   #10
jazzyjazz
Member
 
Registered: Oct 2003
Location: Brussels
Distribution: Slackware-current
Posts: 42

Rep: Reputation: 15
Well if u have default 800x600 is because it is written in first place in your Modes line

The fact that when u reach the edge of ur screen ur desktop moves could be due to the fact that in ur XF86 config file Virtual desktop is enabled.

Try to find for virtual desktop in ur config file and change the input for that line
 
Old 11-26-2003, 07:10 AM   #11
black
Member
 
Registered: Jul 2002
Location: nowhere
Distribution: GNU
Posts: 118

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by jazzyjazz
Well if u have default 800x600 is because it is written in first place in your Modes line

The fact that when u reach the edge of ur screen ur desktop moves could be due to the fact that in ur XF86 config file Virtual desktop is enabled.

Try to find for virtual desktop in ur config file and change the input for that line
is that section named virtual desktop ? i coulnd found that item just get a "monitor" section...or is that in other file named XF86Config ?
 
Old 11-26-2003, 07:44 AM   #12
jazzyjazz
Member
 
Registered: Oct 2003
Location: Brussels
Distribution: Slackware-current
Posts: 42

Rep: Reputation: 15
i'm not sure where exactly it is, but if you open the config file in any text editor, just hit Ctrl+F too look for the word
 
Old 11-26-2003, 10:03 PM   #13
black
Member
 
Registered: Jul 2002
Location: nowhere
Distribution: GNU
Posts: 118

Original Poster
Rep: Reputation: 15
i searched bot XF86Config and XF86Config-4 but found no "virtual desktop"
 
Old 11-26-2003, 11:53 PM   #14
twilli227
Member
 
Registered: May 2003
Location: S.W. Ohio
Distribution: Ubuntu, OS X
Posts: 760

Rep: Reputation: 30
I am running RH9 and kde. If you go to your start icon -> System Settings -> Display -> enter root password, you can change your settings there. After the change, logout and back in and your settings will take affect.
 
Old 11-27-2003, 12:08 PM   #15
lugoteehalt
Senior Member
 
Registered: Sep 2003
Location: UK
Distribution: Debian
Posts: 1,215
Blog Entries: 2

Rep: Reputation: 49
To toggle a sort of wierd, magnified, virtual desktop; which may help, do:
Ctrl-Alt-keypad +.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Text Resolution, Graphic resolution. Change from prompt dlublink SUSE / openSUSE 2 01-28-2005 12:50 PM
Can't change my resolution! Nolem SUSE / openSUSE 4 12-23-2004 08:45 AM
change resolution abs Slackware 8 03-11-2004 08:44 PM
change resolution Longinus Linux - Newbie 4 12-13-2003 03:11 PM
how to change resolution in 7.3? lpriyamb Red Hat 2 11-28-2003 10:04 PM


All times are GMT -5. The time now is 07:00 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration