LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
LinkBack Search this Thread
Old 07-04-2004, 03:19 PM   #1
mark1
LQ Newbie
 
Registered: Jul 2004
Posts: 9

Rep: Reputation: 0
How to change from twm to kde?


I have just installed xfree86 and kde, but when I "startx" I get a uggly graphical interface (I think it is just the twm window manager).

I just couldnt find what to change in order so that when i type startx, the KDE desktop environment opens... Any ideas?

Although X server seems to be installed ok (as I can get the graphical environment), I type "xwmconfig" and nothing happens! Trying "locate xwmconfig" returns nothing (locate db is up to date!)...

Thank you,
Marcelo

Last edited by mark1; 07-04-2004 at 03:22 PM.
 
Old 07-04-2004, 03:45 PM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,950
Blog Entries: 11

Rep: Reputation: 860Reputation: 860Reputation: 860Reputation: 860Reputation: 860Reputation: 860Reputation: 860
Jumping to conclusions here, you're using
Slackware? Which version?

If you issue (as root) whereis xwmconfig,
what do you get?


Cheers,
Tink
 
Old 07-04-2004, 06:39 PM   #3
mark1
LQ Newbie
 
Registered: Jul 2004
Posts: 9

Original Poster
Rep: Reputation: 0
I surely forgot to tell what distro Im using.. Its Arch Linux 0.6 (kernel 2.6.3), base distribution.

I then installed kde with "pacman -Sy kde" which downloaded and installed all the necessary modules whith their dependecies.

Issuing "whereis xwmconfig" returns just this single line:
xwmconfig:

and nothing else. Ive tried removing and reinstalling the packages with "pacman" with no success.

tks,

Mark
 
Old 07-04-2004, 06:58 PM   #4
vdogvictor
Member
 
Registered: Feb 2004
Distribution: Arch
Posts: 498

Rep: Reputation: 31
what about this

startx kde

or you can run this from inside twm

kde
 
Old 07-04-2004, 08:49 PM   #5
Poprocks
Member
 
Registered: Sep 2003
Location: Toronto, Canada
Distribution: Slackware
Posts: 194

Rep: Reputation: 26
edit your ~/.xinitrc file -- it's a bash script -- you should be able to replace whatever's in it with these two lines:
Code:
#!/bin/bash
startkde
Then try startx again, and you should be in for a pleasant surprise
 
Old 07-04-2004, 09:00 PM   #6
mark1
LQ Newbie
 
Registered: Jul 2004
Posts: 9

Original Poster
Rep: Reputation: 0
vdogvictor

Trying "startx kde" returns "bad command line option 'kde'"
Trying "kde" inside the twm: "bash: kde: command not found"

Poprocks

Tried your suggestion, it opens the graphical X but issues the following error:

"Could not start kdeinit. Check your installation." It seems that kde was not installed correctly, but using pacman (Archs default package manager), everything seems to install perfectly!

tks,
Mark
 
Old 07-04-2004, 09:20 PM   #7
scuzzman
Senior Member
 
Registered: May 2004
Location: Hilliard, Ohio, USA
Distribution: Slackware, Kubuntu
Posts: 1,851

Rep: Reputation: 47
or: in your home dir, put a file called
.xinitrc

mine looks like this:
Code:
#gnomesession
#startkde
#icewm
fluxbox
#blackbox
see how the fluxbox doesn't have an # in front of it
that means when i startx, it loads fluxbox
simply create this file in your ~ directory, replacing the windowmanagers you have with the ones in my .xinitrc
when you want to switch window managers, ie from fluxbox to kde, simply move the # likewise
hope this helps!
 
Old 07-05-2004, 03:03 PM   #8
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,950
Blog Entries: 11

Rep: Reputation: 860Reputation: 860Reputation: 860Reputation: 860Reputation: 860Reputation: 860Reputation: 860
Quote:
Originally posted by scuzzman
or: in your home dir, put a file called
.xinitrc

mine looks like this:
Code:
#gnomesession
#startkde
#icewm
fluxbox
#blackbox
That must b the shortest ~/.xinitrc I've ever seen ...
Considering that it's supposed to be modelled after
the xinitrc's that X usually utilises :}

locate xinitrc | grep X | xargs less


Cheers,
Tink
 
Old 07-05-2004, 03:42 PM   #9
scuzzman
Senior Member
 
Registered: May 2004
Location: Hilliard, Ohio, USA
Distribution: Slackware, Kubuntu
Posts: 1,851

Rep: Reputation: 47
ok - but this works just fine. is the rest just pageantry? or would it be causing the problems i'm seeing in this thread?
http://www.linuxquestions.org/questi...hreadid=198910
 
Old 07-06-2004, 08:59 AM   #10
mark1
LQ Newbie
 
Registered: Jul 2004
Posts: 9

Original Poster
Rep: Reputation: 0
Thumbs up Fixed!

Thanks for the replies!

Saw what you told about xinitrc, Tinkster... Ive done like scuzzman told, though, "before" realizing what the real problem was, so it is really short in my home directory, with no problem at all...

Found and fixed my problem: analizing Xs logs, saw that libstdc++.so.6 was missing. Did a "pacman -Sy gcc" wich downloaded and installed gccs package with the missing library. Then typed ldconfig to update all the libs mappings and voil! startx brings up my brand new KDE desktop...

Thanks again people! Im newbie when it comes to Linux..

bye,
Mark
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
howto change screen resolution in TWM? minike Linux - Software 2 07-10-2005 06:32 AM
xvnc - make it default to kde not twm batfastad Linux - Software 1 11-18-2004 03:53 PM
How do i get rid of twm and go back to KDE? MadSkillzMan Linux - General 2 07-29-2004 02:43 PM
Twm ! Cdzin Slackware 1 07-30-2003 01:51 PM
Help with TWM. jake Linux - General 0 01-21-2002 06:12 AM


All times are GMT -5. The time now is 11:25 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration