LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-18-2007, 11:07 PM   #1
mhg
Member
 
Registered: Apr 2007
Location: Utah
Distribution: BodhiLinux
Posts: 205

Rep: Reputation: 30
how to change automount permissions in Ubuntu


Hi All,

I tried posting this in the Ubuntu part of the Linux distributions, but so far no help there. Maybe someone here can help?



Just starting to try and learn/use Linux. Working through a problem with Ubuntu.

Being a NOOB, I am not sure how to best describe what I am dealing with.

I have a wireless device that streams music from my PC to home stereo. This device uses some type of server software. I knew just barely enough to use the instructions on the device web page to add the installation to synaptic and get it installed. Very cool.

I have all my music files on an external HHD, formated NFTS. I can see the files, and Totem will play the files. The problem is that I need to tell the server where to find the files. I browse to the folder, copy and paste the file path to the server settings, and get the message there is no such directory.

In this thread: http://forums.slimdevices.com/showthread.php?t=35254 , the folks there are thinking it is an issue of the server not having the correct permissions for accessing this external drive. Keep in mind most of this is still over my head, I am so new to Linux and command lines.

IF I understand correctly what folks are telling me, Ubuntu sees my server (slimserver) as a user, and that user needs the proper permissions to access the drive.

Now I don't know if that makes sense to anyone but me, but I think what I am attempting to learn, is how to set automount permissions for this drive, and hopefully any other USB drive. It was explained in the other thread that I do not want a permanent mount, or permissions for this drive only, as I will want to be able to also use USB for camera, thumb drive etc.

So far I am very happy with Ubuntu. I also have PCLinuxOS installed, but have been stuck with this one problem with Ubuntu. I definitely need to figure out this type of issue in order to use Linux as my main OS.

Should I post this in the newbie forum instead of the Ubuntu forum?

Thanks for any help.
 
Old 05-18-2007, 11:33 PM   #2
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
Quote:
Originally Posted by mhg
Hi All,
I have a wireless device that streams music from my PC to home stereo. This device uses some type of server software. I knew just barely enough to use the instructions on the device web page to add the installation to synaptic and get it installed. Very cool.
best to state at the outset what the device is called ... try "lsusb" to see how it declaires itself.
Quote:
In this thread: http://forums.slimdevices.com/showthread.php?t=35254 , the folks there are thinking it is an issue of the server not having the correct permissions for accessing this external drive.

IF I understand correctly what folks are telling me, Ubuntu sees my server (slimserver) as a user, and that user needs the proper permissions to access the drive.
If so, then there will be a user or group associated with the device. Examine the menu/dialog in system > administration > users and groups. It may just be a matter of adding slimserver to the audio group.
Quote:
Now I don't know if that makes sense to anyone but me, but I think what I am attempting to learn, is how to set automount permissions for this drive, and hopefully any other USB drive. It was explained in the other thread that I do not want a permanent mount, or permissions for this drive only, as I will want to be able to also use USB for camera, thumb drive etc.
Well, check the existing permissions with ls -l ... also check if the drive is listed in fstab and mtab. Try changing the drive permissions and seeing if slimserver magically starts going.

sudo chmod 777 /media/usbdrive

This gives everyone r/w permission.
 
Old 05-19-2007, 12:04 PM   #3
mhg
Member
 
Registered: Apr 2007
Location: Utah
Distribution: BodhiLinux
Posts: 205

Original Poster
Rep: Reputation: 30
User groups does not show slimserver.

The device is a SlimDevices Squeezebox.

Here are the replies I got form the command lines you suggested:

mike@mike-desktop:~$ lsusb
Bus 005 Device 002: ID 136b:cb07
Bus 005 Device 001: ID 0000:0000
Bus 004 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000

mike@mike-desktop:~$ ls -l
total 10388
-rw-r--r-- 1 mike mike 13574 2007-05-18 17:09 command line replies.odt
drwxr-xr-x 2 mike mike 4096 2007-05-14 20:11 Desktop
lrwxrwxrwx 1 mike mike 26 2007-05-10 12:30 Examples -> /usr/share/example-content
drwx------ 2 mike mike 4096 2007-05-11 19:36 memo_file
drwxr-xr-x 3 mike mike 4096 2007-05-12 19:01 music
drwx------ 2 mike mike 4096 2007-05-11 19:34 MyPDA
drwxr-xr-x 2 mike mike 4096 2007-05-12 18:35 test files
-rw-r--r-- 1 mike mike 5286856 2007-05-14 20:02 translog.20070514200145.log
-rw-r--r-- 1 mike mike 5286900 2007-05-14 20:16 translog.20070514201022.log

mike@mike-desktop:~$ fstab
bash: fstab: command not found
mike@mike-desktop:~$ mtab
bash: mtab: command not found
mike@mike-desktop:~$ sudo chmod 777 /media/usbdrive
chmod: cannot access `/media/usbdrive': No such file or directory
mike@mike-desktop:~$ sudo chmod 777 /media/SimpleDrive
chmod: changing permissions of `/media/SimpleDrive': Read-only file sys

SimpleDrive is the USB external HHD.

Does this help to narrow the issue down?

Thanks for the help.
 
Old 05-20-2007, 12:47 AM   #4
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
Quote:
Originally Posted by mhg
User groups does not show slimserver.

The device is a SlimDevices Squeezebox.

Here are the replies I got form the command lines you suggested:

mike@mike-desktop:~$ lsusb
Bus 005 Device 002: ID 136b:cb07
...cool: got it.
Quote:
mike@mike-desktop:~$ ls -l
total 10388
...nonono... for the drive!
<looks ahead>

ls -l /media
ls -l /media/SimpleDrive
Quote:
mike@mike-desktop:~$ fstab
bash: fstab: command not found
mike@mike-desktop:~$ mtab
bash: mtab: command not found
These are config files, not commands...

cat fstab
cat mtab
Quote:
mike@mike-desktop:~$ sudo chmod 777 /media/usbdrive
chmod: cannot access `/media/usbdrive': No such file or directory
mike@mike-desktop:~$ sudo chmod 777 /media/SimpleDrive
chmod: changing permissions of `/media/SimpleDrive': Read-only file sys
ahh... you figured it out for yourself! Well done: theres hope for you yet

Don't see how this is a read-only file system... how is it formatted?

sudo chmod 555 /media/SimpleDrive

fdisk -l
 
Old 05-20-2007, 02:39 PM   #5
mhg
Member
 
Registered: Apr 2007
Location: Utah
Distribution: BodhiLinux
Posts: 205

Original Poster
Rep: Reputation: 30
OK, was able to get issue with server kind of straightened out.

A person posted a command line that would change the umask of the drive to 022 so all can read/write. Trouble is, he told he knew it did nothing for automount issues. So every time I unplug the drive, I have to unmount and remount with his command line.

What I need is a way to change the automount options for Ubuntu 6.10.

I am told this is not an issue with V 7.04.

Any suggestions?

Thank You.
 
Old 05-22-2007, 06:00 AM   #6
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
Please quote the successful commandline and/or reply to questions in my last post. Preferably both.
 
Old 05-22-2007, 09:36 PM   #7
mhg
Member
 
Registered: Apr 2007
Location: Utah
Distribution: BodhiLinux
Posts: 205

Original Poster
Rep: Reputation: 30
mike@mike-desktop:~$ ls -l /media/SimpleDrive
total 16
dr-x------ 1 mike mike 4096 2007-05-08 18:38 back up
dr-x------ 1 mike mike 8192 2007-05-09 17:20 music
dr-x------ 1 mike mike 0 2007-04-16 18:05 RECYCLER
dr-x------ 1 mike mike 4096 2007-04-15 18:14 System Volume Information
mike@mike-desktop:~$ sudo chmod 555 /media/SimpleDrive
Password:
chmod: changing permissions of `/media/SimpleDrive': Read-only file system
mike@mike-desktop:~$

The external is NTFS, as I am just beginning to see if I can migrate to Linux.

Almost to the point where I need to slow down, use Linux as I can until I learn more. This issue has me stumped. I got some links from another thread:
http://www.debian-administration.org/articles/127
http://www.linuxhq.com/lg/issue24/nielsen.html

As a NOOB, still struggling to use command line, but will try reading through these articles.

Not sure if I have given you the info you need.

Thanks for helping.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
automount permissions for external USB HHD mhg Ubuntu 4 11-25-2009 02:44 AM
Change Default Home Directory with LDAP and Automount greslore Linux - General 3 06-23-2009 04:32 PM
Automount DVD Drive w/ Permissions jerm1701 Linux - General 4 03-02-2006 06:00 PM
Howto set permissions and automount for new drive? andymadigan Debian 4 08-02-2004 11:17 PM
Automount permissions Galizah Mandriva 0 05-07-2004 10:58 AM


All times are GMT -5. The time now is 02:00 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration