LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-03-2012, 05:25 AM   #1
mzzxx11
Member
 
Registered: Sep 2012
Posts: 78

Rep: Reputation: Disabled
how to autoload a manufacturer module at boot


Im using an Edimax usb wifi adapter, and the Edimax provide their proprietry linux kernel module.

How do I make my debian stable system auto load this module at boot?

TIA
 
Old 10-03-2012, 05:58 AM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154
Are you sure that the required module isn't already present on your OS ?

Which Edimax ? Edimax use one of: zd1211rw.ko, rt73usb.ko, rt2800usb.ko.
http://wireless.kernel.org/en/users/Devices/USB
 
Old 10-03-2012, 07:25 AM   #3
mzzxx11
Member
 
Registered: Sep 2012
Posts: 78

Original Poster
Rep: Reputation: Disabled
the stock module r8192s_usb isnt good, since it causes random disconnects.

Im now using the Edimax module and so far zero problerms.

But, I want to have it loaded auto. on boot
 
Old 10-03-2012, 07:42 AM   #4
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154
I guess you can do like the example mentioned here
http://kernel-handbook.alioth.debian...h-modules.html
" /etc/modprobe.d/local file ..... : options libata atapi_enabled=1 "

Other hit with Google .. debian load modules ..
http://www.cyberciti.biz/faq/linux-h...-at-boot-time/

.
 
Old 10-03-2012, 08:39 AM   #5
mzzxx11
Member
 
Registered: Sep 2012
Posts: 78

Original Poster
Rep: Reputation: Disabled
Thanks, the first link solved my problem :-)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] How to extract module names and append to modules.autoload.d bianchiaz Linux - Newbie 4 09-07-2009 10:24 AM
How to autoload a kernel module using rc.local? nikhil86 Programming 1 04-03-2008 05:21 AM
prevent module autoload tovis Debian 2 10-02-2007 04:53 AM
Disable hotplug autoload of usb_storage module exodist Linux - General 3 08-16-2006 08:44 AM
mepis 3.3 with 2.6.10 kernel e1000 nic module autoload bredfern Linux - Hardware 0 06-02-2005 05:49 PM


All times are GMT -5. The time now is 09:04 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration