LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-02-2009, 08:03 AM   #1
mcdimus
LQ Newbie
 
Registered: Jun 2009
Posts: 2

Rep: Reputation: 0
How to auto-load a custom module?


Hallo.

Sorry for my bad language skills, but hope you will understand.


I am using Ubuntu 9.04 on Thinkpad SL400 and I need to install lenovo-sl-laptop driver for hot-keys and back-light control.
Here is a short manual, which I have used: http://www.thinkwiki.org/wiki/SL_Driver_on_Ubuntu.

So it works perfectly when I manually insmod the module via "sudo insmod lenovo-sl-laptop.ko". But I would like it to load automatically. I did exactly the 5th step, although module does not load at startup. What is more I have noticed that the module "lenovo-sl-laptop.ko" disappeared from "volatile" folder after reboot.

I would be grateful, if somebody could tell me how to do the trick.

Thank you,

Dmitri.
 
Old 06-03-2009, 01:57 AM   #2
rikxik
Member
 
Registered: Dec 2007
Posts: 88

Rep: Reputation: 19
1. AGAIN verify that you are manually lsmod (to confirm if you have the original .ko files in right place). If not, you need to reinstall them. No need to move to volatile etc.
2. create a file /etc/modprobe.d/lenovo-sl-laptop.conf which just has one line: 'options lenovo-sl-laptop control_backlight=1' (this tells modprobe to load the module with backlight control enabled)
3. edit the /etc/modules file and add the line 'lenovo-sl-laptop' to the end
4. Reboot. If still not working, check /var/log/messages and /var/log/syslog
 
Old 06-03-2009, 04:36 PM   #3
mcdimus
LQ Newbie
 
Registered: Jun 2009
Posts: 2

Original Poster
Rep: Reputation: 0
The module `lenovo-sl-laptop.ko` is in the folder on my desktop. And then I "cd" to this directory and "insmod lenovo-sl-laptop" - it works.

I have created a file /etc/modprobe.d/lenovo-sl-laptop.conf and have edited the /etc/modules file as well.

I have checked /var/log/messages and /var/log/syslog, there is no word about `lenovo-sl-laptop` after rebooting.

So it is still not auto-loading.

Last edited by mcdimus; 06-03-2009 at 04:37 PM.
 
Old 06-04-2009, 03:04 AM   #4
rikxik
Member
 
Registered: Dec 2007
Posts: 88

Rep: Reputation: 19
I don't have access to a linux m/c now - you can try copying the .ko files to the usual place for modules (/usr/lib/ ??). After that, do insmod from a different directory, say, /tmp. If it picks up, then you should be ok.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
need help to prevent auto load of module at boot keratos Debian 11 08-31-2008 08:33 AM
auto load sound module charafantah Linux - Hardware 4 03-05-2006 08:54 AM
Module Auto-Load: module.conf tricks? m_e_perry Linux - Newbie 3 10-07-2004 06:45 PM
Problem with module auto-loading (load on demand) in kernel 2.6.7 (2.6.x too) Cyb3rPr0 Linux - Software 4 07-02-2004 01:57 AM
problem with auto. module load subguru Slackware 2 08-09-2003 03:28 PM


All times are GMT -5. The time now is 08:57 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration