LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-20-2011, 02:56 PM   #1
R_AD
LQ Newbie
 
Registered: Jul 2011
Posts: 6
Blog Entries: 1

Rep: Reputation: Disabled
Unhappy How To Add Windows 7 To GRUB Boot Entry. ?


Hello All!, I have Recently downloaded Fedora 15.|64bit| & I Think its a very good distro. However I Realised Once My Pc Restarted My Windows 7 Was Removed from my boot entry. I am Not At All familar with Linux, Ive Read millions of forums trying to fix my problem but all has failed.Could someone show me how to add The OS Back or How To Burn A Bootable OS (Win7) Using This Distro Of Linux. I Would really be very appreciative of this help.



Thanks In Advance.
 
Old 07-20-2011, 04:19 PM   #2
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, SLES, CentOS, Red Hat
Posts: 2,385

Rep: Reputation: 477Reputation: 477Reputation: 477Reputation: 477Reputation: 477
@ Reply

Hi there,

Welcome to LQ!!!

If Windows 7 was the first operating system that you installed on the system and over it you have installed Fedora 15 the you can try the following steps to get your Windows 7 entry back:

1. Boot into Fedora 15.
2. Login.
3. Open up terminal.
4. Type: su - root and enter the root password.
5. Backup /boot/grub/grub.conf file using the following command: cp /boot/grub/grub.conf /boot/grub/grub.bak
6. vi /boot/grub/grub.conf and then hit insert key. Scroll to bottom of the page and then put the following entries at the end of the file:

Code:
title Windows 7

           rootnoverify (hd0,1)
           chainloader +1
7. Hit escape key and then press : and type wq to write the changes.
8. Reboot your system and see if you are able to get Windows 7.
 
1 members found this post helpful.
Old 07-20-2011, 04:34 PM   #3
R_AD
LQ Newbie
 
Registered: Jul 2011
Posts: 6
Blog Entries: 1

Original Poster
Rep: Reputation: Disabled
Great Thanks Alot!. However I Now experience a new problem, when i try to boot windows 7
i get this error: Filename must be an absolute pathname or blocklist. Any Knowlege of what happened?

Last edited by R_AD; 07-20-2011 at 04:44 PM.
 
Old 07-20-2011, 04:39 PM   #4
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, SLES, CentOS, Red Hat
Posts: 2,385

Rep: Reputation: 477Reputation: 477Reputation: 477Reputation: 477Reputation: 477
@ Reply

From the output I can see (hd0,1) is in use by Fedora so it appears that your Windows should be on (hd0,0). Make the changes as follows:

Code:
# kernel /boot/vmlinuz-version ro root=/dev/sda2
# initrd /boot/initrd-[generic-]version.img
#boot=/dev/sda
default=0
timeout=0
splashimage=(hd0,1)/boot/grub/splash.xpm.gz
hiddenmenu
title Fedora (2.6.38.8-35.fc15.x86_64)
root (hd0,1)
kernel /boot/vmlinuz-2.6.38.8-35.fc15.x86_64 ro root=UUID=05f9d427-1f75-4011-9557-e9f24fc98845 rd_NO_LUKS rd_NO_LVM rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYTABLE=us rhgb quiet
initrd /boot/initramfs-2.6.38.8-35.fc15.x86_64.img
title Fedora (2.6.38.6-26.rc1.fc15.x86_64)
root (hd0,1)
kernel /boot/vmlinuz-2.6.38.6-26.rc1.fc15.x86_64 ro root=UUID=05f9d427-1f75-4011-9557-e9f24fc98845 rd_NO_LUKS rd_NO_LVM rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYTABLE=us rhgb quiet
initrd /boot/initramfs-2.6.38.6-26.rc1.fc15.x86_64.img

title Windows 7

rootnoverify (hd0,0)
chainloader +1
When you will hit the escape key then you can type : (semicolon) this will give you a : prompt at the bottom of the vi screen (vi is an editor using which you are editing the file as I mentioned in the my previous post). At : prompt you have to type wq and then hit enter. Once done reboot your system.
 
1 members found this post helpful.
Old 07-20-2011, 04:49 PM   #5
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 7,280

Rep: Reputation: 1380Reputation: 1380Reputation: 1380Reputation: 1380Reputation: 1380Reputation: 1380Reputation: 1380Reputation: 1380Reputation: 1380Reputation: 1380
Cool

Quote:
Ive Read millions of forums trying to fix my problem
Millions??

Are you trying to use the Fedora bootloader?
Did you install the Fedora bootloader to the master boot record?
Did you install the Fedora bootloader to its partition?
Did you install Fedora to a separate partition from windows?

Fedora is very good at detecting windows partitions and adding an entry to its boot menu. I would guess based on the limited information you provided that you either did not install the Fedora bootloader to the master boot record or you installed Fedora to the same partition as windows.

If you could post drive/partition information it would help someone to help you. Boot Fedora, click the Applications tab on the Desktop and find the terminal, open it and enter: su -, you will be prompted for your root password. Enter it and the type the command: fdisk -l, (loweer case letter L in the command) this will give your partition information to post here so someone can give you more specific instructions on how to solve your problem.

The solution suggested above will work if:

your windows boot files are on the second partition of the first drive,
you install Fedora bootloader to the mbr,
you didn't overwrite your windows partition.
 
2 members found this post helpful.
Old 07-20-2011, 04:52 PM   #6
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, SLES, CentOS, Red Hat
Posts: 2,385

Rep: Reputation: 477Reputation: 477Reputation: 477Reputation: 477Reputation: 477
@ Reply

Did you try edited steps that I have mentioned in my previous post? If yes, then boot into Fedora 15 and let me know the output of your /boot/grub/grub.conf file. You can get this using the following commands:

1. Login.
2. Open up terminal.
3. In the terminal type: su - root
4. Then type: cat /boot/grub/grub.conf , this command will display the output of the grub.conf file. Paste the output here.

And yes, Yancek is right. I hope you have not formatted the the hard disk and installed Fedora 15 on it. I also hope that you selected custom partition layout during Fedora 15 installation.

Last edited by T3RM1NVT0R; 07-20-2011 at 04:54 PM.
 
Old 07-20-2011, 05:13 PM   #7
R_AD
LQ Newbie
 
Registered: Jul 2011
Posts: 6
Blog Entries: 1

Original Poster
Rep: Reputation: Disabled
Thank You ALL. T3RM1NVT0R!! It Is A Success!!. How Much Times Do I Need To Thank You?
I Swear You're A Genius Or Something. & Yes I Selected Custom Installation, A Forum Told Me To Remove Windows 7 Entry, as they said i shouldnt Use GRUB 2. Which Was Stupid Of Me To Do.

Last edited by R_AD; 07-20-2011 at 05:14 PM.
 
Old 07-20-2011, 06:04 PM   #8
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, SLES, CentOS, Red Hat
Posts: 2,385

Rep: Reputation: 477Reputation: 477Reputation: 477Reputation: 477Reputation: 477
@ Reply

Great!!! Glad to hear that you got it working. You're welcome. Please mark this thread as solved.
 
Old 07-20-2011, 07:37 PM   #9
R_AD
LQ Newbie
 
Registered: Jul 2011
Posts: 6
Blog Entries: 1

Original Poster
Rep: Reputation: Disabled
Quick question... Just ran into a prob.. I just formatted the partition that contains fedora 15 using windows.. Now when I attempt to boot my PC the grub bootloader comes up and I cannot boot anything.... The error that I get|| i feel i need a boot command to boot boot win7 from grub... grub propmts me " minimal bash-like line editing is supported. for the first word tab possible list a possible commands completion anywhere else tab list
 
Old 07-20-2011, 11:44 PM   #10
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 7,280

Rep: Reputation: 1380Reputation: 1380Reputation: 1380Reputation: 1380Reputation: 1380Reputation: 1380Reputation: 1380Reputation: 1380Reputation: 1380Reputation: 1380
Almost all of the Grub bootloader files are on the Fedora partition with 512 bytes in the master boot record. By formatting the Fedora partition you have removed almost all the Grub files so you can't use it to boot. Windows can't boot Linux systems without third party software.

Why did you delete Fedora partition? I thought you had it working?
What exactly is it that you want to do? Windows only? If so, you can repair the windows bootloader with your windows 7 installation disk. If you don't have one, you can download one at this site:

http://neosmart.net/blog/2009/window...-repair-discs/

If you can't boot anything, you'll need to use another computer.
 
Old 07-21-2011, 08:01 AM   #11
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, SLES, CentOS, Red Hat
Posts: 2,385

Rep: Reputation: 477Reputation: 477Reputation: 477Reputation: 477Reputation: 477
@ Reply

Yes it will come to grub> prompt because you have formatted the Fedora 15 partition which contains the bootloader. If you want your Windows 7 back then you have to use Windows 7 DVD to get into recovery console and then from recovery console you have to run the following command:

Code:
bootrec.exe /fixmbr
This will fix the booting issue as after running this command your Windows 7 will boot using its own bootloader.
 
Old 08-24-2011, 11:11 PM   #12
R_AD
LQ Newbie
 
Registered: Jul 2011
Posts: 6
Blog Entries: 1

Original Poster
Rep: Reputation: Disabled
Thank You All, For Your Help. Big Learning Process For Me. =].XD. Everythings Okay Now,Ive Repaired Fedora However Grub Still Controls Booting. Ive Tried BCD Manager, And It says error and request for a registry file,That should be manually located. This Is Not Much Of A Problem, Also My Fedora Stops Working, when i attempt to log on, It Says an error has occured, please try again later. o.0.
 
Old 09-08-2011, 06:38 AM   #13
salemeni
Member
 
Registered: Aug 2011
Posts: 64

Rep: Reputation: Disabled
You can look here
https://help.ubuntu.com/community/Re...tallingWindows

java socket

Last edited by salemeni; 01-26-2012 at 07:27 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Add Windows XP entry to GRUB bforbes Linux - Software 16 05-25-2011 11:08 AM
how do i add linux to windows boot entry nikhil778 Linux - General 1 08-30-2003 10:59 AM
How to add a boot record which used to startup windows under my Grub boot loader? yunxiang Linux - Newbie 6 02-01-2003 02:22 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 11:33 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration