LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-18-2006, 05:14 PM   #1
hawkwing3141
LQ Newbie
 
Registered: May 2005
Posts: 2

Rep: Reputation: 0
How I set up a DVD+RW in Slackware 10.2 with linux 2.6.13, plus irrelevant tangent


This may all be self-evident to the majority of readers or buried in some HOW-TO that I haven't read, but it took me forever to get it working, so I thought I would post here in case it could help someone else... YMMV. It seems all the answers I could find out there are for the 2.4.x kernel but they don't always specify that and it can get confusing (for me, at least). Also, I may have failed to include below some of the things I tried. I do also have an outstanding question about K3B, below.

running:
Slackware10.2 with relevant security upgrades
Linux kernel 2.6.13

1. DO NOT ADD "append=ide-scsi" to your GRUB/LILO config file if you are using a 2.6.x kernel! It is deprecated. Maybe I'm the only one in Linuxland who didn't quite get that, but then again maybe not...

2. make sure you have a line for the device in your /etc/fstab, the pertinent lines from mine are here, and I copied these from someone else so I'm not actually sure what all the options do yet, but they work so I haven't worried about it:
Code:
/dev/cdrom       /mnt/cdrom       auto     owner,ro,user,noauto  0   0
/dev/hdc         /mnt/dvdrw       auto     owner,user,rw,noauto 0 0
/dev/cdrom goes to /dev/hdd and /dev/dvd goes to /dev/hdc though I'm not sure how they get that way. I think you cannot add your own symlink in /dev because the directory gets rewritten after every restart.

3. compile/install the alpha cdrecord 2.01.01a11 or later, which includes proper support for DVD writing. "cdrecord -scanbus" does not find my drive, but "cdrecord dev=ATAPI -scanbus" does. I installed K3B to run these programs.

4. add yourself to the "disk" group in /etc/group so you can mount your drives without being root

5. Question: I have installed dvd+rw-tools (6.1) and K3B (0.12.16 using KDE 3.4.2) finds all of them except for growisofs even though it is present, executable, and in the same directory as the rest of the tools! argh! i don't get it. k3bsetup wouldn't run in userspace (even after entering root password), so I ran it with sudo and it worked. Do i need to upgrade to KDE 3.5?

TANGENT:
Almost two years ago I finally got sick of MS and sat down to install linux for the first time, with no prior *nix experience (e.g. what does "compile" mean??). I looked around at various distros, but for some reason I chose Slackware (maybe because I found a copy of the hardcopy companion book at a used book store -- fat lot of good that did, it was so out of date it did more harm than good). I've learned a lot about linux from the experience but I have to admit I'm not sure that it has been worth the time, effort, and frustration that it took. The CD/DVD burning was the last of the many problems I have had getting slackware to work with my computer, and now that I have vanquished the problem, I'm switching to Kubuntu. I'm not interested in hearing about how great slack is for this or that user, I'm just saying I would not recommend it to a linux home user newbie, but then again I guess that is already well known.
 
Old 08-18-2006, 07:37 PM   #2
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: McCalla, AL
Distribution: Funtoo
Posts: 6,926

Rep: Reputation: 128Reputation: 128
Welcome to LQ!

How did you make it over a year as a member without posting?

Quote:
Originally posted by hawkwing3141
2. make sure you have a line for the device in your /etc/fstab, the pertinent lines from mine are here, and I copied these from someone else so I'm not actually sure what all the options do yet, but they work so I haven't worried about it
I don't know what happens when you use the drive, but this line:
Code:
/dev/hdc         /mnt/dvdrw       auto     owner,user,rw,noauto 0 0
should use ro rather than rw. Also, you need either owner, user, or users --
but not owner and user. You can learn what those mean from the manual pages
for fstab and mount.

Here are my lines in fstab for two DVD+/-RW drives:
Code:
/dev/hda         /dvd1            auto        noauto,users,ro  0   0
/dev/hdc         /dvd2            auto        noauto,users,ro  0   0
The first field is my block device. If unknown issue "dmesg | grep -i atapi".

The second field is the mount point I created. I put it right under / rather
than in /mnt so that I have less to type in command line interface (CLI).

They are automatically mounted when I boot by auto in the third field.

They are mounted explicitly by noauto in the fourth field.
The users option in the fourth field allows all users to mount/unmount them.
The ro option in the fourth field means the filesystem is mounted read-only,
since you cannot write to the filesystem of the DVD -- just to the media.

The sixth field has 0 0 which tells Slackware it does not check the filesystem,
since in reality this directory should always be empty.

Quote:
Originally posted by hawkwing3141
2. /dev/cdrom goes to /dev/hdd and /dev/dvd goes to /dev/hdc though I'm not sure how they get that way.
It is my understanding that Slackware writes the symlinks to the first available
device starting with IDE0. On my systems they are all written like this:
Code:
mingdao@silas:~/kernel/linux-2.6.17.8$ ls -lh /dev/cdrom
lrwxrwxrwx 1 root root 8 2006-07-06 09:10 /dev/cdrom -> /dev/hda
mingdao@silas:~/kernel/linux-2.6.17.8$ ls -lh /dev/dvd
lrwxrwxrwx 1 root root 8 2006-07-06 09:10 /dev/dvd -> /dev/hda
Slackware only creates three directories under /mnt:
Code:
mingdao@silas:~/kernel/linux-2.6.17.8$ ls -lh /mnt
total 0
drwxr-xr-x 2 root    root  48 2002-03-16 15:34 cdrom/
drwxr-xr-x 2 root    root  48 2002-03-16 15:34 floppy/
drwxr-xr-x 2 mingdao users 48 2002-03-16 15:34 hd/
It does not create /mnt/dvd for you.

Quote:
Originally posted by hawkwing3141
3. compile/install the alpha cdrecord 2.01.01a11 or later, which includes proper support for DVD writing. "cdrecord -scanbus" does not find my drive, but "cdrecord dev=ATAPI -scanbus" does. I installed K3B to run these programs.
You can use the default cdrecord in Slackware. In fact, I've been
burning CDs as a normal user since kernel > 2.6.8 and cdrtools-2.00.3;
and now do it with the cdrecord in Slackware-10.2 or -current, which
as of today is cdrtools-2.01.

For DVD writing I use growisofs from CLI -- and on this box K3B does, also.

Quote:
Originally posted by hawkwing3141
4. add yourself to the "disk" group in /etc/group so you can mount your drives without being root
You mount the drive according to the options in the fourth field of
/etc/fstab if they're setup properly there. I am not in the disk group.

I do add my normal user to the audio, video, and cdrom groups.

Quote:
Originally posted by hawkwing3141
5. Question: I have installed dvd+rw-tools (6.1) and K3B (0.12.16 using KDE 3.4.2) finds all of them except for growisofs even though it is present, executable, and in the same directory as the rest of the tools! argh! i don't get it. k3bsetup wouldn't run in userspace (even after entering root password), so I ran it with sudo and it worked. Do i need to upgrade to KDE 3.5?
I prefer CLI to GUI for such apps, but K3B works perfectly as a normal
user on every Slackware box I've setup. You should run k3bsetup first,
and set your drives up with it.

TANGENT:

In 2003 I was about to setup a RAID array when someone commented, "Your
system is fast enough, you should try Linux on that second drive." He
recommended RedHat, so I tried RH 9.0. If that were the only Linux distro,
I'd happily run a WinNT version (W2K or XP Pro). Thankfully, it's not.

After a couple months of DeadRat, I moved to Debian. Would have stayed with
it, except (a) I didn't know how to compile from source, (b) apt was not
my idea of sane package management, and (c) the Debian democracy could not
get KDE past Woody at the time, because 2 developers argued over some libs.

While using LQ I found that most posters whose information was correct had
Slackware listed in their sig, so I tried it. Now I'm a Slacker for life
after a couple of years of busting my gut over it. And the truth is that I
still lack a basic, foundational knowledge of Linux, and Slackware. But it
is my desire to help others, and to stay as far away from criminal companies
such as Microsoft as I can.

Tinkster, my favorite LQ mod once told me:
Quote:
The fact that you have a history of having fought
windows to the blood, and having conquered it in the
end may well make windows appear to you as easier
than Slackware (which you haven't wrestled down yet).
That's how I feel about Slackware. I'm wrestling it still, and stay
quite bloody in the fray. But today I have many systems which I have
total control over. I have no opinion of Kubuntu, as I've never once
used it. I did order the CDs when *buntu came out, but they didn't
ship them to me.

I agree that Slack would be difficult for someone who just wants to
use his computer to get work done. Configuring Slackware can be very
difficult. It does afford a nice platform for those who want to learn
more about their computer, and operating systems in general.

Last edited by Bruce Hill; 08-18-2006 at 07:39 PM.
 
Old 08-18-2006, 09:28 PM   #3
hawkwing3141
LQ Newbie
 
Registered: May 2005
Posts: 2

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Chinaman
How did you make it over a year as a member without posting?
I sucked it up and figured things out for myself! In truth, using LQ & Google (not to mention the practically unreadable man pages and HOWTO's that are so often given to newbies as "introductory" material) I was able to figure most things out, and those I didn't I just put off until later (read "gave up on").

Quote:
I don't know what happens when you use the drive, but this line:
Code:
/dev/hdc         /mnt/dvdrw       auto     owner,user,rw,noauto 0 0
should use ro rather than rw. Also, you need either owner, user, or users --
but not owner and user. You can learn what those mean from the manual pages
for fstab and mount.
Thanks I fixed those up.

Quote:
They are automatically mounted when I boot by auto in the third field.
I thought that in this case "auto" means that it determines the filesystem automatically.


Quote:
You mount the drive according to the options in the fourth field of
/etc/fstab if they're setup properly there. I am not in the disk group.

I do add my normal user to the audio, video, and cdrom groups.
ok, thanks

Quote:
I agree that Slack would be difficult for someone who just wants to
use his computer to get work done. Configuring Slackware can be very
difficult. It does afford a nice platform for those who want to learn
more about their computer, and operating systems in general.
I really did want to learn about Linux, and I'm perfectly happy to work from the command line, but I'm just tired of spending hours futzing with config files I've never heard of. I've decided from now on I just want the computer to do the configuring and let me do the rest. We'll see how that works out, but I still know how to open a console, thanks to Slackware

Thanks for your reply!
 
Old 08-18-2006, 10:41 PM   #4
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: McCalla, AL
Distribution: Funtoo
Posts: 6,926

Rep: Reputation: 128Reputation: 128
Quote:
mingdao@silas:~/kernel/linux-2.6.17.8$ man fstab
The third field, (fs_vfstype), describes the type of the filesystem. Linux supports lots of filesystem types, such as adfs, affs, autofs, coda, coherent, cramfs, devpts, efs, ext2, ext3, hfs, hpfs, iso9660, jfs, minix, msdos, ncpfs, nfs, ntfs, proc, qnx4, reiserfs, romfs, smbfs, sysv, tmpfs, udf, ufs, umsdos, vfat, xenix, xfs, and possibly others. For more details, see mount(8). For the filesystems currently supported by the running kernel, see /proc/filesystems. An entry swap denotes a file or partition to be used for swapping, cf. swapon(8). An entry ignore causes the line to be ignored. This is useful to show disk partitions which are currently unused.

The fourth field, (fs_mntops), describes the mount options associated with the filesystem.
Quote:
mingdao@silas:~/kernel/linux-2.6.17.8$ man mount
The auto type may be useful for user-mounted floppies. Creating a file /etc/filesystems can be useful to change the probe order (e.g., to try vfat before msdos or ext3 before ext2) or if you use a kernel module autoloader. Warning: the probing uses a heuristic (the presence of appropriate `magic'), and could recognize the wrong filesystem type, possibly with catastrophic consequences. If your data is valuable, don't ask mount to guess.
Manual pages are usually quite esoteric, because they're written by
programmers, usually after the app is released. Programmers by and
large are not good technical document writers. And they usually forget
a lot of little steps that they've long ago scripted, and aliases they
use, which aren't in a standard Linux distro install.


I hope you have a good experience with Ubuntu, and that your Slackware
years have taught you how to tweak enough so that you can straighten
out the things they've hacked.


And now that you've got this experience, perhaps you can post to help
others when they have problems.
 
Old 10-12-2006, 10:27 PM   #5
Jopers
LQ Newbie
 
Registered: Oct 2006
Distribution: Slackware
Posts: 9

Rep: Reputation: 0
I just connected a new DVD RW to my pc but some things have happened... K3B does not detect my DVD ROM drive or my DVD RW drive. Mount commands don't work either.

I am using kernel 2.4 with slackware 11.

I tried both cdrecord commands. This is what I got:

Code:
# cdrecord -scanbus
Cdrecord-Clone 2.01 (i686-pc-linux-gnu) Copyright (C) 1995-2004 Jörg Schilling
cdrecord: No such file or directory. Cannot open '/dev/pg*'. Cannot open SCSI driver.
cdrecord: For possible targets try 'cdrecord -scanbus'.
cdrecord: For possible transport specifiers try 'cdrecord dev=help'.
and
Code:
# cdrecord dev=ATAPI -scanbus
Cdrecord-Clone 2.01 (i686-pc-linux-gnu) Copyright (C) 1995-2004 Jörg Schilling
scsidev: 'ATAPI'
devname: 'ATAPI'
scsibus: -2 target: -2 lun: -2
Warning: Using ATA Packet interface.
Warning: The related Linux kernel interface code seems to be unmaintained.
Warning: There is absolutely NO DMA, operations thus are slow.
cdrecord: No such file or directory. Cannot open SCSI driver.
cdrecord: For possible targets try 'cdrecord -scanbus'.
cdrecord: For possible transport specifiers try 'cdrecord dev=help'.
I would greatly appreciate any help. Please help.

Last edited by Jopers; 10-12-2006 at 11:18 PM.
 
Old 10-12-2006, 11:49 PM   #6
Jopers
LQ Newbie
 
Registered: Oct 2006
Distribution: Slackware
Posts: 9

Rep: Reputation: 0
Nevermind. I forgot to set the jumper.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Another Completely Worthless And Irrelevant Thread peter_89 General 4 03-01-2006 01:58 PM
Suse 10.0 set dvd env Linux - General 2 11-15-2005 03:12 PM
default, irrelevant packages installed kpachopoulos Fedora - Installation 1 06-12-2005 05:38 AM
irrelevant thread.. i broke my glasses. acid_kewpie General 35 06-28-2002 04:16 AM
irrelevant thread.. lighten up ak... super_me General 2 06-17-2002 01:55 AM


All times are GMT -5. The time now is 05:18 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration