LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 08-17-2011, 08:48 PM   #1
surfsidebill
LQ Newbie
 
Registered: Aug 2011
Posts: 7

Rep: Reputation: Disabled
How get monitor to native resolution on Ubuntu 11.04


Hi Ubuntu experts,

I am new to Ubuntu (11.04, 64 bit) and have been surfing and reading, but haven't quite figured out how to get my hp w2207 monitor to display in native mode, which is 1680x1050, 60Hz. I tried System Settings/Hardware/Monitors but the highest resolution there is 1024x768. I tried the 'Detect monitors' button, but it doesn't seem to do anything. I am running on an Intel D525 Atom Mboard and i have updated Ubuntu to latest updates. From what I have read, the D525 uses Intel's GMA 3150 chip and the drivers for that chip are automatically included in the standard Ubuntu release, so that's not my problem (I think). Somehow the monitor is not being detected, apparently. On this forum I saw a recommendation to edit a file 'xorg.conf' and to insert a Monitor section etc. But I have not been able to find 'xorg.conf' in /etc/X11, nor in /usr/whatever. So my question is, should I make an 'xorg.conf' and put it in /etc/X11, or is it possible there is already one somewhere else? Is there a better place to put it? I hate to ask, but is there a text editor I can use in graphics mode, or does everything have to be in command line to get this job done? thanks for reading through all this.
 
Old 08-17-2011, 10:37 PM   #2
cargod_hera
LQ Newbie
 
Registered: Apr 2010
Location: Dallas, TX
Distribution: Simply MEPIS, OpenArtist, Ubuntu 10.04, Mint, Elive, Epidemic, Kongoni, Anibus, BackTrack4
Posts: 29

Rep: Reputation: 2
Open a terminal and, as root, enter the following command:

Quote:
cp /etc/X11/xorg.conf /etc/X11/xorg.conf.old
nano /etc/X11/xorg.conf
That will save your current xorg.conf where you can find it and open your xorg.conf in the terminal as a editable document. Next, scrolling down in your xorg.conf document, find your "screen" section and add the following:

Quote:
SubSection "Display"
Virtual 1680 1050
Depth 24
Modes "1680x1050" "1280x1024" "1024x768"
EndSubSection
You can also add your screen resolution into the "monitor" section under "modes" but it's your screen that you really need to edit.
After adding those display edits, use <Ctrl X> to exit the document, you'll be prompted whether you want to save the document. Enter "y" for yes and then just hit <enter> to save your new xorg.conf over your existing one.
 
Old 08-18-2011, 06:25 AM   #3
surfsidebill
LQ Newbie
 
Registered: Aug 2011
Posts: 7

Original Poster
Rep: Reputation: Disabled
xorg.conf not in /etc/X11

Thanks for your help. I logged in as root, but the cp command doesn't work because there is no xorg.conf in that directory.

Could it be somewhere else?
 
Old 08-18-2011, 07:07 AM   #4
jdkaye
Senior Member
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 4,767

Rep: Reputation: Disabled
That's true of most newer systems. Just execute the second command (the one beginning with "nano") and paste the text given below into that file. Then ctl-o to save the file and ctl-x to exit from nano and continue as instructed above.
ciao,
jdk
 
Old 08-18-2011, 08:33 AM   #5
surfsidebill
LQ Newbie
 
Registered: Aug 2011
Posts: 7

Original Poster
Rep: Reputation: Disabled
I edited /etc/X11/xorg.conf per the instructions above, saved the file and restarted.

Now the system comes up and the screen is black - totally blank.
I can shut down by pressing the power button and restart by pressing it again.
I see the motherboard screen, then a very deep purple background and then the screen goes totally blank.
At this point, nothing on the keyboard or mouse will get a response.
editing the xorg.conf file doesn't seem to have had the desired effect.
Any suggestions how to recover?
 
Old 08-18-2011, 09:29 AM   #6
jdkaye
Senior Member
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 4,767

Rep: Reputation: Disabled
Can you boot into Recovery Mode and then check the /var/log/Xorg.0.log for errors? Lines beginning with (EE). That may tell you what the problem is.
ciao,
jdk
 
Old 08-18-2011, 11:39 AM   #7
surfsidebill
LQ Newbie
 
Registered: Aug 2011
Posts: 7

Original Poster
Rep: Reputation: Disabled
I renamed the /etc/X11/xorg.conf created per above to a .bak file and rebooted. Everything returned to normal, with 1024x768 monitor.
Then I renamed back to xorg.conf and rebooted and system went blank again.
Then in Recovery mode I used nano to look at /var/log/Xorg.0.log:

It says that 'SubSection' in xorg.conf 'is not a valid keyword in this section'

The entire contents of the file is the above text. Is there more preamble to the file that belongs in it?
 
Old 08-18-2011, 11:42 AM   #8
jdkaye
Senior Member
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 4,767

Rep: Reputation: Disabled
So why don't you just delete the xorg.conf file or rename it "xorg.conf.bad" and then restart your system. If I understand you, the system works ok without the xorg.conf. Is that correct? If so, then that's your solution.
ciao,
jdk
 
Old 08-18-2011, 12:03 PM   #9
surfsidebill
LQ Newbie
 
Registered: Aug 2011
Posts: 7

Original Poster
Rep: Reputation: Disabled
because I am trying to use the native resolution of my monitor which is 1680x1050, not 1024x768. See the title of this thread.
 
Old 08-18-2011, 12:18 PM   #10
jdkaye
Senior Member
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 4,767

Rep: Reputation: Disabled
Well it seems that lots of people are having your problem since 2008. This thread is but one of a long list of them. Maybe it will help, maybe not. good luck.
jdk
 
Old 08-18-2011, 12:36 PM   #11
cascade9
Senior Member
 
Registered: Mar 2011
Location: Brisneyland
Distribution: Debian, aptosid
Posts: 3,718

Rep: Reputation: 904Reputation: 904Reputation: 904Reputation: 904Reputation: 904Reputation: 904Reputation: 904Reputation: 904
xorg.conf is depricated in newer versions of ubuntu, they are generally not required anymore. But making one isnt hard, just run this command-

sudo Xorg -configure

I *think* that it should create the file in /usr/share/X11/xorg.conf.d, but I dont have a ubuntu install to test that with.

By the way, I guess that your resolution problem is due to EDID (Extended display identification data). This page should help you figure out if its the EDID-

http://maxolasersquad.blogspot.com/2...formation.html
 
Old 08-18-2011, 02:56 PM   #12
surfsidebill
LQ Newbie
 
Registered: Aug 2011
Posts: 7

Original Poster
Rep: Reputation: Disabled
thanks for these suggestions. At this point, I have removed the xorg.conf file in /etc/X11, so I am back where I started with all the files I installed.

EXCEPT somewhere along the line (right after I tried introducing and removing xorg.conf), my system decided I have two screens - one laptop and one external. Since my system is a single monitor (HP w2207), I think Ubuntu 11.04 is even more confused than I am. Which is saying a lot. Both these screens are displayed on one monitor. The 'laptop' screen is 1024x768 and the 'external' screen can be set to several higher resolutions, one of which is 1680x1050. The smaller one is overlaid on the larger one. Both screens appear to be complete, so I have two menubars at the top of the screen!

I looked at /var/log/Xorg.0.log and studied what it's doing - It appears to correctly get EDID for my monitor, with a list of VGA display modes, etc. Unclear where two screens come from.

I can turn off the 'laptop' screen and just enable the 'external' monitor, and the Monitor screen now (suddenly) says that I have a Hewlett Packard 22" monitor. And it displays a list of display modes that goes up to 1680x1050.

EXCEPT that the screen goes crazy when I select 1680x1050.

So I have now got 1280 x 1024. I think I am looking at Xorg bugs.
 
Old 08-18-2011, 03:14 PM   #13
surfsidebill
LQ Newbie
 
Registered: Aug 2011
Posts: 7

Original Poster
Rep: Reputation: Disabled
One last note

At this point my Intel D525 mboard with 3150 GMA running Ubuntu 11.04 thinks it has two monitors: a 'laptop' (this one is now turned off in Monitor dialog) and an 'external', which can be set to any of the long list of available resolutions, one of which is the native resolution - 1680 x 1050.

By working my way up from 1280x1024 and by shutting down each time I incremented the resolution, I worked my way up to 1680x1024 and now it's working fine. Because I have added no files and not edited any files, I have no clue what really happened. The turning point was when the system started recognizing my monitor's EDID, I think. Somehow Natty is confused about the number of monitors I have.

Thanks to you experts, I learned a lot I didn't know with this exercise.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] [ubuntu 10.04] Detecting monitor resolution kentfx Linux - Desktop 1 05-14-2010 06:32 AM
Native monitor resolution gone - where is the wrong info stored? harry88 Linux - General 2 03-02-2010 05:20 PM
monitor native resolution not displayed properly itsme_me Linux - Hardware 4 05-21-2009 04:08 AM
how I can grading up the monitor-resolution in ubuntu GBunge Linux - Hardware 5 10-19-2006 03:22 AM
Higher than native monitor resolution? garlick Linux - Software 3 05-25-2004 03:34 AM


All times are GMT -5. The time now is 08:33 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration