LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 06-24-2008, 05:17 PM   #1
kazman1969
LQ Newbie
 
Registered: Jun 2008
Posts: 3

Rep: Reputation: 0
How do increase the number of PTS sessions allowed? I am currently limited to 34.


We are using Suse 10 and we have numerous users logging in. As soon as we hit our 35th concurrent login we get the error message ..."Invalid Login".

How do we increase the number of available logins?

We are using telenet sessions to login.

Any help would be greatly appreciated.

Thanks.
 
Old 06-24-2008, 05:41 PM   #2
colucix
Moderator
 
Registered: Sep 2003
Location: Bologna
Distribution: CentOS 6.5 OpenSuSE 12.3
Posts: 10,458

Rep: Reputation: 1941Reputation: 1941Reputation: 1941Reputation: 1941Reputation: 1941Reputation: 1941Reputation: 1941Reputation: 1941Reputation: 1941Reputation: 1941Reputation: 1941
The number of logins is controlled by a kernel parameter. Look at
Code:
cat /proc/sys/kernel/pty/max
it should be 34 on your system. To change that simply do
Code:
echo 512 > /proc/sys/kernel/pty/max
you can choose any other number up to 5120, if I remember well. If you want to make this change permanent, that is preserve it after reboot, you have to add the following line to /etc/sysctl.conf
Code:
kernel.pty.max = 512
Another option is to check the PAM limits. Look at /etc/security/limits.conf and see if the item maxsyslogins is set.

Last edited by colucix; 06-24-2008 at 05:53 PM.
 
Old 06-24-2008, 06:01 PM   #3
kazman1969
LQ Newbie
 
Registered: Jun 2008
Posts: 3

Original Poster
Rep: Reputation: 0
I typed in : cat /proc/sys/kernel/pty/max and the system returned 4096.

So it appears that my logins are set to 4096. Any idea why after 34 logins we get invalid login from a telenet session?
 
Old 06-24-2008, 06:29 PM   #4
kazman1969
LQ Newbie
 
Registered: Jun 2008
Posts: 3

Original Poster
Rep: Reputation: 0
Sorry, I just saw your suggestion at the end of the previous post...

Here is what I have in the limits.conf file:

#<domain> <type> <item> <value>
#

#* soft core 0
#* hard rss 10000
#@student hard nproc 20
#@faculty soft nproc 20
#@faculty hard nproc 50
#ftp hard nproc 0
#@student - maxlogins 4

Do I need to set the maxlogins to a value - or by it not being set doe sthis mean unlimted maxlogins?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to increase number of threads per process? Vaish Linux - Distributions 8 02-25-2010 01:21 AM
How can I increase minimal time gap between allowed attempts ? yuye811 Linux - Security 5 04-09-2008 01:37 PM
how to increase the loop devices number baloon Red Hat 3 03-29-2007 07:53 PM
How to increase number of record locks? Fillys6 Linux - Software 2 02-03-2006 09:01 AM
Red Hat 9 limited to 60 telnet sessions avk Red Hat 5 06-30-2005 09:30 AM


All times are GMT -5. The time now is 03:40 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration