LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-18-2005, 11:49 AM   #1
Navyblue
Member
 
Registered: Jul 2005
Posts: 161

Rep: Reputation: 30
How do I view FAT partitions in FC4?


i guys,

Supernoob here.

As above, How do I view FAT partitions in FC4? In SUSE 9.3 I could view them without doing any configuration tweaking.

Thanks in advance.
 
Old 07-18-2005, 12:39 PM   #2
tangle
Senior Member
 
Registered: Apr 2002
Location: Smithville, TN
Distribution: Slackware
Posts: 1,745

Rep: Reputation: 71
Open up the command line and type these commands.

mkdir /mnt/windows
chown root.users /mnt/windows
modprobe vfat
mount -t vfat /dev/hda1 /mnt/windows

This is if your windows partition that you want to mount is the first partition on the first drive.

Drives are named:
primary master - /dev/hda
primary slave - /dev/hdb
secondary master - /dev/hdc
secondary slave - /dev/hdd

The number after the last letter is the partition number. If you want it to mount at boot time add this to your /etc/fstab:

/dev/hda1 /winwindows vfat uid=500,gid=500,umask=000,exec,dev,suid,rw 1 0

Last edited by tangle; 07-18-2005 at 12:49 PM.
 
Old 07-18-2005, 12:45 PM   #3
redhatrosh
Member
 
Registered: May 2004
Location: Student of University of Mumbai, Maharastra State, India
Distribution: Redhat Linux 9.0, Knoppix LIVE CD, Ubuntu Live CD, Kubuntu Live CD
Posts: 483

Rep: Reputation: 30
Well, You might have to have root permission for this.

You have to edit a file for that (so that it automatically mounts the next time you boot)
If you have C: , D: and so...on....
and you would like to name the like that...make folders in /mnt folder as C, D etc....

Secondly, under root login, edit /etc/fstab file

append the following

Code:
/dev/hdax      /mnt/<drivename>     vfat
Append depending on the number of partitons

x represents the device number. It wud depend on you partition and hard disk (or disks)

hda1 represents C: drive on first hard disk
hda 5 represents D: (if there's only one primary partition) drive on first hard disk

hdb1 wud represent somethin...(I dont know...) I have only one hard disk
 
Old 07-18-2005, 02:11 PM   #4
Navyblue
Member
 
Registered: Jul 2005
Posts: 161

Original Poster
Rep: Reputation: 30
Thanks guys for your responses.

I have tried the combinations below and none of them work:

/dev/hda1 /winwindows vfat uid=500,gid=500,umask=000,exec,dev,suid,rw 1 0
/dev/hda1 /mnt/windows vfat uid=500,gid=500,umask=000,exec,dev,suid,rw 1 0
/dev/hda1 /mnt/c vfat uid=500,gid=500,umask=000,exec,dev,suid,rw 1 0
/dev/hda1 /mnt/c vfat umask=000
/dev/hda1 /mnt/c vfat

The following is my current /etc/fstab

# This file is edited by fstab-sync - see 'man fstab-sync' for details
LABEL=/ / ext3 defaults 1 1
/dev/devpts /dev/pts devpts gid=5,mode=620 0 0
/dev/shm /dev/shm tmpfs defaults 0 0
/dev/proc /proc proc defaults 0 0
/dev/sys /sys sysfs defaults 0 0
LABEL=SWAP-sda3 swap swap defaults 0 0
/dev/fd0 /media/floppy auto pamconsole,exec,noauto,managed 0 0
/dev/hdb /media/cdrecorder auto pamconsole,exec,noauto,managed 0 0
/dev/hda /media/cdrom auto pamconsole,exec,noauto,managed 0 0

And my set up is:
SATA HD
Partition 1 FAT32 volume label windows
Partition 2 NTFS volume label swap
Partition 3 FAT32 volume label programs
Partition 4 ext3 (where FC4 is residing)
Partition 5 FAT32 volume label storage
Partition 6 is Linux swap partition.
Primary paralel ATA master and secondary occupied by 2 optical drives.
 
Old 07-19-2005, 11:22 AM   #5
redhatrosh
Member
 
Registered: May 2004
Location: Student of University of Mumbai, Maharastra State, India
Distribution: Redhat Linux 9.0, Knoppix LIVE CD, Ubuntu Live CD, Kubuntu Live CD
Posts: 483

Rep: Reputation: 30
I think, the last option
Code:
/dev/hda1 /mnt/c vfat
in your fstab file (if appended) should have definitely worked!

ANy errors do you get when you boot Fedora??
 
Old 07-19-2005, 12:11 PM   #6
tangle
Senior Member
 
Registered: Apr 2002
Location: Smithville, TN
Distribution: Slackware
Posts: 1,745

Rep: Reputation: 71
Did you make a directory in /mnt to mount the partition too? If not run this command.

mkdir /mnt/windows

If so what do you get when you run this comman?

mount -t vfat /dev/hda1 /mnt/windows

You have to do this when logged in as root.
 
Old 07-19-2005, 12:21 PM   #7
michaelk
Moderator
 
Registered: Aug 2002
Posts: 15,265

Rep: Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624
SATA drives have SCSI device IDs. Try using /dev/sda1 instead of /dev/hda1.
 
Old 07-19-2005, 01:12 PM   #8
Navyblue
Member
 
Registered: Jul 2005
Posts: 161

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by redhatrosh
I think, the last option
Code:
/dev/hda1 /mnt/c vfat
in your fstab file (if appended) should have definitely worked!

ANy errors do you get when you boot Fedora??
With those lines appended in the fstab, during boot up it says something like mount point did not exist.
 
Old 07-19-2005, 01:16 PM   #9
Navyblue
Member
 
Registered: Jul 2005
Posts: 161

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by tangle
Did you make a directory in /mnt to mount the partition too? If not run this command.

mkdir /mnt/windows

If so what do you get when you run this comman?

mount -t vfat /dev/hda1 /mnt/windows

You have to do this when logged in as root.
I made a directtory named "windows" in /mnt with Nautillus.

After typing the mount command it says something like special device dev/hda did not exist.
 
Old 07-19-2005, 01:24 PM   #10
Navyblue
Member
 
Registered: Jul 2005
Posts: 161

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by michaelk
SATA drives have SCSI device IDs. Try using /dev/sda1 instead of /dev/hda1.
I think you are right, my optical drive claimed sda and thus I felt something fishy and decided to post my set up earlier on. And GRUB says FC4 is on sda7.

But I tried replacing the hda to sda in the fstab and the mount command but FC4 said the same thing.

fstab says my swap partition is /dev/sda3, any chance that it has anything to do with it?

I have already uninstalled the SUSE 9.3 (which showed those FAT32 partitions by default). And I installed Ubuntu 5.04 and those partitions doesn't show up as well.

Btw thanks guys for your kind responses.

Last edited by Navyblue; 07-19-2005 at 01:25 PM.
 
Old 07-19-2005, 01:43 PM   #11
Navyblue
Member
 
Registered: Jul 2005
Posts: 161

Original Poster
Rep: Reputation: 30
GUYS I DID IT !!! I made a directories corresponding to the name assigned to the drives in the fstab and it works.

Now, just a little more, what do I use to replace the "vfat" for NTFS partition? I tried repacing with "NTFS" and it doesn't work.
 
Old 07-19-2005, 02:23 PM   #12
enemorales
Member
 
Registered: Jul 2004
Location: Santiago, Chile
Distribution: Ubuntu
Posts: 410

Rep: Reputation: 31
Well ntfs should work, but:

- Do not mount the drive with write permissions, because it is still experimental.
- You have to have the ntfs module loaded. Try "modprobe ntfs" before trying to mount it. If it doesn't work you have to get a fedora core kernel that supports it (I'm not a FC user, but I think they provide them as RPM. Do you know what RPM are, don't you? )

HTH

---

Question for the others: Do SATA drives allow to have more than 4 primary partitions? Because Navyblue got 6 of them, so at least one of them has to be extended, then it cannot (shouldn't) be mounted and the numbers change... Isn't it?
 
Old 07-19-2005, 02:50 PM   #13
michaelk
Moderator
 
Registered: Aug 2002
Posts: 15,265

Rep: Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624
By default Fedora does not include ntfs support. Here is the link for read support:
http://linux-ntfs.sourceforge.net/rpm/index.html
 
Old 07-20-2005, 12:00 AM   #14
Navyblue
Member
 
Registered: Jul 2005
Posts: 161

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by enemorales
Well ntfs should work, but:

- Do not mount the drive with write permissions, because it is still experimental.
- You have to have the ntfs module loaded. Try "modprobe ntfs" before trying to mount it. If it doesn't work you have to get a fedora core kernel that supports it (I'm not a FC user, but I think they provide them as RPM. Do you know what RPM are, don't you? )

HTH
Yeah I happen to know it, but I don't know how do I uninstall it if I have to do that.

Quote:
Originally posted by michaelk
By default Fedora does not include ntfs support. Here is the link for read support:
http://linux-ntfs.sourceforge.net/rpm/index.html
Thanks for the link, with my limited Linux knowledge, I guess at this stage I shouldn't mess with it yet.

Thanks guys for your tremendous help!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
mounting fat 32 partitions scarryharry Fedora 1 03-31-2005 02:47 PM
Accessing Fat/NTFS partitions satinet Linux - General 3 09-03-2004 02:16 PM
Accessing FAT partitions? fusion1911 Slackware 8 11-16-2003 02:46 PM
Can't see files in mounted fat partitions mcfly420 Slackware 4 05-29-2003 03:23 AM
After installing Mandrake 7.1 - I can't see two out of four FAT partitions BetaLord Linux - Software 4 12-23-2001 05:16 AM


All times are GMT -5. The time now is 04:06 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration