LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-20-2015, 09:33 AM   #1
Azorael
LQ Newbie
 
Registered: May 2015
Posts: 2

Rep: Reputation: Disabled
How do I use the at ---- to run ktorrent


I am running fedora 20 I type: "at 1400" ENTER then the next line appears :> so I type "ktorrent" ENTER then the next line I press ctr D. My problem is when the time actually comes for this program to start at the specified time it does not. How to do i get ktorrent to propperly start at a specified time with the at command
 
Old 05-20-2015, 12:28 PM   #2
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,520

Rep: Reputation: 1502Reputation: 1502Reputation: 1502Reputation: 1502Reputation: 1502Reputation: 1502Reputation: 1502Reputation: 1502Reputation: 1502Reputation: 1502Reputation: 1502
Quote:
Originally Posted by Azorael View Post
I am running fedora 20 I type: "at 1400" ENTER then the next line appears :> so I type "ktorrent" ENTER then the next line I press ctr D. My problem is when the time actually comes for this program to start at the specified time it does not. How to do i get ktorrent to propperly start at a specified time with the at command
Since it's a program that uses X, you need to specify the DISPLAY variable prior running the program. Also it's always better to use the full path to the program executable. So after running "at 1400", use:
Code:
DISPLAY=:0.0 /usr/bin/ktorrent
Regards
 
1 members found this post helpful.
Old 05-20-2015, 02:57 PM   #3
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,825

Rep: Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408
also be aware fedora 20 will go end of life in about 6 to 8 weeks
after that there will NEVER be any more support for 20


you might want to install Fedora 21
or in a few weeks install Fedora 22 when it comes out



Ktorrent is the KDE desktop GUI for torrents

the KDE desktop needs to be installed ( or most of it seeing as Fedora is VERY VERY Gnome centric )
 
Old 05-20-2015, 04:57 PM   #4
jpollard
Senior Member
 
Registered: Dec 2012
Location: Washington DC area
Distribution: Fedora, CentOS, Slackware
Posts: 4,604

Rep: Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241
Quote:
Originally Posted by bathory View Post
Since it's a program that uses X, you need to specify the DISPLAY variable prior running the program. Also it's always better to use the full path to the program executable. So after running "at 1400", use:
Code:
DISPLAY=:0.0 /usr/bin/ktorrent
Regards
Note: this won't work unless you are also logged in... AND are using display 0.0. My wife also uses my system so I currently have 1.0 so this command would not work for me either. It may also have a problem if the screen is locked (displays don't show until unlocked).

Since ktorrent is GUI based application, it may not start without the GUI interface directing it to start (not sure about whether it would automatically resume something that was active when it exited...)
 
1 members found this post helpful.
Old 05-20-2015, 09:05 PM   #5
Azorael
LQ Newbie
 
Registered: May 2015
Posts: 2

Original Poster
Rep: Reputation: Disabled
Wow thank you so much i really appreciate the help!!!, it works when I type DISPLAY=:0.0 then the full path. I did try the full path without the display and that did not work.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
KTorrent montyburnz Linux - Newbie 1 09-23-2009 10:58 PM
HELP with Ktorrent jTm_316 Linux - Software 1 01-09-2009 01:02 AM
ktorrent decodedthought Linux - Newbie 5 03-22-2008 03:31 AM
KTorrent? Lola Kews Linux - Software 18 10-18-2007 02:35 PM
need help with ktorrent megadsonic SUSE / openSUSE 2 12-27-2005 02:46 PM


All times are GMT -5. The time now is 11:04 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration