LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 06-17-2008, 09:29 AM   #1
LMD1990
LQ Newbie
 
Registered: Jun 2008
Posts: 8

Rep: Reputation: 0
How do I stop Firefox and Terminal loading at start up?


Hey guys, I'm having a problem when booting up Xubuntu, and that is that both Firefox and Terminal load at start up. I've checked Autostarted Apps, but neither are listed.

In a related issue, sometimes when i load Xubuntu, it locks up after the log-in screen and nothing loads- only way to kill it is to hit ctrl+alt+backspace or the power button. I'm not too sure if it's xfce being awkward, or the "Last Session" option, which is automatically set as the Session option.

Any ideas?
 
Old 06-17-2008, 09:47 AM   #2
wernerz
Member
 
Registered: Jun 2008
Location: Ottawa, Ontario, Canada
Distribution: debian, dsl-n
Posts: 55

Rep: Reputation: 15
It seems xfce is set to start programs that you had running when you last logged off. Go to the session options and turn off the "automatically save session on logout" feature. Then disable firefox and terminal. Hope this helps.
 
Old 06-17-2008, 01:26 PM   #3
LMD1990
LQ Newbie
 
Registered: Jun 2008
Posts: 8

Original Poster
Rep: Reputation: 0
I did that, but the "save sessions on logout" option wasn't selected in the first place, and yet it still does it.

Any idea what I should do?
 
Old 06-17-2008, 01:54 PM   #4
jomen
Senior Member
 
Registered: May 2004
Location: Leipzig/Germany
Distribution: Arch
Posts: 1,684

Rep: Reputation: 54
just a guess:
it could be written into ~/.config/xfce4-session/xfce4-session.rc
 
Old 06-17-2008, 01:56 PM   #5
IsaacKuo
Senior Member
 
Registered: Apr 2004
Location: Baton Rouge, Louisiana, USA
Distribution: Debian 4.0 Etch
Posts: 1,349

Rep: Reputation: 49
Here's one thing to try:

1) SELECT "save sessions on logout".

2) Close all programs and logout.

3) Log back in and see if firefox/terminal still open. If not, then DESELECT "save sessions on logout".

It may just be using the last saved session settings.
 
  


Reply

Tags
xfce


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
when i try to start firefox it acts like its going to start but then stops loading. krrish Red Hat 3 08-22-2007 07:32 AM
How to stop a command or start over, in a terminal royeo Linux - Newbie 6 08-12-2006 01:21 PM
How to stop audio driver loading while the system is start wangduanzhu Fedora 1 04-02-2006 08:52 AM
Page does not stop loading in firefox jackpal Linux - Software 5 04-28-2005 02:49 PM
Stop KDE from loading at start Jimi_l Debian 4 07-21-2003 01:16 PM


All times are GMT -5. The time now is 07:32 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration