LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   How do I stop Firefox and Terminal loading at start up? (http://www.linuxquestions.org/questions/linux-newbie-8/how-do-i-stop-firefox-and-terminal-loading-at-start-up-649893/)

LMD1990 06-17-2008 10:29 AM

How do I stop Firefox and Terminal loading at start up?
 
Hey guys, I'm having a problem when booting up Xubuntu, and that is that both Firefox and Terminal load at start up. I've checked Autostarted Apps, but neither are listed.

In a related issue, sometimes when i load Xubuntu, it locks up after the log-in screen and nothing loads- only way to kill it is to hit ctrl+alt+backspace or the power button. I'm not too sure if it's xfce being awkward, or the "Last Session" option, which is automatically set as the Session option.

Any ideas?

wernerz 06-17-2008 10:47 AM

It seems xfce is set to start programs that you had running when you last logged off. Go to the session options and turn off the "automatically save session on logout" feature. Then disable firefox and terminal. Hope this helps.

LMD1990 06-17-2008 02:26 PM

I did that, but the "save sessions on logout" option wasn't selected in the first place, and yet it still does it.

Any idea what I should do?

jomen 06-17-2008 02:54 PM

just a guess:
it could be written into ~/.config/xfce4-session/xfce4-session.rc

IsaacKuo 06-17-2008 02:56 PM

Here's one thing to try:

1) SELECT "save sessions on logout".

2) Close all programs and logout.

3) Log back in and see if firefox/terminal still open. If not, then DESELECT "save sessions on logout".

It may just be using the last saved session settings.


All times are GMT -5. The time now is 11:10 PM.