LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-13-2012, 01:14 PM   #1
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
How do I start network before login debian squeeze


What I would like to do is have network available after boot so that I can connect via ssh, but ssh is not available is network connection until after login.
I had the same problem a few years back as stated in this post in which the links are now dead. http://www.linuxquestions.org/questi...omaine-830908/
Googling doesn't return any links that I've found useful as I thought last time I had to edit the /etc/init.d file.
 
Old 06-13-2012, 05:36 PM   #2
fruttenboel
Member
 
Registered: Jul 2008
Location: Tilburg NL
Distribution: Slackware 14.2 ciurrent, kernel 3.18.11
Posts: 270

Rep: Reputation: 48
When I boot my Slackware systems. the network is up and running when the logon is shown on screen. AFAIK this is standard for all linuxes.
 
Old 06-13-2012, 07:35 PM   #3
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.8, Centos 5.10
Posts: 17,260

Rep: Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328
What fruttenboel said; network services normally start well before login is allowed.
Looking at a RHEL5 server here
Code:
S10network
in /etc/rc3.d
 
Old 06-13-2012, 10:23 PM   #4
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Original Poster
Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
During startup it shows what services are being activated including network but, unless I log into the physical computer the network is not accessible via ssh.

Last edited by EDDY1; 06-13-2012 at 10:44 PM.
 
Old 06-13-2012, 11:55 PM   #5
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.8, Centos 5.10
Posts: 17,260

Rep: Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328
You'd best show us an example; it sounds like you are trying to make an automated cxn from this system to another, before networking is fully up.
 
Old 06-14-2012, 12:06 AM   #6
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Original Poster
Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
Another note if I log out of gnome the network is no longer available.

Last edited by EDDY1; 06-14-2012 at 12:09 AM.
 
Old 06-14-2012, 04:59 AM   #7
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Original Poster
Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
I also want to add that I can only ssh into machine after logging into user account & only while user is logged on.
Also the vncviewer can only see the machine when the user is logge in
 
Old 06-14-2012, 08:59 PM   #8
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Debian, Mageia, and whatever VMs I happen to be playing with
Posts: 11,683
Blog Entries: 12

Rep: Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903
I don't know if this is really relevant, but I can ssh/scp into my Debian box without a local user's being logged in. On reboot, I can do it as soon as the login prompt appears.

Note that it is using wired networking, a static ip, and no display manager, so it may not be a comparable situation. However, if I remember correctly, I was able to do this before I made the display manager go away.
 
Old 06-14-2012, 09:23 PM   #9
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,131
Blog Entries: 2

Rep: Reputation: 4833Reputation: 4833Reputation: 4833Reputation: 4833Reputation: 4833Reputation: 4833Reputation: 4833Reputation: 4833Reputation: 4833Reputation: 4833Reputation: 4833
Have you configured your network in /etc/network/interfaces or do you use Gnome's NetworkManager?
 
Old 06-14-2012, 10:26 PM   #10
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Original Poster
Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
@TobiSGD
Since I haven't recalled what I did to get the network to be available on boot on my Dell Optiplex, I only have the default network setup on my Amd machine from new install.
I think I need to take the old Dell out of storage to see what I changed to make the network available at boot.

Last edited by EDDY1; 06-14-2012 at 10:30 PM.
 
Old 06-14-2012, 10:36 PM   #11
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,131
Blog Entries: 2

Rep: Reputation: 4833Reputation: 4833Reputation: 4833Reputation: 4833Reputation: 4833Reputation: 4833Reputation: 4833Reputation: 4833Reputation: 4833Reputation: 4833Reputation: 4833
It is actually pretty simple: Just post the contents of /etc/network/interfaces and have a look at the settings of your Network Manager, if you have one installed (like wicd or Gnome NetworkManager).
 
Old 06-14-2012, 10:42 PM   #12
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Original Poster
Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
I just reinstalled os selecting only ssh server, rebooted then used tasksel to install desktop, logged into my router & was able to ping. So now I atleast know it's getting ip address at boot, so I have to go in & configure to accept connection from my laptop.
 
Old 06-14-2012, 11:01 PM   #13
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Original Poster
Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
Well I didn't figure out how to do it manually but letting tasksel do it from the beginning definately worked.
The only issue I had was that I needed to remove the old keys, then I was able to login.
I really would like to know what is different as these 2 files haven't changed.


Quote:
topgun2@Perfectionplus1:~$ cat /etc/network/interfaces
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth0
#NetworkManager#iface eth0 inet dhcp
topgun2@Perfectionplus1:~$ cat /etc/NetworkManager/NetworkManager.conf
[main]
plugins=ifupdown,keyfile

[ifupdown]
managed=false
topgun2@Perfectionplus1:~$
It has to have something to do with /etc/init.d

Last edited by EDDY1; 06-14-2012 at 11:07 PM.
 
Old 06-15-2012, 03:59 AM   #14
fruttenboel
Member
 
Registered: Jul 2008
Location: Tilburg NL
Distribution: Slackware 14.2 ciurrent, kernel 3.18.11
Posts: 270

Rep: Reputation: 48
I think you need to change inetd.conf. For Linux, the network is so essential that it is ALWAYS running by default. My inetd.conf file looks as follows:

Code:
# These are standard services:
#
# Very Secure File Transfer Protocol (FTP) server.
#ftp     stream  tcp     nowait  root    /usr/sbin/tcpd  vsftpd
#
# Professional File Transfer Protocol (FTP) server.

ftp     stream  tcp     nowait  root    /usr/sbin/tcpd  proftpd

#
# Telnet server:
#telnet stream  tcp     nowait  root    /usr/sbin/tcpd  in.telnetd
#
# The comsat daemon notifies the user of new mail when biff is set to y:

comsat        dgram   udp     wait    root    /usr/sbin/tcpd  in.comsat
#
# Ident service is used for net authentication
auth    stream  tcp     wait    root    /usr/sbin/in.identd     in.identd
#
See also various setups for various machines on the webpage

http://fruttenboel.verhoeven272.nl/l...eryllium2.html

Other linux, same idea.
 
Old 06-15-2012, 05:12 AM   #15
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Original Poster
Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
My ssytem doesnt have inet.d.conf
I'm now looking in rc.d files
My system was booting rcS.d & I noticed that it's the only 1 that rmnologin
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Debian Squeeze does not start into graphic desktop camera3043 Linux - Desktop 15 05-27-2012 05:56 AM
debian 6.0.1 (squeeze) is misbehaving - does not give login screen marmirelo Linux - Newbie 3 04-05-2012 01:02 AM
[SOLVED] Broken login screen debian squeeze MartyJay Linux - Newbie 17 11-07-2011 06:36 PM
[SOLVED] After Debian upgrade from Lenny to Squeeze, MySQL will not start fireball1974 Linux - Server 3 03-20-2011 08:28 PM
[SOLVED] [squeeze] login screen and network grayed out wch705 Debian 6 10-02-2010 03:23 AM


All times are GMT -5. The time now is 06:15 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration