LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-09-2004, 05:04 AM   #1
Joe Franek
LQ Newbie
 
Registered: Apr 2004
Posts: 2

Rep: Reputation: 0
How do I start a "not ready" cups printer ?


I write an maintain Business Basic applications running on flavours of unix. We have recently migrated some of our clients to Feodora and configured the printers under cups. When a printer runs out of paper and goes into a "not ready" state, how do you make it "ready" again ! Being a complete linux novice ( my linux support techie is on hols ) I thought i would try lpc start <printer name > but just got the reply start not supported under cups of words to that effect - can anyone help me ! ?
 
Click here to see the post LQ members have rated as the most helpful post in this thread.
Old 04-09-2004, 05:15 AM   #2
iluvatar
Member
 
Registered: Jul 2003
Location: netherlands
Distribution: debian
Posts: 403

Rep: Reputation: 30
try using some browser to connect to http://<pc with cups>:631. this is a webinterface for cups.

greetz,
-= iluvatar =-
 
Old 04-10-2004, 02:12 AM   #3
Joe Franek
LQ Newbie
 
Registered: Apr 2004
Posts: 2

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by iluvatar
try using some browser to connect to http://<pc with cups>:631. this is a webinterface for cups.

greetz,
-= iluvatar =-
thanks for the swift reply, but this doesn't give me the solution ! I am accessing this machine through an Intel VPN tunnel which gives me precious little ability other than the use of my telnet client ( Anzio ) - sorry to be "old fashioned", but I am searching for the ACTUAL COMMAND/S that I can type in in the absence of remote browser access
 
Old 07-26-2009, 09:01 PM   #4
tangoholic
LQ Newbie
 
Registered: Jul 2009
Posts: 1

Rep: Reputation: 4
This has been a lonely question at the top of the Google search for years. I happened to stumble across the answer today.

Yes, the web link to localhost:631 worked great for me. I happen to have CUPS 1.3.11 on Debian, and the Printers tab has a "Start Printer" or "Stop Printer" button depending if the printer is currently running or not. It worked great, but it was hiding the command line equivalent.

I happen to have a copy of the CUPS book, and it mentions two commands, viz:

/usr/bin/enable <name>

and

/usr/bin/disable <name>

to start and stop printer queues. Alas, Debian does not have enable/disable commands that I could find. I did a little more digging, and an "apropos cups" command (part of the "man" facility) showed a lot of commands related to CUPS. In particular, I spotted "/usr/sbin/cupsenable" and "/usr/sbin/cupsdisable". Sure enough, on Debian CUPS, these are the command line versions to enable and disable printer queues.


Best regards,

Lester
 
4 members found this post helpful.
Old 04-17-2010, 10:37 PM   #5
caffeineAddict
LQ Newbie
 
Registered: Apr 2010
Posts: 1

Rep: Reputation: 0
Thank you

I registered to this site to thank you, tangoholic. You really saved the day with this post. Thank you!!!!
 
Old 06-04-2012, 05:11 PM   #6
eaberry
LQ Newbie
 
Registered: Jan 2007
Posts: 7

Rep: Reputation: 1
Thumbs up

"/usr/sbin/cupsenable" and "/usr/sbin/cupsdisable". Sure enough, on Debian CUPS, these are the command line versions to enable and disable printer queues.

Works on Fedora 14 also.
Thank you! Thought i had lost the use of my printer until the next reboot just because i tried to print when it was off.

Last edited by eaberry; 06-04-2012 at 05:13 PM. Reason: typo
 
1 members found this post helpful.
Old 06-05-2012, 01:48 AM   #7
tailinlinux
Member
 
Registered: Oct 2010
Location: Paudpod, Botolan, Zambales, Philippines
Distribution: Mandriva, Ubuntu, Mint, Open Suse, Meego
Posts: 390
Blog Entries: 3

Rep: Reputation: 25
Quote:
Originally Posted by eaberry View Post
"/usr/sbin/cupsenable" and "/usr/sbin/cupsdisable". Sure enough, on Debian CUPS, these are the command line versions to enable and disable printer queues.

Works on Fedora 14 also.
Thank you! Thought i had lost the use of my printer until the next reboot just because i tried to print when it was off.
or this one

service cups restart
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
server-error-internal-error with CUPS "Configure Printer" fskmh Slackware 6 06-05-2013 02:51 PM
ALSA + slmodemd + "semaphore not ready" + no modem noise cyberjun Linux - Laptop and Netbook 21 04-06-2005 02:39 PM
KDE/CUPS printer slow to start up; fixed with "127.0.0.1 localhost" in /etc/hosts KWTm LinuxQuestions.org Member Success Stories 0 03-05-2005 12:11 PM
How to start KDE automaticlly without typing "startx" then "startkde" Jonescity Slackware 8 10-29-2004 10:32 PM
CUPS keeps "forgetting" my USB printer! JazzMastaJim Linux - Hardware 3 06-17-2004 12:40 AM


All times are GMT -5. The time now is 12:59 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration