LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-25-2015, 09:45 PM   #1
ramsforums
Member
 
Registered: Jun 2007
Posts: 58

Rep: Reputation: 0
Question how do I solve the following error?


while executing
sudo apt-get update

I am getting the following error at the end of execution.

W: Failed to fetch http://ppa.launchpad.net/noobslab/ic...Translation-en Hash Sum mismatch

W: Failed to fetch http://ppa.launchpad.net/noobslab/th...Translation-en Hash Sum mismatch

E: Some index files failed to download. They have been ignored, or old ones used instead.

How do I fix?

Thank you
 
Old 09-25-2015, 10:08 PM   #2
ardvark71
LQ Veteran
 
Registered: Feb 2015
Location: Oregon, USA
Distribution: Lubuntu 14.04, Windows Vista
Posts: 5,182
Blog Entries: 3

Rep: Reputation: 694Reputation: 694Reputation: 694Reputation: 694Reputation: 694Reputation: 694
Quote:
Originally Posted by ramsforums View Post
How do I fix?
Hi...

I'm not sure this will work in your case but you can try the instructions here.

Regards...
 
Old 09-25-2015, 11:54 PM   #3
ramsforums
Member
 
Registered: Jun 2007
Posts: 58

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by ardvark71 View Post
Hi...

I'm not sure this will work in your case but you can try the instructions here.

Regards...


Thanks

I have tried as follows


Quote:

sudo -i
apt-get clean
cd /var/lib/apt
mv lists lists.old
mkdir -p lists/partial
apt-get clean
apt-get update

Also tried

Quote:
sudo rm /var/lib/apt/lists/* -vf

sudo apt-get update
Now I get the following

Code:
Fetched 33.1 MB in 52s (634 kB/s)
W: Failed to fetch http://ppa.launchpad.net/noobslab/icons/ubuntu/dists/trusty/main/i18n/Translation-en  Hash Sum mismatch

E: Some index files failed to download. They have been ignored, or old ones used instead.
Previously I used to get two Failed fetch .. Has Sum mismatch now I get only one.

Last edited by ramsforums; 09-25-2015 at 11:55 PM.
 
Old 09-26-2015, 01:13 AM   #4
ardvark71
LQ Veteran
 
Registered: Feb 2015
Location: Oregon, USA
Distribution: Lubuntu 14.04, Windows Vista
Posts: 5,182
Blog Entries: 3

Rep: Reputation: 694Reputation: 694Reputation: 694Reputation: 694Reputation: 694Reputation: 694
Quote:
Originally Posted by ramsforums View Post
Previously I used to get two Failed fetch .. Has Sum mismatch now I get only one.
Well, that's an improvement.

Could you post the contents of your "/etc/apt/sources.list" file?

I also found this page with a slightly different command but I'm not sure it will work.

Regards...

Last edited by ardvark71; 09-26-2015 at 01:21 AM. Reason: Added information.
 
Old 09-26-2015, 01:27 AM   #5
norobro
Member
 
Registered: Feb 2006
Distribution: Debian Sid
Posts: 518

Rep: Reputation: 177Reputation: 177
There is something odd going on with the "i18n" directory on that server. It shows up in the directory listing but if you click on it, you get "not found on this server". Parent directory link
 
Old 09-26-2015, 02:23 AM   #6
ardvark71
LQ Veteran
 
Registered: Feb 2015
Location: Oregon, USA
Distribution: Lubuntu 14.04, Windows Vista
Posts: 5,182
Blog Entries: 3

Rep: Reputation: 694Reputation: 694Reputation: 694Reputation: 694Reputation: 694Reputation: 694
Quote:
Originally Posted by norobro View Post
There is something odd going on with the "i18n" directory on that server. It shows up in the directory listing but if you click on it, you get "not found on this server". Parent directory link
Hi...

Good point but I wonder why one of the two entries seems to be resolved?

Regards...
 
Old 09-26-2015, 09:51 AM   #7
ramsforums
Member
 
Registered: Jun 2007
Posts: 58

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by ardvark71 View Post
Well, that's an improvement.

Could you post the contents of your "/etc/apt/sources.list" file?

I also found this page with a slightly different command but I'm not sure it will work.

Regards...
Thanks

I have tried the link you have provided. I still get the same error.

Here is the sources.list

Code:
# deb http://us.archive.ubuntu.com/ubuntu/ trusty main restricted

# deb http://us.archive.ubuntu.com/ubuntu/ trusty-updates main restricted
# deb http://security.ubuntu.com/ubuntu trusty-security main restricted

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://us.archive.ubuntu.com/ubuntu/ trusty main restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ trusty main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://us.archive.ubuntu.com/ubuntu/ trusty-updates main restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ trusty-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://us.archive.ubuntu.com/ubuntu/ trusty universe
deb-src http://us.archive.ubuntu.com/ubuntu/ trusty universe
deb http://us.archive.ubuntu.com/ubuntu/ trusty-updates universe
deb-src http://us.archive.ubuntu.com/ubuntu/ trusty-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
## team, and may not be under a free licence. Please satisfy yourself as to 
## your rights to use the software. Also, please note that software in 
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://us.archive.ubuntu.com/ubuntu/ trusty multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ trusty multiverse
deb http://us.archive.ubuntu.com/ubuntu/ trusty-updates multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ trusty-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.

deb http://security.ubuntu.com/ubuntu trusty-security main restricted
deb-src http://security.ubuntu.com/ubuntu trusty-security main restricted
deb http://security.ubuntu.com/ubuntu trusty-security universe
deb-src http://security.ubuntu.com/ubuntu trusty-security universe
deb http://security.ubuntu.com/ubuntu trusty-security multiverse
deb-src http://security.ubuntu.com/ubuntu trusty-security multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
deb http://archive.canonical.com/ubuntu trusty partner
# deb-src http://archive.canonical.com/ubuntu trusty partner

## Uncomment the following two lines to add software from Ubuntu's
## 'extras' repository.
## This software is not part of Ubuntu, but is offered by third-party
## developers who want to ship their latest software.
deb http://extras.ubuntu.com/ubuntu trusty main
# deb-src http://extras.ubuntu.com/ubuntu trusty main
deb http://downloads.sourceforge.net/project/ubuntuzilla/mozilla/apt all main
# deb-src http://downloads.sourceforge.net/project/ubuntuzilla/mozilla/apt all main
deb http://us.archive.ubuntu.com/ubuntu/ trusty-backports universe multiverse main restricted
 
Old 09-26-2015, 05:48 PM   #8
ardvark71
LQ Veteran
 
Registered: Feb 2015
Location: Oregon, USA
Distribution: Lubuntu 14.04, Windows Vista
Posts: 5,182
Blog Entries: 3

Rep: Reputation: 694Reputation: 694Reputation: 694Reputation: 694Reputation: 694Reputation: 694
Hi...

Unless I'm missing something, I don't see any reference to the PPA mentioned in your error messages. Are you using Ubuntu, Mint or some other distribution that uses Ubuntu's repositories?

Regards...
 
Old 09-26-2015, 08:20 PM   #9
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware
Posts: 6,411
Blog Entries: 6

Rep: Reputation: Disabled
Looking at the sources.list it looks like our op is running Ubuntu.-

That's the Trusty Repository:-
 
Old 09-26-2015, 08:45 PM   #10
ramsforums
Member
 
Registered: Jun 2007
Posts: 58

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by ardvark71 View Post
Hi...

Unless I'm missing something, I don't see any reference to the PPA mentioned in your error messages. Are you using Ubuntu, Mint or some other distribution that uses Ubuntu's repositories?

Regards...
I am using LXLE
 
Old 09-26-2015, 09:13 PM   #11
norobro
Member
 
Registered: Feb 2006
Distribution: Debian Sid
Posts: 518

Rep: Reputation: 177Reputation: 177
Do you have a directory named "/etc/apt/sources.list.d"?

Please post the output of:
Code:
ls -l /etc/apt/sources.list.d
Or post the output of "inxi -r" if you have inxi installed:
Code:
$ inxi -r
Repos:     Active apt sources in file: /etc/apt/sources.list
           deb http://ftp.us.debian.org/debian/ sid main non-free contrib
           Active apt sources in file: /etc/apt/sources.list.d/google-chrome.list
           deb http://dl.google.com/linux/chrome/deb/ stable main
           Active apt sources in file: /etc/apt/sources.list.d/google-earth.list
           deb http://dl.google.com/linux/earth/deb/ stable main
 
Old 09-26-2015, 09:52 PM   #12
ramsforums
Member
 
Registered: Jun 2007
Posts: 58

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by norobro View Post
Do you have a directory named "/etc/apt/sources.list.d"?

Please post the output of:
Code:
ls -l /etc/apt/sources.list.d
Or post the output of "inxi -r" if you have inxi installed:
Code:
$ inxi -r
Repos:     Active apt sources in file: /etc/apt/sources.list
           deb http://ftp.us.debian.org/debian/ sid main non-free contrib
           Active apt sources in file: /etc/apt/sources.list.d/google-chrome.list
           deb http://dl.google.com/linux/chrome/deb/ stable main
           Active apt sources in file: /etc/apt/sources.list.d/google-earth.list
           deb http://dl.google.com/linux/earth/deb/ stable main
Thanks for the help.

I ran

sudo apt-get update

The result as follows
Code:
W: Failed to fetch http://archive.getdeb.net/ubuntu/dists/trusty-getdeb/games/binary-amd64/Packages  Hash Sum mismatch

W: Failed to fetch http://archive.getdeb.net/ubuntu/dists/trusty-getdeb/games/binary-i386/Packages  Hash Sum mismatch

W: Failed to fetch http://ppa.launchpad.net/noobslab/icons/ubuntu/dists/trusty/main/i18n/Translation-en  Hash Sum mismatch

E: Some index files failed to download. They have been ignored, or old ones used instead.
Installed inxi and ran the following command

inxi -r

the result as follows
Code:
Repos:     Active apt sources in file: /etc/apt/sources.list
           deb http://us.archive.ubuntu.com/ubuntu/ trusty main restricted
           deb-src http://us.archive.ubuntu.com/ubuntu/ trusty main restricted
           deb http://us.archive.ubuntu.com/ubuntu/ trusty-updates main restricted
           deb-src http://us.archive.ubuntu.com/ubuntu/ trusty-updates main restricted
           deb http://us.archive.ubuntu.com/ubuntu/ trusty universe
           deb-src http://us.archive.ubuntu.com/ubuntu/ trusty universe
           deb http://us.archive.ubuntu.com/ubuntu/ trusty-updates universe
           deb-src http://us.archive.ubuntu.com/ubuntu/ trusty-updates universe
           deb http://us.archive.ubuntu.com/ubuntu/ trusty multiverse
           deb-src http://us.archive.ubuntu.com/ubuntu/ trusty multiverse
           deb http://us.archive.ubuntu.com/ubuntu/ trusty-updates multiverse
           deb-src http://us.archive.ubuntu.com/ubuntu/ trusty-updates multiverse
           deb http://security.ubuntu.com/ubuntu trusty-security main restricted
           deb-src http://security.ubuntu.com/ubuntu trusty-security main restricted
           deb http://security.ubuntu.com/ubuntu trusty-security universe
           deb-src http://security.ubuntu.com/ubuntu trusty-security universe
           deb http://security.ubuntu.com/ubuntu trusty-security multiverse
           deb-src http://security.ubuntu.com/ubuntu trusty-security multiverse
           deb http://archive.canonical.com/ubuntu trusty partner
           deb http://extras.ubuntu.com/ubuntu trusty main
           deb http://downloads.sourceforge.net/project/ubuntuzilla/mozilla/apt all main
           deb http://us.archive.ubuntu.com/ubuntu/ trusty-backports universe multiverse main restricted
           Active apt sources in file: /etc/apt/sources.list.d/anonbeat-guayadeque-trusty.list
           deb http://ppa.launchpad.net/anonbeat/guayadeque/ubuntu trusty main
           Active apt sources in file: /etc/apt/sources.list.d/catfish-search-catfish-stable-trusty.list
           deb http://ppa.launchpad.net/catfish-search/catfish-stable/ubuntu trusty main
           Active apt sources in file: /etc/apt/sources.list.d/claws-mail-ppa-trusty.list
           deb http://ppa.launchpad.net/claws-mail/ppa/ubuntu trusty main
           Active apt sources in file: /etc/apt/sources.list.d/getdeb.list
           deb http://archive.getdeb.net/ubuntu trusty-getdeb apps
           Active apt sources in file: /etc/apt/sources.list.d/google.list
           deb http://dl.google.com/linux/chrome/deb/ stable main
           Active apt sources in file: /etc/apt/sources.list.d/kubuntu-ppa-backports-trusty.list
           deb http://ppa.launchpad.net/kubuntu-ppa/backports/ubuntu trusty main
           Active apt sources in file: /etc/apt/sources.list.d/libreoffice-ppa-trusty.list
           deb http://ppa.launchpad.net/libreoffice/ppa/ubuntu trusty main
           Active apt sources in file: /etc/apt/sources.list.d/linphone-release-trusty.list
           deb http://ppa.launchpad.net/linphone/release/ubuntu trusty main
           Active apt sources in file: /etc/apt/sources.list.d/linrunner-tlp-trusty.list
           deb http://ppa.launchpad.net/linrunner/tlp/ubuntu trusty main
           Active apt sources in file: /etc/apt/sources.list.d/lxle-stable-trusty.list
           deb http://ppa.launchpad.net/lxle/stable/ubuntu trusty main
           Active apt sources in file: /etc/apt/sources.list.d/mdoyen-homebank-trusty.list
           deb http://ppa.launchpad.net/mdoyen/homebank/ubuntu trusty main
           Active apt sources in file: /etc/apt/sources.list.d/mkusb-ppa-trusty.list
           deb http://ppa.launchpad.net/mkusb/ppa/ubuntu trusty main
           Active apt sources in file: /etc/apt/sources.list.d/nemh-systemback-trusty.list
           deb http://ppa.launchpad.net/nemh/systemback/ubuntu trusty main
           Active apt sources in file: /etc/apt/sources.list.d/nilarimogard-webupd8-trusty.list
           deb http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu trusty main
           Active apt sources in file: /etc/apt/sources.list.d/noobslab-icons-trusty.list
           deb http://ppa.launchpad.net/noobslab/icons/ubuntu trusty main
           Active apt sources in file: /etc/apt/sources.list.d/noobslab-themes-trusty.list
           deb http://ppa.launchpad.net/noobslab/themes/ubuntu trusty main
           Active apt sources in file: /etc/apt/sources.list.d/nowrep-qupzilla-trusty.list
           deb http://ppa.launchpad.net/nowrep/qupzilla/ubuntu trusty main
           Active apt sources in file: /etc/apt/sources.list.d/otto-kesselgulasch-gimp-trusty.list
           deb http://ppa.launchpad.net/otto-kesselgulasch/gimp/ubuntu trusty main
           Active apt sources in file: /etc/apt/sources.list.d/paolorotolo-copy-trusty.list
           deb http://ppa.launchpad.net/paolorotolo/copy/ubuntu trusty main
           Active apt sources in file: /etc/apt/sources.list.d/pithos-ppa-trusty.list
           deb http://ppa.launchpad.net/pithos/ppa/ubuntu trusty main
           Active apt sources in file: /etc/apt/sources.list.d/playdeb.list
           deb http://archive.getdeb.net/ubuntu trusty-getdeb games
           Active apt sources in file: /etc/apt/sources.list.d/plushuang-tw-uget-stable-trusty.list
           deb http://ppa.launchpad.net/plushuang-tw/uget-stable/ubuntu trusty main
           Active apt sources in file: /etc/apt/sources.list.d/tuxpoldo-btsync-trusty.list
           deb http://ppa.launchpad.net/tuxpoldo/btsync/ubuntu trusty main
           Active apt sources in file: /etc/apt/sources.list.d/ubuntugames-games-trusty.list
           deb http://ppa.launchpad.net/ubuntugames/games/ubuntu trusty main
           Active apt sources in file: /etc/apt/sources.list.d/v-2e-tox-trusty.list
           deb http://ppa.launchpad.net/v-2e/tox/ubuntu trusty main
           Active apt sources in file: /etc/apt/sources.list.d/videolan-stable-daily-trusty.list
           deb http://ppa.launchpad.net/videolan/stable-daily/ubuntu trusty main
           Active apt sources in file: /etc/apt/sources.list.d/webupd8team-y-ppa-manager-trusty.list
           deb http://ppa.launchpad.net/webupd8team/y-ppa-manager/ubuntu trusty main
           Active apt sources in file: /etc/apt/sources.list.d/ytvwld-syncthing-trusty.list
           deb http://ppa.launchpad.net/ytvwld/syncthing/ubuntu trusty main
 
Old 09-26-2015, 10:14 PM   #13
norobro
Member
 
Registered: Feb 2006
Distribution: Debian Sid
Posts: 518

Rep: Reputation: 177Reputation: 177
Holy cow! Lots of repositories.

Since you were able to install "inxi", I think that the "error" that you are getting is really just a warning because there is something wrong with that one repository. As I see it you have two options:
  1. Ignore the warning and wait for "noobslab" to correct their problem
  2. Get rid of the warning by changing the name of the file "/etc/apt/sources.list.d/noobslab-icons-trusty.list"
    Something like this:
    Code:
    rename /etc/apt/sources.list.d/noobslab-icons-trusty.list *~ 
        Disregard - this command is incorrect. See edit.
    Then change it back at a later date to check to see if the site has been fixed.

Edit: You might need to rename the other file for "noobslab" also.
Code:
# rename 's/(.*noobslab.*)/$1~/' /etc/apt/sources.list.d/*

Last edited by norobro; 09-27-2015 at 12:12 PM.
 
Old 09-26-2015, 10:22 PM   #14
ramsforums
Member
 
Registered: Jun 2007
Posts: 58

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by norobro View Post
Holy cow! Lots of repositories.

Since you were able to install "inxi", I think that the "error" that you are getting is really just a warning because there is something wrong with that one repository. As I see it you have two options:
  1. Ignore the warning and wait for "noobslab" to correct their problem
  2. Get rid of the warning by changing the name of the file "/etc/apt/sources.list.d/noobslab-icons-trusty.list"
    Something like this:
    Code:
    rename /etc/apt/sources.list.d/noobslab-icons-trusty.list *~
    Then change it back at a later date to check to see if the site has been fixed.

Edit: You might need to rename the other file for "noobslab" also.
Code:
rename /etc/apt/sources.list.d/noobslab-themes-trusty.list *~

Thanks norobro.

When I invoke the first command I get the following
Code:
Bareword "noobslab" not allowed while "strict subs" in use at (eval 1) line 1.
Bareword "themes" not allowed while "strict subs" in use at (eval 1) line 1.
Bareword "trusty" not allowed while "strict subs" in use at (eval 1) line 1.
Bareword "list" not allowed while "strict subs" in use at (eval 1) line 1.
 
Old 09-26-2015, 10:29 PM   #15
norobro
Member
 
Registered: Feb 2006
Distribution: Debian Sid
Posts: 518

Rep: Reputation: 177Reputation: 177
Try renaming them with your file manager. As a last resort you can just delete them.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
I can't solve this error rexyuan Linux - General 3 08-31-2015 04:25 AM
want help to solve this error dalalami21 Linux - Software 1 03-02-2013 01:57 PM
How can i solve this error? bala_adi Red Hat 5 04-25-2009 10:26 AM
help me how to solve this error?? MahARaJaAngKaSa Ubuntu 1 04-20-2009 04:23 AM
How to solve this Error message jmfa59 Linux - Newbie 3 07-03-2007 09:32 AM


All times are GMT -5. The time now is 08:19 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration