LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-16-2003, 02:44 AM   #1
yzrider210
Member
 
Registered: Oct 2003
Location: Nor Cal
Distribution: SuSE 9.0 Pro
Posts: 130

Rep: Reputation: 15
how do i shut down X server?


I'm trying to install a NVidia driver, and when I give it the command to install, it says it has detected X server (I believe it was X server.....it was X somthing) and that it needs to be shut down before i can install the driver. How do i do this?
 
Old 11-16-2003, 05:49 AM   #2
baud
Member
 
Registered: Aug 2003
Location: Versailles
Distribution: Mandrakecooker 10.1
Posts: 67

Rep: Reputation: 15
telinit 3 # will reboot to mode 3 of inittab (no window manager)
do your installation
telinit 5 # will bring you back to your normal boot sequence

an alternative is to edit /etc/inittab : the following line from 3 to 5
id:5:initdefault:
and reboot each time...
 
Old 11-16-2003, 05:50 AM   #3
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,085

Rep: Reputation: 398Reputation: 398Reputation: 398Reputation: 398
You need (as root) to edit the file /etc/inittab

Find the line that says

id:5:initdefault:

And change it to

id:3:initdefault:

Save the file and reboot.

You will be in text mode, with a text login. Login and install the driver.

Type startx to test it. If it works, and you want to boot into Xwindows rather than typing startx every time you reboot, re-edit /etc/inittab changing the 3 back to a 5, save the file, then reboot, by giving the command shutdown -r

HTH
 
Old 11-16-2003, 08:25 AM   #4
dalek
Senior Member
 
Registered: Jul 2003
Location: Mississippi USA
Distribution: Gentoo
Posts: 2,058
Blog Entries: 2

Rep: Reputation: 79
You could also read this.

http://www.linuxquestions.org/questi...ticle&artid=30

Yep, I wrote it. It is hard to find though.

Later

 
Old 11-16-2003, 11:26 AM   #5
teval
Member
 
Registered: Jul 2003
Location: Toronto, Canada
Distribution: Gentoo
Posts: 720

Rep: Reputation: 30
Or.. you can simply

CTRL + ALT + BACKSPACE

And then install the nvidia driver
type startx to start X back up.
This is if you haven't started X from a graphical login.
Alternativly you can:

CTRL + ALT + F2
Log in there, and type:
killall -9 x
killall -9 xinit
killall -9 startx

And then install the driver
 
Old 11-17-2003, 11:30 AM   #6
yzrider210
Member
 
Registered: Oct 2003
Location: Nor Cal
Distribution: SuSE 9.0 Pro
Posts: 130

Original Poster
Rep: Reputation: 15
ok, thanx, I'll try those when I get home
 
Old 11-20-2003, 01:26 AM   #7
yzrider210
Member
 
Registered: Oct 2003
Location: Nor Cal
Distribution: SuSE 9.0 Pro
Posts: 130

Original Poster
Rep: Reputation: 15
It still doesn't work.....gives me a bunch of error messages like it can't identify my kernel
 
Old 11-20-2003, 01:41 AM   #8
GrapeApe
Member
 
Registered: Nov 2003
Distribution: Mandrake 9.2
Posts: 57

Rep: Reputation: 15
what exactly were you doing when you got the error message?
what is the exact error message?
 
Old 11-20-2003, 02:07 AM   #9
wiraone
Member
 
Registered: Nov 2003
Location: Diawang-awangan
Distribution: Ubuntu Hoary!
Posts: 319

Rep: Reputation: 30
Why oh why you need to reboot when you can simply do the following:

1. clt-alt-f1
2. logon as root
3. $ init 3
4. install the NVIDIA driver
5. $ init 5
 
Old 11-20-2003, 11:58 AM   #10
yzrider210
Member
 
Registered: Oct 2003
Location: Nor Cal
Distribution: SuSE 9.0 Pro
Posts: 130

Original Poster
Rep: Reputation: 15
I'm not at my Linux comp now, so I can't check the actual error message, however I will when i get home.

I logged into root, opened the console and typed telinit 3 #
That brought me into the shell out of X window, and I typed sh NVIDIA-Linux-x86-1.0-4496-pkg2.run
Then it brought up quite a few error messages
 
Old 11-20-2003, 09:46 PM   #11
yzrider210
Member
 
Registered: Oct 2003
Location: Nor Cal
Distribution: SuSE 9.0 Pro
Posts: 130

Original Poster
Rep: Reputation: 15
OK, heres the log file from the installation:

nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Thu Nov 20 18:40:58 2003

option status:
license pre-accepted : false
update : false
force update : false
expert : false
uninstall : false
driver info : false
no precompiled interface: false
no ncurses color : false
query latest driver ver : false
OpenGL header files : false
no questions : false
silent : false
XFree86 install prefix : /usr/X11R6
OpenGL install prefix : /usr
Installer install prefix: /usr
kernel include path : (not specified)
kernel install path : (not specified)
proc mount point : /proc
ui : (not specified)
tmpdir : /tmp
ftp site : ftp://download.nvidia.com

Using: nvidia-installer ncurses user interface
-> License accepted.
-> No precompiled kernel interface was found to match your kernel; would you li
ke the installer to attempt to download a kernel interface for your kernel f
rom the NVIDIA ftp site (ftp://download.nvidia.com)? (Answer: No)
-> No precompiled kernel interface was found to match your kernel; this means
that the installer will need to compile a new kernel interface.
ERROR: Unable to find the kernel header files for the currently running kernel.
Please make sure you have installed the kernel header files for your
kernel; on Red Hat Linux systems, for example, be sure you have the
'kernel-source' rpm installed. If you know the correct kernel header
files are installed, you may specify the kernel include path with the
'--kernel-include-path' commandline option.
ERROR: Installation has failed. Please see the file
'/var/log/nvidia-installer.log' for details. You may find suggestions
on fixing installation problems in the README available on the Linux
driver download page at www.nvidia.com.

PS I chose not to download anything cuz I don't have a clue how to or even if its possible to use my dialup connection in shell......whenever i go to shell it automatically kills my connection

Last edited by yzrider210; 11-20-2003 at 09:49 PM.
 
Old 11-21-2003, 02:11 AM   #12
GrapeApe
Member
 
Registered: Nov 2003
Distribution: Mandrake 9.2
Posts: 57

Rep: Reputation: 15
i got that kernel header error message when i was installing my modem on mandrake. i'm not familiar with suse at all but i imagine that somewhere you have a program to install various packages and rpms (in mandrake it's rpmdrake). all i had to do was do a search for "kernel" in rpmdrake and it came back with the option to install "kernel-source-2.4.22-6mdk". so it sounds to me like you need to find out what kernel you are currently running and install the kernel source package/rpm for it. i'm pretty new to linux so you may want to get a 2nd opinion but it might be worth checking out.
 
Old 11-21-2003, 11:12 AM   #13
yzrider210
Member
 
Registered: Oct 2003
Location: Nor Cal
Distribution: SuSE 9.0 Pro
Posts: 130

Original Poster
Rep: Reputation: 15
ok, that sorta makes sense........
First, how do I find out what kernel I have?
Second, how do I install the source package for it?
 
Old 11-21-2003, 02:11 PM   #14
GrapeApe
Member
 
Registered: Nov 2003
Distribution: Mandrake 9.2
Posts: 57

Rep: Reputation: 15
from what i can tell it seems like SuSE 9.0 Pro uses the 2.4.21 kernel. i think your package management tool is called yast.....like i said i've never used suse so take everything i say with a grain of salt!!! if yast is anything like rpmdrake you should be able to search for or browse packages you have available to you to install. if you can't find it in some package management tool you probably would be able to download it from the suse website. you probably could also try a new post/search concerning suse package/rpm installation. it may grab the attention of some suse gurus out there that have much more knowledge about SuSE specific questions than i do.
 
Old 11-21-2003, 03:44 PM   #15
dalek
Senior Member
 
Registered: Jul 2003
Location: Mississippi USA
Distribution: Gentoo
Posts: 2,058
Blog Entries: 2

Rep: Reputation: 79
Try this.

Code:
uname -r
That should tell you what kernel version you using.

Later

 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't shut down X server, tried everything(?) trentr Linux - General 4 11-30-2005 07:55 PM
how to shut downd X server from X server? mac1234mac Linux - Software 2 09-16-2005 01:02 PM
X-server.. how do I shut overproof Linux - Newbie 6 04-08-2005 01:43 AM
How do I shut down the x-server? JackieBrown SUSE / openSUSE 1 12-29-2004 08:50 PM
Auto shut down server ! the_reen Red Hat 1 07-08-2004 11:01 PM


All times are GMT -5. The time now is 11:46 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration