LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
LinkBack Search this Thread
Old 08-14-2005, 11:17 AM   #1
banner
Member
 
Registered: Mar 2005
Posts: 49

Rep: Reputation: 15
How do I Sharing A NTFS Drive with everyone


I would like to know how to share a NTFS drive with everyone onmy thin client network, basicall it seems that onle the root can access the files, but when a regular user tries to access the drive. Iget a permissioned denied.I tried right clicking and going under properties and give group access to everyone , butthat does not seem to work. So how can I share a NTFS drive in which all users who log in can access that drive.

I am stuck?

O by the way i am using fedora 4
 
Old 08-14-2005, 12:06 PM   #2
tuxdev
Senior Member
 
Registered: Jul 2005
Distribution: Slackware
Posts: 2,008

Rep: Reputation: 110Reputation: 110
try putting something like this in your /etc/fstab.
Code:
/dev/hdb1        /home            vfat        auto,owner,users       1   0
Of course, your filesystem is ntfs and not vfat, and is read only (ro). Also, any thin client can be though of as equal to sitting in front of the server computer.
 
Old 08-14-2005, 12:14 PM   #3
Boow
Member
 
Registered: Feb 2004
Distribution: Slackware 10.2
Posts: 669

Rep: Reputation: 32
You need uid gid umask options in you fstab. type man mount for more info on those options. man pages can be hard to understand but there are plenty of examples on the net. Here one example

/dev/hda1 /mnt/windows ntfs ro,uid=1000,gid=100,umask 0227,users 0 0
 
Old 08-14-2005, 12:23 PM   #4
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,697

Rep: Reputation: 61
just add umask=0000. That will take care of it.

Brian1
 
Old 08-14-2005, 07:57 PM   #5
banner
Member
 
Registered: Mar 2005
Posts: 49

Original Poster
Rep: Reputation: 15
unmask=000 ?

just add umask=0000. That will take care of it.


what does it do and where do i set these settings up, sorry i am a newbie.
 
Old 08-16-2005, 04:38 PM   #6
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,697

Rep: Reputation: 61
Edit your /etc/fstab file and have it look like this. Change /dev/hda1 to match your drive and partition location.
Code:
/dev/hda1       	/winxp                  ntfs	umask=000,users,noauto,owner,ro 0 0
Brian1
 
Old 08-17-2005, 07:55 AM   #7
banner
Member
 
Registered: Mar 2005
Posts: 49

Original Poster
Rep: Reputation: 15
Still do not understand how to share Ntfs

I still can not share my ntfs drive, I tried folowing the instruction given , but i must be doing something wrong. I will give you the settings i have in my fstab settings. maybe some can tell me what i am doing wrong. Please help


# This file is edited by fstab-sync - see 'man fstab-sync' for details
/dev/VolGroup00/LogVol00 / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
none /dev/pts devpts gid=5,mode=620 0 0
none /dev/shm tmpfs defaults 0 0
none /proc proc defaults 0 0
none /sys sysfs defaults 0 0
/dev/VolGroup00/LogVol01 swap swap defaults 0 0
/dev/hdc /media/cdrom auto pamconsole,exec,noauto,managed 0 0
/dev/sda1 /media/Entartainment ntfs ro,uid=1000,gid=100,umask 0227,users 0 0 pamconsole,exec,noauto,fscontext=system_ubject_r:removable_t,managed 0 0
/dev/sdb1 /media/USB_DRIVE vfat pamconsole,exec,noauto,fscontext=system_ubject_r:removable_t,managed 0 0
 
Old 08-18-2005, 05:05 PM   #8
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,697

Rep: Reputation: 61
The line you have does not follow the fstab structure. Give this one a try.
Code:
/dev/sda1    /media/Entartainment     ntfs	umask=000,users,noauto,owner,ro 0 0
Brian1
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Moving files from NTFS drive to a EXT3 drive?? webshark Slackware 10 05-28-2006 03:02 PM
slackware 9.1 mounting problems (cd drive, cd writer drive, win partition (ntfs)) mr.gizm0 Slackware 8 05-11-2004 06:23 PM
Setting up a 120gb NTFS Hard Drive and sharing it as an ftp server AnarKi Linux - Newbie 1 11-12-2003 04:30 PM
Sharing NTFS stuff? Tayl Linux - General 6 09-24-2003 09:47 PM
Cannot Copy Files From Network FAT32/NTFS Drive to My Local Linux Drive michaelh Linux - Networking 3 10-29-2002 10:27 AM


All times are GMT -5. The time now is 08:49 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration