LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   How do I Sharing A NTFS Drive with everyone (http://www.linuxquestions.org/questions/linux-newbie-8/how-do-i-sharing-a-ntfs-drive-with-everyone-353161/)

banner 08-14-2005 11:17 AM

How do I Sharing A NTFS Drive with everyone
 
I would like to know how to share a NTFS drive with everyone onmy thin client network, basicall it seems that onle the root can access the files, but when a regular user tries to access the drive. Iget a permissioned denied.I tried right clicking and going under properties and give group access to everyone , butthat does not seem to work. So how can I share a NTFS drive in which all users who log in can access that drive.

I am stuck?

O by the way i am using fedora 4

tuxdev 08-14-2005 12:06 PM

try putting something like this in your /etc/fstab.
Code:

/dev/hdb1        /home            vfat        auto,owner,users      1  0
Of course, your filesystem is ntfs and not vfat, and is read only (ro). Also, any thin client can be though of as equal to sitting in front of the server computer.

Boow 08-14-2005 12:14 PM

You need uid gid umask options in you fstab. type man mount for more info on those options. man pages can be hard to understand but there are plenty of examples on the net. Here one example

/dev/hda1 /mnt/windows ntfs ro,uid=1000,gid=100,umask 0227,users 0 0

Brian1 08-14-2005 12:23 PM

just add umask=0000. That will take care of it.

Brian1

banner 08-14-2005 07:57 PM

unmask=000 ?
 
just add umask=0000. That will take care of it.


what does it do and where do i set these settings up, sorry i am a newbie.

Brian1 08-16-2005 04:38 PM

Edit your /etc/fstab file and have it look like this. Change /dev/hda1 to match your drive and partition location.
Code:

/dev/hda1              /winxp                  ntfs        umask=000,users,noauto,owner,ro 0 0
Brian1

banner 08-17-2005 07:55 AM

Still do not understand how to share Ntfs
 
I still can not share my ntfs drive, I tried folowing the instruction given , but i must be doing something wrong. I will give you the settings i have in my fstab settings. maybe some can tell me what i am doing wrong. Please help


# This file is edited by fstab-sync - see 'man fstab-sync' for details
/dev/VolGroup00/LogVol00 / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
none /dev/pts devpts gid=5,mode=620 0 0
none /dev/shm tmpfs defaults 0 0
none /proc proc defaults 0 0
none /sys sysfs defaults 0 0
/dev/VolGroup00/LogVol01 swap swap defaults 0 0
/dev/hdc /media/cdrom auto pamconsole,exec,noauto,managed 0 0
/dev/sda1 /media/Entartainment ntfs ro,uid=1000,gid=100,umask 0227,users 0 0 pamconsole,exec,noauto,fscontext=system_u:object_r:removable_t,managed 0 0
/dev/sdb1 /media/USB_DRIVE vfat pamconsole,exec,noauto,fscontext=system_u:object_r:removable_t,managed 0 0

Brian1 08-18-2005 05:05 PM

The line you have does not follow the fstab structure. Give this one a try.
Code:

/dev/sda1    /media/Entartainment    ntfs        umask=000,users,noauto,owner,ro 0 0
Brian1


All times are GMT -5. The time now is 12:48 AM.