LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-12-2004, 03:24 PM   #1
zoe182
LQ Newbie
 
Registered: Feb 2004
Posts: 19

Rep: Reputation: 0
How do i mount USB HD in mdk 9.2


I'm the ultimate newbie so step by step by step by step by step *SIMPLE* instructions please..

I saw this on another post on a different site but i still do not understand.

"No way that you can mount anything if you are not root UNLESS you use "sudo" first!!! Therefore, you should put your name, as regular user, in /etc/sudoers and give yourself a permission to run the mount command then...

man sudo

for more info!

taurus"



 
Old 02-12-2004, 04:17 PM   #2
zoe182
LQ Newbie
 
Registered: Feb 2004
Posts: 19

Original Poster
Rep: Reputation: 0
bump...anyone..
 
Old 02-12-2004, 04:19 PM   #3
PenguinPwrdBox
Member
 
Registered: Oct 2003
Posts: 568

Rep: Reputation: 30
Well, first you have to ensure compatibility in the kernel for both the device and the filesystem......
 
Old 02-12-2004, 04:21 PM   #4
zoe182
LQ Newbie
 
Registered: Feb 2004
Posts: 19

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by PenguinPwrdBox
Well, first you have to ensure compatibility in the kernel for both the device and the filesystem......
Go on :P
 
Old 02-12-2004, 04:21 PM   #5
busbarn
Member
 
Registered: Feb 2002
Location: Denver, CO US
Distribution: Arch
Posts: 453

Rep: Reputation: 30
You don't need to be root to mount the drive, but you do need to be root to set it up. I hope this is step by step for you:

1. Log in as root or su into root
Code:
su
password:
#
2. You want to make sure that you have the usb drive plugged in, and that you have the following enabled in your kernel:
*USB supprt
*USB mass storage
*UHCI, OHCI, or EHCI (if you're using 2.6)
*General scsi support
*Support for scsi drives
You can do them as modules or enabled. I don't like dealing with modules so I just enable it. Personal preferance--some people notice a performance difference, but it's too much of a hastle for me.
There is plenty of information on this forum to learn how to compile your kernel, so I won't go into that.

3. As root, type the command (in a terminal like konsole, xterm, aterm, or eterm)
dmesg

a bunch of information will scroll by. Scroll up and look for something that says USB mass storage drive found on scsi blah blah blah. It should also tell you whether it has been assigned as sda, sdb, or sdc. I'm not at home so I cant post what it looks like. I'll try and come back and edit this for more details so you know what to look for.

4. You are still root, at the prompt type the following commands:
Code:
mkdir /mnt/usbdrive
open a text editor (I use gentoo and I really like nano as a cconsole text editor) and edit your file called fstab. This file is a list of mount points (in the most general sense)
Code:
nano -w /etc/fstab
and enter this line, where location is replaced by your result of dmesg:
Code:
/dev/location      /mnt/usbdrive  auto     rw,user,noauto  0  0
Remember location needs to be something like sda1, sda4, sdb1, or sdb4, etc. If the hard drive has a vfat file system, it will most likely be sda4. Otherwise, your chances are sda1 will be the answer, especially if it is the only usb device you have plugged in.

As root type:
Code:
mount /mnt/usbdrive
If you don't get any error messages, then you are good to go. Then type"

Code:
umount /mnt/usbdrive
Exit root, and you should be good to go.

Last edited by busbarn; 02-12-2004 at 04:23 PM.
 
Old 02-12-2004, 04:46 PM   #6
zoe182
LQ Newbie
 
Registered: Feb 2004
Posts: 19

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by busbarn
You don't need to be root to mount the drive, but you do need to be root to set it up. I hope this is step by step for you:

1. Log in as root or su into root
Code:
su
password:
#
2. You want to make sure that you have the usb drive plugged in, and that you have the following enabled in your kernel:
*USB supprt
*USB mass storage
*UHCI, OHCI, or EHCI (if you're using 2.6)
*General scsi support
*Support for scsi drives
You can do them as modules or enabled. I don't like dealing with modules so I just enable it. Personal preferance--some people notice a performance difference, but it's too much of a hastle for me.
There is plenty of information on this forum to learn how to compile your kernel, so I won't go into that.

3. As root, type the command (in a terminal like konsole, xterm, aterm, or eterm)
dmesg

a bunch of information will scroll by. Scroll up and look for something that says USB mass storage drive found on scsi blah blah blah. It should also tell you whether it has been assigned as sda, sdb, or sdc. I'm not at home so I cant post what it looks like. I'll try and come back and edit this for more details so you know what to look for.

4. You are still root, at the prompt type the following commands:
Code:
mkdir /mnt/usbdrive
open a text editor (I use gentoo and I really like nano as a cconsole text editor) and edit your file called fstab. This file is a list of mount points (in the most general sense)
Code:
nano -w /etc/fstab
and enter this line, where location is replaced by your result of dmesg:
Code:
/dev/location      /mnt/usbdrive  auto     rw,user,noauto  0  0
Remember location needs to be something like sda1, sda4, sdb1, or sdb4, etc. If the hard drive has a vfat file system, it will most likely be sda4. Otherwise, your chances are sda1 will be the answer, especially if it is the only usb device you have plugged in.

As root type:
Code:
mount /mnt/usbdrive
If you don't get any error messages, then you are good to go. Then type"

Code:
umount /mnt/usbdrive
Exit root, and you should be good to go.


------------------------------------------------------------------
On step 3 i got something that says....

hub.c: new USB device 00:11.3-1, assigned address 3
usb-uhci.c: interrupt, status 3, frame# 1012
scsi: device set offline - not ready or command retry failed after bus reset: host 1 channel 0 id 0 lun 0
WARNING: USB Mass Storage data integrity not assured
USB Mass Storage device found at 2
USB Mass Storage support registered.
hda: dma_intr: status=0x51 { DriveReady SeekComplete Error }
hda: dma_intr: error=0x84 { DriveStatusError BadCRC }
hda: dma_intr: status=0x51 { DriveReady SeekComplete Error }
hda: dma_intr: error=0x84 { DriveStatusError BadCRC }
scsi2 : SCSI emulation for USB Mass Storage devices
resize_dma_pool: unknown d
 
Old 02-12-2004, 05:12 PM   #7
busbarn
Member
 
Registered: Feb 2002
Location: Denver, CO US
Distribution: Arch
Posts: 453

Rep: Reputation: 30
i get that data integrity thing sometimes too. I don't understand it, but I haven't had any problems with it either.

Quote:
scsi: device set offline - not ready or command retry failed after bus reset: host 1 channel 0 id 0 lun 0
This tells me that maybe all of scsi isn't loaded or enabled kernel wise. Or is there no power going to the drive? Try typing

cat /proc/scsi/scsi

and post the results that you get.
 
Old 02-12-2004, 05:15 PM   #8
zoe182
LQ Newbie
 
Registered: Feb 2004
Posts: 19

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by busbarn
i get that data integrity thing sometimes too. I don't understand it, but I haven't had any problems with it either.



This tells me that maybe all of scsi isn't loaded or enabled kernel wise. Or is there no power going to the drive? Try typing

cat /proc/scsi/scsi

and post the results that you get.

Attached devices:
Host: scsi0 Channel: 00 Id: 00 Lun: 00
Vendor: PLEXTOR Model: CD-R PX-W4012A Rev: 1.01
Type: CD-ROM




I have problems with it turning on and off, it was on at the time, but maybe was in the process of turning off or somethnig... *shrug*

Last edited by zoe182; 02-12-2004 at 05:19 PM.
 
Old 02-12-2004, 08:03 PM   #9
busbarn
Member
 
Registered: Feb 2002
Location: Denver, CO US
Distribution: Arch
Posts: 453

Rep: Reputation: 30
THis shows that you do not have scsi disk support enabled or the module loaded. When you get that enabled and the drive is turned on and plugged in, the drive should show up in that cat /proc command.
 
Old 02-12-2004, 10:34 PM   #10
zoe182
LQ Newbie
 
Registered: Feb 2004
Posts: 19

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by busbarn
THis shows that you do not have scsi disk support enabled or the module loaded. When you get that enabled and the drive is turned on and plugged in, the drive should show up in that cat /proc command.

So where is the kernal so i can enable is :S
 
Old 02-12-2004, 10:45 PM   #11
busbarn
Member
 
Registered: Feb 2002
Location: Denver, CO US
Distribution: Arch
Posts: 453

Rep: Reputation: 30
There is plenty of information on this forum regarding compiling your kernel. Do a search and you will find everything you need!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
MDK 9.2 cannot mount Ext USB hard drive dr_skids Linux - Hardware 0 11-06-2005 12:56 PM
USB drive mount double mount issue pazzport Ubuntu 3 10-10-2005 09:28 PM
MDK 10.2: No USB at all (/proc/bus/usb/devices missing) shrodi Mandriva 5 07-01-2005 12:28 PM
MDK 10.x - Mount USB Pen OK, But no permission to write Xolo Linux - Software 2 05-20-2005 06:19 AM
mount usb module then mount usb hard drive guanyu Linux - Hardware 1 10-08-2003 12:50 PM


All times are GMT -5. The time now is 02:34 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration