LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-27-2012, 02:09 PM   #1
reidtc82
LQ Newbie
 
Registered: Feb 2012
Posts: 8

Rep: Reputation: Disabled
how do i make use of mem=#### when attempting to install fedora


I apologize if thos has been asked a million times already. It also seems like basic general linux knowledge but i dont know it so im asking.

Im currently trying my hand at setting up a webserver with a dell optiplex 740 using an amd athlon x2 64 2.5ghz processor and 2 gigs ddr2 667 ram. No addutional grfx carss just the built invideo stuff. I have been running into problems all weekend. First was actually getting a good iso. Then a reliable image burn. I think i have those two issues sorted. Im installing on a new hdd so this isnt a dual boot.

My problem is with a good iso and image burn to dvd i hang on install with a message stating not enough memory for specified image/kernel/version (i cant remember exactly but its a common problem i find in other threads). Then im given a boot: prompt.

So ive determined my issue at this point i think. From ehat im reading is that dell puts a memory hole early in ram and the install thinks it doesnt havr enough ram because it has no addresses mapped beyond the hole. At least thats my understanding.

The solition i read is to use mem=##### to modify or add to the grub file manually how much memory to use...

Thats my understanding thus far but i cant figure out the syntax and exact location to use mem=####. Do i type that in at the boot: ? If so in what syntax? Ive read that i should hit tab after the error then use the mem=####.

Could someone explain the process in detail and any sytax i may be missing and anything else i should know? When i simply type say mem=2048 at the boot: prompt. It tells me it cant recognize the kernel so i assume that isnt right. I may also not be entering e memory amount correctly.

Thats it as far as i can deduct.

Ive tried a few versions of fedora all x86 64 as i think thats the right one for my system.
 
Old 02-27-2012, 04:43 PM   #2
kbp
Senior Member
 
Registered: Aug 2009
Posts: 3,790

Rep: Reputation: 650Reputation: 650Reputation: 650Reputation: 650Reputation: 650Reputation: 650
That will actually be a kernel boot parameter, when you first boot you'll get the menu with installation options and from there you should be able to press [TAB] to edit options.
 
Old 02-27-2012, 04:51 PM   #3
reidtc82
LQ Newbie
 
Registered: Feb 2012
Posts: 8

Original Poster
Rep: Reputation: Disabled
Ah ok i will try that when i get home.
 
Old 02-27-2012, 05:53 PM   #4
johnsfine
LQ Guru
 
Registered: Dec 2007
Distribution: Centos
Posts: 5,286

Rep: Reputation: 1181Reputation: 1181Reputation: 1181Reputation: 1181Reputation: 1181Reputation: 1181Reputation: 1181Reputation: 1181Reputation: 1181
Edit: After writing the message below, I used google to find the issue, probably what the OP found:
https://bugzilla.redhat.com/show_bug.cgi?id=678820
That does make it sound like mem= is a correct work around.


Quote:
Originally Posted by reidtc82 View Post
From ehat im reading is that dell puts a memory hole early in ram and the install thinks it doesnt havr enough ram because it has no addresses mapped beyond the hole. At least thats my understanding.
Where did you read that?
That doesn't sound very plausible.
Even if it is correct, I'm pretty sure correct syntax for mem= still wouldn't help any.
Linux can use memory with big holes. But I don't know whether there is some restriction in loading the kernel across a hole. One one not normally expect a hole in ram after the first MB and before enough contiguous ram to load a kernel.

Quote:
Ive tried a few versions of fedora all x86 64 as i think thats the right one for my system.
Do you have any version of Linux that will boot up? Maybe 32 bit Linux is best for this.
With any Linux that boots up try the following command and post the results:
Code:
dmesg | grep e820
That should give you the BIOS memory map showing which ram the BIOS tells Linux is usable vs. reserved or missing.

Last edited by johnsfine; 02-27-2012 at 06:06 PM.
 
Old 02-27-2012, 08:41 PM   #5
reidtc82
LQ Newbie
 
Registered: Feb 2012
Posts: 8

Original Poster
Rep: Reputation: Disabled
I figured it out. Now ive got fedora installed and running.

Not sure where i read about the memory hole but i did have to use mem= to get it working. I just wasnt aware of when and how to de it. Pressed tab abd entered mem=1024M at the promt and it installed.

Thanks for the help if i fond where i read about the memory hole ill post it.

Edit: yeah thats exactly what I read through that link. comment 10.

Posted the results of the command you said to run.

Last edited by reidtc82; 02-27-2012 at 08:50 PM.
 
Old 02-27-2012, 08:46 PM   #6
reidtc82
LQ Newbie
 
Registered: Feb 2012
Posts: 8

Original Poster
Rep: Reputation: Disabled
[ 0.000000] BIOS-e820: 0000000000000000 - 000000000009f000 (usable)
[ 0.000000] BIOS-e820: 000000000009f000 - 00000000000a0000 (reserved)
[ 0.000000] BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
[ 0.000000] BIOS-e820: 0000000000100000 - 0000000001e00000 (usable)
[ 0.000000] BIOS-e820: 0000000001e00000 - 0000000001e80040 (reserved)
[ 0.000000] BIOS-e820: 0000000001e80040 - 000000007bed0000 (usable)
[ 0.000000] BIOS-e820: 000000007bed0000 - 000000007bed3000 (ACPI NVS)
[ 0.000000] BIOS-e820: 000000007bed3000 - 000000007bee0000 (ACPI data)
[ 0.000000] BIOS-e820: 000000007bee0000 - 000000007bf00000 (reserved)
[ 0.000000] BIOS-e820: 000000007c000000 - 0000000080000000 (reserved)
[ 0.000000] BIOS-e820: 00000000f0000000 - 00000000f4000000 (reserved)
[ 0.000000] BIOS-e820: 00000000fec00000 - 0000000100000000 (reserved)
[ 0.000000] e820 update range: 0000000000000000 - 0000000000010000 (usable) ==> (reserved)
[ 0.000000] e820 remove range: 00000000000a0000 - 0000000000100000 (usable)
[ 0.000000] Aperture pointing to e820 RAM. Ignoring.


Thats the result in the booted fedora I have installed
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Attempting to install Matlab r2008a on Fedora Goddard 64 bit TupacAmaru Linux - Software 6 08-23-2010 10:45 AM
Can't "make config" whilst attempting wifi card install on Debian Sarge. Keychain Linux - Hardware 3 09-19-2008 12:24 PM
Attempting to make Centos5 DVD or CD's for Install vwtech Linux - Distributions 2 01-24-2008 11:38 AM
Missing Dependancies when attempting to install totem and vlc on Fedora 6 system. walkingtheredpath Linux - Software 9 07-04-2007 11:33 PM
big problem with partition after attempting to install fedora russellc Fedora - Installation 5 07-06-2004 03:24 PM


All times are GMT -5. The time now is 10:08 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration