LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-11-2005, 03:37 PM   #16
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,066
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910

Well ... the next thing will be to bump up the debug-level in
cupsd.conf, restart cups, try to print, stop cups, copy the
logfile away, put debugging back to normal and restart
cups yet again, and then check what's in the log.


Cheers,
Tink
 
Old 07-11-2005, 05:29 PM   #17
M$ISBS
Member
 
Registered: Aug 2003
Posts: 834

Original Poster
Rep: Reputation: 30
I just did exactly what you posted to do and the newest log file has several lines in different locations throughout the the log file that say " Destination printer does not exist"
It also mentions to up the debug level to gain more information about the problem, I am doing that right now.
I just checked the newest log and I got a " sending error client-error-not-possible " Could this be a
permissions problem?

Thanks for the help, I realize you cannot continue forever helping me, If you can for a few more posts that would be great but if not I understand.

Last edited by M$ISBS; 07-11-2005 at 05:35 PM.
 
Old 07-12-2005, 12:57 AM   #18
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,066
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
And, what did the higher level of debug (I hope you
went up to debug2) tell you about the problems?


Cheers,
Tink
 
Old 07-12-2005, 03:11 PM   #19
M$ISBS
Member
 
Registered: Aug 2003
Posts: 834

Original Poster
Rep: Reputation: 30
Yes, I went up to debug2. It said " sending error client-error-not-possible " and " Destination Printer does not exist "
 
Old 07-12-2005, 03:32 PM   #20
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,066
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
Quote:
Originally posted by M$ISBS
Yes, I went up to debug2. It said " sending error client-error-not-possible " and " Destination Printer does not exist "
Can you copy & paste the relevant section, plus at least 30
lines from above and below it? debug2 is usually VERY verbose.


Cheers,
Tink
 
Old 07-12-2005, 04:47 PM   #21
M$ISBS
Member
 
Registered: Aug 2003
Posts: 834

Original Poster
Rep: Reputation: 30
I hope this is what you need, I just cut and pasted as much as I could from around the middle of /var/log/cups/error_log. The whole first half of the file was the same as the first 10 lines or so below so I did not include it.

D [12/Jul/2005:07:27:59 +0000] AcceptClient: 6 from localhost:631.
D [12/Jul/2005:07:27:59 +0000] ReadClient: 6 POST / HTTP/1.1
D [12/Jul/2005:07:27:59 +0000] ProcessIPPRequest: 6 status_code=1
D [12/Jul/2005:07:27:59 +0000] CloseClient: 6
I [12/Jul/2005:07:31:14 +0000] Scheduler shutting down normally.
D [12/Jul/2005:07:31:14 +0000] StopListening: closing all listen sockets.
D [12/Jul/2005:07:31:14 +0000] PauseListening: clearing input bits...
D [12/Jul/2005:07:32:18 +0000] AddLocation: added location 'CUPS_INTERNAL_BROWSE_ACL'
I [12/Jul/2005:07:32:18 +0000] Loaded configuration file "/etc/cups/cupsd.conf"
I [12/Jul/2005:07:32:18 +0000] Configured for up to 100 clients.
I [12/Jul/2005:07:32:18 +0000] Allowing up to 100 client connections per host.
I [12/Jul/2005:07:32:18 +0000] Full reload is required.
D [12/Jul/2005:07:32:18 +0000] LoadAllPrinters: Loading printer Samsung...
D [12/Jul/2005:07:32:19 +0000] LoadDevices: Added device "ipp"...
D [12/Jul/2005:07:32:19 +0000] LoadDevices: Added device "lpd"...
D [12/Jul/2005:07:32:19 +0000] LoadDevices: Added device "smb"...
D [12/Jul/2005:07:32:19 +0000] LoadDevices: Added device "usb:/dev/usb/lp0"...
D [12/Jul/2005:07:32:19 +0000] LoadDevices: Added device "usb:/dev/usb/lp1"...
D [12/Jul/2005:07:32:19 +0000] LoadDevices: Added device "usb:/dev/usb/lp2"...
D [12/Jul/2005:07:32:19 +0000] LoadDevices: Added device "usb:/dev/usb/lp3"...
D [12/Jul/2005:07:32:19 +0000] LoadDevices: Added device "usb:/dev/usb/lp4"...
D [12/Jul/2005:07:32:19 +0000] LoadDevices: Added device "usb:/dev/usb/lp5"...
D [12/Jul/2005:07:32:19 +0000] LoadDevices: Added device "usb:/dev/usb/lp6"...
D [12/Jul/2005:07:32:19 +0000] LoadDevices: Added device "usb:/dev/usb/lp7"...
D [12/Jul/2005:07:32:19 +0000] LoadDevices: Added device "usb:/dev/usb/lp8"...
D [12/Jul/2005:07:32:19 +0000] LoadDevices: Added device "usb:/dev/usb/lp9"...
D [12/Jul/2005:07:32:19 +0000] LoadDevices: Added device "usb:/dev/usb/lp10"...
D [12/Jul/2005:07:32:19 +0000] LoadDevices: Added device "usb:/dev/usb/lp11"...
D [12/Jul/2005:07:32:19 +0000] LoadDevices: Added device "usb:/dev/usb/lp12"...
D [12/Jul/2005:07:32:19 +0000] LoadDevices: Added device "usb:/dev/usb/lp13"...
D [12/Jul/2005:07:32:19 +0000] LoadDevices: Added device "usb:/dev/usb/lp14"...
D [12/Jul/2005:07:32:19 +0000] LoadDevices: Added device "usb:/dev/usb/lp15"...
D [12/Jul/2005:07:32:19 +0000] LoadDevices: Added device "http"...
D [12/Jul/2005:07:32:19 +0000] LoadDevices: Added device "scsi"...
D [12/Jul/2005:07:32:19 +0000] LoadDevices: Added device "socket"...
I [12/Jul/2005:07:32:19 +0000] LoadPPDs: Read "/etc/cups/ppds.dat", 525 PPDs...
I [12/Jul/2005:07:32:19 +0000] LoadPPDs: No new or changed PPDs...
D [12/Jul/2005:07:32:19 +0000] LoadAllJobs: Scanning /var/spool/cups...
D [12/Jul/2005:07:32:19 +0000] LoadAllJobs: Loading attributes for job 117...
D [12/Jul/2005:07:32:19 +0000] LoadAllJobs: Loading attributes for job 118...
D [12/Jul/2005:07:32:19 +0000] LoadAllJobs: Loading attributes for job 119...
D [12/Jul/2005:07:32:19 +0000] LoadAllJobs: Loading attributes for job 120...
D [12/Jul/2005:07:32:19 +0000] LoadAllJobs: Auto-typing document file d00120-001...
I [12/Jul/2005:07:32:19 +0000] Full reload complete.
D [12/Jul/2005:07:32:19 +0000] StartListening: NumListeners=1
D [12/Jul/2005:07:32:19 +0000] StartListening: address=00000000 port=631
D [12/Jul/2005:07:32:19 +0000] ResumeListening: setting input bits...
I [12/Jul/2005:13:14:35 +0000] Scheduler shutting down normally.
D [12/Jul/2005:13:14:35 +0000] StopListening: closing all listen sockets.
D [12/Jul/2005:13:14:35 +0000] PauseListening: clearing input bits...
D [12/Jul/2005:13:15:58 +0000] AddLocation: added location 'CUPS_INTERNAL_BROWSE_ACL'
I [12/Jul/2005:13:15:58 +0000] Loaded configuration file "/etc/cups/cupsd.conf"
I [12/Jul/2005:13:15:58 +0000] Configured for up to 100 clients.
I [12/Jul/2005:13:15:58 +0000] Allowing up to 100 client connections per host.
I [12/Jul/2005:13:15:58 +0000] Full reload is required.
D [12/Jul/2005:13:15:58 +0000] LoadAllPrinters: Loading printer Samsung...
D [12/Jul/2005:13:15:58 +0000] LoadDevices: Added device "ipp"...
D [12/Jul/2005:13:15:58 +0000] LoadDevices: Added device "lpd"...
D [12/Jul/2005:13:15:58 +0000] LoadDevices: Added device "smb"...
D [12/Jul/2005:13:15:58 +0000] LoadDevices: Added device "usb://Samsung/ML-1210"...
D [12/Jul/2005:13:15:58 +0000] LoadDevices: Added device "usb:/dev/usb/lp1"...
D [12/Jul/2005:13:15:58 +0000] LoadDevices: Added device "usb:/dev/usb/lp2"...
D [12/Jul/2005:13:15:58 +0000] LoadDevices: Added device "usb:/dev/usb/lp3"...
D [12/Jul/2005:13:15:58 +0000] LoadDevices: Added device "usb:/dev/usb/lp4"...
D [12/Jul/2005:13:15:58 +0000] LoadDevices: Added device "usb:/dev/usb/lp5"...
D [12/Jul/2005:13:15:58 +0000] LoadDevices: Added device "usb:/dev/usb/lp6"...
D [12/Jul/2005:13:15:58 +0000] LoadDevices: Added device "usb:/dev/usb/lp7"...
D [12/Jul/2005:13:15:58 +0000] LoadDevices: Added device "usb:/dev/usb/lp8"...
D [12/Jul/2005:13:15:58 +0000] LoadDevices: Added device "usb:/dev/usb/lp9"...
D [12/Jul/2005:13:15:58 +0000] LoadDevices: Added device "usb:/dev/usb/lp10"...
D [12/Jul/2005:13:15:58 +0000] LoadDevices: Added device "usb:/dev/usb/lp11"...
D [12/Jul/2005:13:15:58 +0000] LoadDevices: Added device "usb:/dev/usb/lp12"...
D [12/Jul/2005:13:15:58 +0000] LoadDevices: Added device "usb:/dev/usb/lp13"...
D [12/Jul/2005:13:15:58 +0000] LoadDevices: Added device "usb:/dev/usb/lp14"...
D [12/Jul/2005:13:15:58 +0000] LoadDevices: Added device "usb:/dev/usb/lp15"...
D [12/Jul/2005:13:15:58 +0000] LoadDevices: Added device "http"...
D [12/Jul/2005:13:15:58 +0000] LoadDevices: Added device "scsi"...
D [12/Jul/2005:13:15:58 +0000] LoadDevices: Added device "socket"...
I [12/Jul/2005:13:15:58 +0000] LoadPPDs: Read "/etc/cups/ppds.dat", 525 PPDs...
I [12/Jul/2005:13:15:58 +0000] LoadPPDs: No new or changed PPDs...
D [12/Jul/2005:13:15:58 +0000] LoadAllJobs: Scanning /var/spool/cups...
D [12/Jul/2005:13:15:58 +0000] LoadAllJobs: Loading attributes for job 117...
D [12/Jul/2005:13:15:58 +0000] LoadAllJobs: Loading attributes for job 118...
D [12/Jul/2005:13:15:58 +0000] LoadAllJobs: Loading attributes for job 119...
D [12/Jul/2005:13:15:58 +0000] LoadAllJobs: Loading attributes for job 120...
D [12/Jul/2005:13:15:58 +0000] LoadAllJobs: Auto-typing document file d00120-001...
I [12/Jul/2005:13:15:58 +0000] Full reload complete.
D [12/Jul/2005:13:15:58 +0000] StartListening: NumListeners=1
D [12/Jul/2005:13:15:58 +0000] StartListening: address=00000000 port=631
D [12/Jul/2005:13:15:58 +0000] ResumeListening: setting input bits...
I [12/Jul/2005:22:39:16 +0000] Scheduler shutting down normally.
D [12/Jul/2005:22:39:16 +0000] StopListening: closing all listen sockets.
D [12/Jul/2005:22:39:16 +0000] PauseListening: clearing input bits...
D [12/Jul/2005:22:40:54 +0000] AddLocation: added location 'CUPS_INTERNAL_BROWSE_ACL'
I [12/Jul/2005:22:40:54 +0000] Loaded configuration file "/etc/cups/cupsd.conf"
I [12/Jul/2005:22:40:54 +0000] Configured for up to 100 clients.
I [12/Jul/2005:22:40:54 +0000] Allowing up to 100 client connections per host.
I [12/Jul/2005:22:40:54 +0000] Full reload is required.
D [12/Jul/2005:22:40:54 +0000] LoadAllPrinters: Loading printer Samsung...
D [12/Jul/2005:22:40:54 +0000] LoadDevices: Added device "ipp"...
D [12/Jul/2005:22:40:54 +0000] LoadDevices: Added device "lpd"...
D [12/Jul/2005:22:40:54 +0000] LoadDevices: Added device "smb"...
D [12/Jul/2005:22:40:54 +0000] LoadDevices: Added device "usb://Samsung/ML-1210"...
D [12/Jul/2005:22:40:54 +0000] LoadDevices: Added device "usb:/dev/usb/lp1"...
D [12/Jul/2005:22:40:54 +0000] LoadDevices: Added device "usb:/dev/usb/lp2"...
D [12/Jul/2005:22:40:54 +0000] LoadDevices: Added device "usb:/dev/usb/lp3"...
D [12/Jul/2005:22:40:54 +0000] LoadDevices: Added device "usb:/dev/usb/lp4"...
D [12/Jul/2005:22:40:54 +0000] LoadDevices: Added device "usb:/dev/usb/lp5"...
D [12/Jul/2005:22:40:54 +0000] LoadDevices: Added device "usb:/dev/usb/lp6"...
D [12/Jul/2005:22:40:54 +0000] LoadDevices: Added device "usb:/dev/usb/lp7"...
D [12/Jul/2005:22:40:54 +0000] LoadDevices: Added device "usb:/dev/usb/lp8"...
D [12/Jul/2005:22:40:54 +0000] LoadDevices: Added device "usb:/dev/usb/lp9"...
D [12/Jul/2005:22:40:54 +0000] LoadDevices: Added device "usb:/dev/usb/lp10"...
D [12/Jul/2005:22:40:54 +0000] LoadDevices: Added device "usb:/dev/usb/lp11"...
D [12/Jul/2005:22:40:54 +0000] LoadDevices: Added device "usb:/dev/usb/lp12"...
D [12/Jul/2005:22:40:54 +0000] LoadDevices: Added device "usb:/dev/usb/lp13"...
D [12/Jul/2005:22:40:54 +0000] LoadDevices: Added device "usb:/dev/usb/lp14"...
D [12/Jul/2005:22:40:54 +0000] LoadDevices: Added device "usb:/dev/usb/lp15"...
D [12/Jul/2005:22:40:54 +0000] LoadDevices: Added device "http"...
D [12/Jul/2005:22:40:54 +0000] LoadDevices: Added device "scsi"...
D [12/Jul/2005:22:40:54 +0000] LoadDevices: Added device "socket"...
I [12/Jul/2005:22:40:54 +0000] LoadPPDs: Read "/etc/cups/ppds.dat", 525 PPDs...
I [12/Jul/2005:22:40:54 +0000] LoadPPDs: No new or changed PPDs...
D [12/Jul/2005:22:40:54 +0000] LoadAllJobs: Scanning /var/spool/cups...
D [12/Jul/2005:22:40:54 +0000] LoadAllJobs: Loading attributes for job 117...
D [12/Jul/2005:22:40:54 +0000] LoadAllJobs: Loading attributes for job 118...
D [12/Jul/2005:22:40:54 +0000] LoadAllJobs: Loading attributes for job 119...
D [12/Jul/2005:22:40:54 +0000] LoadAllJobs: Loading attributes for job 120...
D [12/Jul/2005:22:40:54 +0000] LoadAllJobs: Auto-typing document file d00120-001...
I [12/Jul/2005:22:40:54 +0000] Full reload complete.
D [12/Jul/2005:22:40:55 +0000] StartListening: NumListeners=1
D [12/Jul/2005:22:40:55 +0000] StartListening: address=00000000 port=631
D [12/Jul/2005:22:40:55 +0000] ResumeListening: setting input bits...
 
Old 07-13-2005, 04:30 AM   #22
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,066
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
I suggest we start all over.

stop CUPS
Up logging to debug2
remove the currents cups log
restart cups
make sure you're trying to access the printer once
(E.g. print test page from CUPS web-interface)
stop CUPS
mv log to safe place
down logging level
restart cups
post log-file

Why? Because the log you posted didn't even have
the original client-impossible-error ...


Cheers,
Tink
 
Old 07-19-2005, 03:04 PM   #23
M$ISBS
Member
 
Registered: Aug 2003
Posts: 834

Original Poster
Rep: Reputation: 30
I tried to get it working using the parallel port and that wouldnt even work.

Thanks for all the help Tinkster, I know you where really trying to get things going but I got to a point where I had to have it working quickly so i hooked it up to my windows machine. Maybe when I buy another Printer I will try again. Thanks again.

Last edited by M$ISBS; 07-19-2005 at 07:48 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How do I check that my USB ports are working? MoghNX01 Linux - Hardware 7 12-20-2005 01:26 AM
USB ports not working mifan Linux - Hardware 15 09-24-2005 10:11 PM
What USB modules do I need loaded to make printer work? M$ISBS Linux - Hardware 1 07-09-2005 09:27 PM
Extra 2 USB ports not working LavaDevil94 Linux - Hardware 4 09-12-2004 03:46 PM
USB ports not working civ247 Mandriva 0 07-08-2004 07:07 AM


All times are GMT -5. The time now is 09:01 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration