LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 03-09-2008, 10:40 AM   #1
trekfan7
LQ Newbie
 
Registered: Feb 2008
Distribution: Ubuntu ;Hardy
Posts: 14

Rep: Reputation: 0
Question How do I log in as root? Unpacking Gcaldaemon


Instructions given with gcaldaemon zip file.

Unpack the distribution ('GCALDaemon' directory)

under the '/usr/local/sbin' directory, as root.

cd /usr/local/sbin

unzip /downloads/gcaldaemon-linux-1.x.zip

chgrp -R groupname /usr/local/sbin/GCALDaemon

chmod -R g+w /usr/local/sbin/GCALDaemon

chmod 755 /usr/local/sbin/GCALDaemon/bin/*.sh

But I get back that I dont have permission to write to the sbin file.
I know I must do this as root but can someone please tell me how.

I tried adding sudo before the cd command and it said "cd command not found"
Synching evolution with an online calendar is crucial for me. Any help would be appreciated.
 
Old 03-09-2008, 10:56 AM   #2
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian Squeeze
Posts: 5,796

Rep: Reputation: 323Reputation: 323Reputation: 323Reputation: 323
Ubuntu has disabled root loogin, but there is a way around it. The prefered way in Ubuntu is to use sudo.

Open a console, then give the command 'cd /usr/local/sbin' (without quotes). You should be allowed to cd into /usr/local/sbin as normal user.

Move the file you downloaded to /usr/local/bin: sudo mv ~/downloads/gcaldaemon-linux-1.x.zip /usr/local/sbin (assuming the file is in your home directory in a sub-directory called downloads). You will need to use sudo in order to write to /usr/local/sbin, because normal user does not have permission.

Now, to unzip the file, sudo unzip gcaldaemon-linux-1.x.zip.

sudo chgrp -R groupname GCALDaemon (where groupname is the name of the group you are supposed to assign to the file)

sudo chmod -R g+w GCALDaemon

sudo chmod 755 GCALDaemon/bin/*.sh
 
Old 03-10-2008, 04:10 PM   #3
trekfan7
LQ Newbie
 
Registered: Feb 2008
Distribution: Ubuntu ;Hardy
Posts: 14

Original Poster
Rep: Reputation: 0
Unhappy Missing File??

Thanks so much for your response.

This is what I'm getting when I try to cd to usr/local/sbin

But I think the file does exist because I see it in the file manager.


amre@amre-laptop:~$ cd/usr/local/sbin
bash: cd/usr/local/sbin: No such file or directory

So it stands to reason that when I follow along and input the rest of the commands I get:

amre@amre-laptop:~$ sudo mv ~ /home/amre/Desktop/gcaldaemon-linux-1.0-beta16.zip /usr/local/sbin
mv: cannot stat `~/home/amre/Desktop/gcaldaemon-linux-1.0-beta16.zip': No such file or directory

Can you tell me what I'm doing wrong?
Thanks so much.....
 
Old 03-10-2008, 04:46 PM   #4
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
You need a space between "cd" and the directory you want to change to.

Edit: your mv command is wrong because "~" is used to mean your user's home directory (/home/amre in this case). So, you don't want to move from ~/home/amre/Desktop/filename, but rather /home/amre/Desktop/filename or ~/Desktop/filename.

Last edited by Nylex; 03-11-2008 at 02:53 AM.
 
Old 03-10-2008, 04:58 PM   #5
custangro
Senior Member
 
Registered: Nov 2006
Location: California
Distribution: Fedora , CentOS , Solaris 10, RHEL
Posts: 1,935
Blog Entries: 1

Rep: Reputation: 188Reputation: 188
FYI

You can also sudo to root...

Code:
sudo su -
 
Old 03-10-2008, 09:28 PM   #6
wabbalee
Member
 
Registered: Oct 2006
Location: brisbane - australia
Distribution: mepis, ubuntu, zenwalk
Posts: 334

Rep: Reputation: 38
you can enable root access in gui in ubuntu the following way:

go to SYSTEM->ADMINISTRATION->USERS AND GROUPS and on user "ROOT" click properties and set a password in the 'account' tab, then in the 'user privileges' tab place all the ticks and 'ok' your way out.

then go to SYSTEM->ADMINISTRATION->LOGIN WINDOW and in the 'security' tab place a tick in 'allow local system administrator login'

you're done! now you can login as root and start making and breaking your system from X!

not save and secure but oooooooo so handy!

enjoy!
 
Old 03-10-2008, 10:16 PM   #7
felixc
Member
 
Registered: Jul 2005
Location: Canada
Distribution: Ubuntu, Debian
Posts: 94

Rep: Reputation: 15
A much better approach is to just create an interactive sudo session, by running "sudo -i"

This will put you in a root shell, and you won't have to run sudo before every command. Just remember to run "exit" when you're done, so you don't accidentally keep doing stuff as root.

As others have pointed out, a space is required between commands and their arguments.
 
Old 03-11-2008, 07:28 PM   #8
trekfan7
LQ Newbie
 
Registered: Feb 2008
Distribution: Ubuntu ;Hardy
Posts: 14

Original Poster
Rep: Reputation: 0
Still having unzip issue

Quote:
Originally Posted by bigrigdriver View Post

Open a console, then give the command 'cd /usr/local/sbin' (without quotes). You should be allowed to cd into /usr/local/sbin as normal user.

Move the file you downloaded to /usr/local/bin: sudo mv ~/downloads/gcaldaemon-linux-1.x.zip /usr/local/sbin (assuming the file is in your home directory in a sub-directory called downloads). You will need to use sudo in order to write to /usr/local/sbin, because normal user does not have permission.

Now, to unzip the file, sudo unzip gcaldaemon-linux-1.x.zip.

sudo chgrp -R groupname GCALDaemon (where groupname is the name of the group you are supposed to assign to the file)

sudo chmod -R g+w GCALDaemon

sudo chmod 755 GCALDaemon/bin/*.sh
I finally got into the usr/local/sbin file. When I attempt to move Gcaldaemon there I get this response. What am I doing wrong now??

amre@amre-laptop:/usr/local/sbin$ sudo mv ~ /home/amre/Desktop/gcaldaemon-linux-1.0-beta16.zip usr/local/sbin
mv: target `usr/local/sbin' is not a directory

Thanks to everyone who is guiding me through this.

Another question I have is about "groupname" is this a name I choose or find somewhere.......
 
Old 03-11-2008, 07:50 PM   #9
felixc
Member
 
Registered: Jul 2005
Location: Canada
Distribution: Ubuntu, Debian
Posts: 94

Rep: Reputation: 15
The error is arising out of how you are trying to specify the directory:

usr/local/sbin would mean a directory called usr, existing in whatever directory you're currently in.

/usr/local/sbin, on the other hand, means a directory called usr. existing under the root (/) filesystem.
 
Old 03-11-2008, 08:37 PM   #10
chrism01
Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.5, Centos 5.10
Posts: 16,311

Rep: Reputation: 2040Reputation: 2040Reputation: 2040Reputation: 2040Reputation: 2040Reputation: 2040Reputation: 2040Reputation: 2040Reputation: 2040Reputation: 2040Reputation: 2040
I don't think you want to mv your home dir (~) as well as that file ?

mv /home/amre/Desktop/gcaldaemon-linux-1.0-beta16.zip /usr/local/sbin
 
Old 03-13-2008, 04:01 PM   #11
trekfan7
LQ Newbie
 
Registered: Feb 2008
Distribution: Ubuntu ;Hardy
Posts: 14

Original Poster
Rep: Reputation: 0
Smile Thankyou all so much for your help! GCALDaemon is installed!

I have the program installed now and have followed the instructions in the documents file. Haven't gotten it to sync. yet, but I'm working on it. Is there a way to get a sync launcher on the desktop so I don't need to open the terminal to get it to sync on demand?

Thanks
 
Old 01-01-2009, 06:05 PM   #12
fritzy
LQ Newbie
 
Registered: Jan 2009
Posts: 1

Rep: Reputation: 0
How do I know the usergroup?

I keep receiving the following error when I enter 'sudo chgrp -R groupname GCALDaemon'

chgrp: invalid group: `groupname'

How do I know what the groupname should be?

Thanks!

Jason
 
Old 01-06-2009, 12:29 PM   #13
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
Have a look at the installation instructions: http://gcaldaemon.sourceforge.net/usage11.html
 
  


Reply

Tags
evolution, sync


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Attempting to install Gcaldaemon trekfan7 Linux - Newbie 0 03-05-2008 08:24 PM
GCALDaemon Help zoso375 Linux - Software 1 11-05-2007 03:52 AM
NFS Root setup - can't log in as root after CHMOD ? gallwapa Linux - General 1 04-02-2007 05:31 AM
LXer: Syncing magic with GCALDaemon LXer Syndicated Linux News 0 03-05-2007 05:16 AM
Log on as Root, or switch to Root, in MDK 9.1 - KDE 3.1.0 snorky Mandriva 3 09-01-2003 01:07 PM


All times are GMT -5. The time now is 11:38 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration