LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-20-2004, 11:26 AM   #1
joepesci
LQ Newbie
 
Registered: Jul 2004
Posts: 10

Rep: Reputation: 0
how do i know what drives are available for mounting


i am using red hat 9 with gnome interface
 
Old 07-20-2004, 11:44 AM   #2
alar
Member
 
Registered: Sep 2003
Location: Canada
Distribution: CentOS 5.5, Ubuntu 10.04, Linux Mint 11 gnome 64 bit
Posts: 336

Rep: Reputation: 36
command line from the terminal

more /etc/fstab
 
Old 07-20-2004, 12:09 PM   #3
joepesci
LQ Newbie
 
Registered: Jul 2004
Posts: 10

Original Poster
Rep: Reputation: 0
this is what i get
LABEL=/ / ext3 defaults 1 1
none /dev/pts devpts gid=5,mode=620 0 0
none /proc proc defaults 0 0
none /dev/shm tmpfs defaults 0 0
/dev/cdrom /mnt/cdrom udf,iso9660 noauto,owner,kudzu,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner,kudzu 0 0

how come i dont see my other drives i have 2 scsii drives and 3 ide. where r they??
 
Old 07-20-2004, 12:14 PM   #4
AnanthaP
Member
 
Registered: Jul 2004
Location: Chennai, India
Distribution: UBUNTU 5.10 since Jul-18,2006 on Intel 820 DC
Posts: 813

Rep: Reputation: 195Reputation: 195
Using a disk partitioning utility will tell you the drives available. This has to be matched against the entries in /etcfstab.

Not sure how to automate the process.

HTH

End
 
Old 07-20-2004, 12:16 PM   #5
tuxrules
Senior Member
 
Registered: Jun 2004
Location: Chicago
Distribution: Slackware64 -current
Posts: 1,144

Rep: Reputation: 56
As far as i remember, those drives you are talking about are not added to fstab directly. You need to either mount them manually or edit /etc/fstab file to mount them automatically at boot. First, you need to make directories for each drive (partition) you want to mount and then edit fstab.
 
Old 07-20-2004, 12:25 PM   #6
tuxrules
Senior Member
 
Registered: Jun 2004
Location: Chicago
Distribution: Slackware64 -current
Posts: 1,144

Rep: Reputation: 56
Here's what I have.

/dev/hda /mnt/winxp ntfs noauto,ro,users,umask=000 0 0

to mount my ntfs drive. noauto option doesnt mount drive at boot. user option lets users mount partition. After I add this to fstab, right click on gnome-desktop and I'll see disks>winxp.

For ntfs you need to patch your kernel to read NTFS partition. Look here for more info on
NTFS in linux

there's only read-only support for NTFS in linux.

for fat32...support is inbuilt so you need not worry.

Hope this helps
 
Old 07-20-2004, 01:00 PM   #7
mike33
Member
 
Registered: Jul 2004
Location: Houston Tx
Distribution: kubuntu, Debian, Suse 10.2
Posts: 31

Rep: Reputation: 15
You can also see what devices were detected by looking at the file called dmesg (usually in the /var/log directory). Type
dmesg|less
at a console, or
dmesg|grep hd
and see all lines containing the string 'hd'. Here is a part of mine:
hda: WDC WD400BB-00AUA1, ATA DISK drive
hdb: ST340016A, ATA DISK drive
hdc: _NEC DVD_RW ND-2500A, ATAPI CD/DVD-ROM drive
ide2: BM-DMA at 0xac00-0xac07, BIOS settings: hde:pio, hdf:pio
ide3: BM-DMA at 0xac08-0xac0f, BIOS settings: hdg:pio, hdh:pio
hde: Maxtor 6Y080L0, ATA DISK drive
hdg: SAMSUNG DVD-ROM SD-616T, ATAPI CD/DVD-ROM drive
hdh: PHILIPS CDRW2412A, ATAPI CD/DVD-ROM drive
hda: max request size: 128KiB
hda: 78165360 sectors (40020 MB) w/2048KiB Cache, CHS=65535/16/63, UDMA(100)
hdb: max request size: 128KiB
hdb: 78165360 sectors (40020 MB) w/2048KiB Cache, CHS=65535/16/63, UDMA(100)
hde: max request size: 128KiB
hde: 160086528 sectors (81964 MB) w/2048KiB Cache, CHS=65535/16/63, UDMA(133)
Reiserfs journal params: device hda7, size 8192, journal first block 18 ...
Or try
dmesg|grep ide
As you can see from above my 80G hard drive is named hde, and I have the following lines in my /etc/fstab file:
/dev/hde5 /mnt/hde5 ext3 defaults,users 1 1
/dev/hde7 /mnt/hde7 ext3 defaults,users 1 1
where I created the directories /mnt/hde5 /mnt/hde7 beforehand.
This is just one way; as the other posters said, you may also use some utility to find out how your drives are mapped.
 
Old 07-20-2004, 01:08 PM   #8
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 234Reputation: 234Reputation: 234
/sbin/fdisk -l

This will show all partitions on all drives.
 
Old 07-20-2004, 01:23 PM   #9
mike33
Member
 
Registered: Jul 2004
Location: Houston Tx
Distribution: kubuntu, Debian, Suse 10.2
Posts: 31

Rep: Reputation: 15
I didn't know that; that is a much neater, trickykid.
 
Old 07-20-2004, 01:29 PM   #10
joepesci
LQ Newbie
 
Registered: Jul 2004
Posts: 10

Original Poster
Rep: Reputation: 0
it is very complicated

ok i am about to give up!!!! well i will try abit more.

ok now i know that i have
1. a drive called hdc1 and hdc2 that are fat32 i see this in the hardware browser 'i use them in windows to store documents'
2. created a directory named windows and a directory named drive1 in the /mnt directory.
3. opened from system tools a terminal and loged on as root with the su command.
4. then i typed the command mount -t vfat /dev/hdc1/mnt/windows
5. the i go to the windows directory i created int the /mnt and i see no files.

please help help help
 
Old 07-20-2004, 01:36 PM   #11
tuxrules
Senior Member
 
Registered: Jun 2004
Location: Chicago
Distribution: Slackware64 -current
Posts: 1,144

Rep: Reputation: 56
do you mean you created something like this
/mnt/windows/drive1 to mount your hdc1. If that is the case your syntax is bad.

here's the right syntax

mount -t vfat /dev/hdc1 /mnt/windows/drive1

you didnt provide space between /dev/hdc1 and /mnt/windows. Try this...
 
Old 07-20-2004, 01:41 PM   #12
joepesci
LQ Newbie
 
Registered: Jul 2004
Posts: 10

Original Poster
Rep: Reputation: 0
haleluya thanks works good thanks again
 
Old 07-20-2004, 02:07 PM   #13
joepesci
LQ Newbie
 
Registered: Jul 2004
Posts: 10

Original Poster
Rep: Reputation: 0
very good now how do i do that i don't allways have to type the mount command. is there a startup file like in windows ???
 
Old 07-20-2004, 02:41 PM   #14
tuxrules
Senior Member
 
Registered: Jun 2004
Location: Chicago
Distribution: Slackware64 -current
Posts: 1,144

Rep: Reputation: 56
refer to my 2nd post in this thread for options

try this in (as su)
Code:
# gedit /etc/fstab
add the following line at the end
(you can either put space or a tab)

Code:
/dev/hdc1 /mnt/windows/drive1 vfat noauto,user,rw,umask=000 0 0
then logout and login again as user...then you can right click on gnome there you'll see disks>drive1

you'll be able to browse the contents of your fat32 partition.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mounting Drives anjum Linux - Software 3 07-29-2005 01:12 AM
Help in Mounting my cd drives coderasm Linux - Newbie 3 12-06-2004 06:52 AM
mounting my drives mark alan Fedora 7 12-05-2004 09:52 PM
Mounting Drives BlandoCal Linux - Hardware 49 09-14-2003 07:03 PM
Mounting mounting extended partition and its Logical drives desbyleo Linux - Newbie 10 02-18-2002 04:13 PM


All times are GMT -5. The time now is 05:12 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration