LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-13-2010, 11:40 PM   #1
BennyLava
LQ Newbie
 
Registered: Aug 2010
Posts: 8

Rep: Reputation: 0
How do I install these newer Nvidia drivers?


I am trying to install some new Nvidia drivers on my Ubuntu 10.04, because the driver I have now, may be causing some kind of problem. I am running Dungeons and Dragons Online in Wine, and it seems to run quite well on all max settings. But, when I exit the game, my screen turns completely red and I can barely read anything. Its this way for anything that I manage to open. The system must be restarted for me to be able to read anything, and for there to be any other color besides red.

So, I went into the game and asked in the general chat for a linux user. Found one, and he said that I might want to try updating my drivers. The "Nvidia X Server Settings" (under System>Administration) in ubuntu, says that the current driver is version 195.36.24. There is an outdated one visible in the "Hardware Drivers", version "173". The newer one (that it says is actually in use) is listed there too, but its version isn't mentioned.

Anyway, I went to the official Nvidia website, and it seems that my drivers are far out of date. The website has version "256.44" available for download. That seems like a giant gap between that, and my drivers.

http://www.nvidia.com/object/linux-d...44-driver.html

If you look at the middle of that page, you can see "Additional Information" tab on the left. It has the exact installation instructions for the new drivers there. Here is the output of my terminal:

justin@justin-desktop:~$ sudo sh ./NVIDIA-Linux-x86-256.44-pkg2.run
[sudo] password for justin:
sh: Can't open ./NVIDIA-Linux-x86-256.44-pkg2.run
justin@justin-desktop:~$ cd Downloads
justin@justin-desktop:~/Downloads$ sudo sh ./NVIDIA-Linux-x86-256.44-pkg2.run
sh: Can't open ./NVIDIA-Linux-x86-256.44-pkg2.run
justin@justin-desktop:~/Downloads$


What did I do wrong? How do I install it? I thought I followed the instructions pretty closely..
 
Old 08-14-2010, 12:08 AM   #2
craigevil
Senior Member
 
Registered: Apr 2005
Location: OZ
Distribution: Debian Sid
Posts: 4,734
Blog Entries: 12

Rep: Reputation: 461Reputation: 461Reputation: 461Reputation: 461Reputation: 461
BinaryDriverHowto/Nvidia - Community Ubuntu Documentation : https://help.ubuntu.com/community/Bi...erHowto/Nvidia
 
Old 08-14-2010, 06:58 PM   #3
BennyLava
LQ Newbie
 
Registered: Aug 2010
Posts: 8

Original Poster
Rep: Reputation: 0
Ok thank you. From what that guide says, from what I can tell I did everything right and I still got that terminal output in my first post. Since that link that I posted didn't work, here are the installation instructions from nvidia for the driver:

"Note that many Linux distributions provide their own packages of the NVIDIA Linux Graphics Driver in the distribution's native package management format. This may interact better with the rest of your distribution's framework, and you may want to use this rather than NVIDIA's official package.

Also note that SuSE users should read the SuSE NVIDIA Installer HOWTO before downloading the driver.

Installation instructions: Once you have downloaded the driver, change to the directory containing the driver package and install the driver by running, as root, sh ./NVIDIA-Linux-x86-256.44-pkg2.run

One of the last installation steps will offer to update your X configuration file. Either accept that offer, edit your X configuration file manually so that the NVIDIA X driver will be used, or run nvidia-xconfig."
 
Old 08-14-2010, 07:16 PM   #4
BennyLava
LQ Newbie
 
Registered: Aug 2010
Posts: 8

Original Poster
Rep: Reputation: 0
Well I tried again, and I think that I actually did it right this time. Only one problem though. How do I remove X server? And what the heck is X server?
Attached Thumbnails
Click image for larger version

Name:	wtfXserver.jpeg
Views:	14
Size:	122.4 KB
ID:	4315  

Last edited by BennyLava; 08-17-2010 at 06:40 AM.
 
Old 08-17-2010, 06:38 AM   #5
BennyLava
LQ Newbie
 
Registered: Aug 2010
Posts: 8

Original Poster
Rep: Reputation: 0
Starting to think this website doesn't have near as many members as it claims...
 
Old 08-17-2010, 06:48 AM   #6
JoshyJ
Member
 
Registered: Nov 2003
Location: Sydney , Australia
Distribution: Fedora
Posts: 49

Rep: Reputation: 1
X server is your Graphical User Interface. What you need to do is change run levels. Depending on your version you would have to use upstart or init, to change to a run level which does not use X server.

I don't use Ubuntu so don't shoot me if I'm wrong.
 
Old 08-17-2010, 06:57 AM   #7
GrapefruiTgirl
LQ Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551
You do not want to remove the X server! What the message is telling you is that you should exit the X server before running the nvidia driver installer. Usually this is done by logging out of your desktop session and going to init 3 or whatever init runlevel you need to go to to be in multi-user mode, but not running X.

X is the video server which provides the graphical desktop you see. All video, except for console video in virtual terminals, is provided by X.

I've not followed the link provided by craigevil, but: usually with Ubuntu you install the nVidia driver using your package manager. If you don't want to do that (maybe to get a version of the driver that is newer than what your package manager offers) then you have to run the nVidia installer from the virtual terminal, with X stopped. On Ubuntu, to stop X, I believe you go to a virtual terminal, then issue a command(s) something like:
Code:
/etc/init.d/rc.gdm stop
killall X
Then run the installer.

The above command may need slight adjustment - I don't use Ubuntu so I don't remember this off-hand; but this command (and other discussion about installing the driver into Ubuntu) is floating around here in many places, so search around a little if the above doesn't work.

As for the number of members LQ has - we have a lot! But, at any given time, one cannot expect 100's or 1000's of members to be logged in at all times. It's summertime in much of the world, for one thing, so some people are on vacation. Some are at work. Half the world is asleep at any moment. And, some people only log in once in a blue moon, when they need help. Patience is a virtue; and, if still awaiting a reply to an issue, providing any further info that you can add to your thread as an update is a good way to get renewed attention.

Best of luck!

EDIT: P.S. - while the numbering system of the nvidia driver makes it look like there's a huge gap between driver versions, I assure you there is not. The driver version went from 195.xx.xx right up to 256.33 one day. There were no versions in between.

Last edited by GrapefruiTgirl; 08-17-2010 at 06:59 AM. Reason: added P.S.
 
Old 08-17-2010, 07:03 AM   #8
bbb125
LQ Newbie
 
Registered: Aug 2010
Posts: 17

Rep: Reputation: 1
Quote:
Originally Posted by BennyLava View Post
Well I tried again, and I think that I actually did it right this time. Only one problem though. How do I remove X server? And what the heck is X server?
Hi,

I'm a bit of a Linux newbie myself, but according to my book, X is described as a graphic utility which provides underlying graphic operations. You don't want to get rid of this. It is used by GNOME and KDE. Basically, it is called an X server because applications act as clients which make requests to the X server when they need to perform display operations. So an application can send a request to do things like create a window without knowing the specific details of how to do this.

For an explanation of runlevels, go here: http://www.linux.com/news/enterprise...nd-rcd-scripts

To change the runlevel, you are supposed to use the telinit command: http://linux.about.com/library/cmd/blcmdl8_telinit.htm

Please correct me if I am giving incorrect information.

Last edited by bbb125; 08-17-2010 at 07:09 AM.
 
Old 08-17-2010, 03:19 PM   #9
MrCode
Member
 
Registered: Aug 2009
Location: Oregon, USA
Distribution: Arch
Posts: 864
Blog Entries: 31

Rep: Reputation: 148Reputation: 148
@GrapefruiTgirl

I believe:

Code:
/etc/init.d/gdm stop
...should be sufficient.

Yeah, Ubuntu's NVIDIA drivers in the repositories are usually a little out-of-date in my experience. Here's what I did on my Ubuntu 9.04 system:
  • Downloaded latest .run installer from NVIDIA website
  • Opened an X terminal and entered sudo /etc/init.d/gdm stop
  • Once in a text-mode VT, cd'd to the dir where the .run installer was
  • sudo chmod +x NVIDIA_<whatever>.run
  • sudo sh NVIDIA_<whatever>.run
 
Old 08-17-2010, 04:18 PM   #10
tommcd
Senior Member
 
Registered: Jun 2006
Location: Philadelphia PA USA
Distribution: Lubuntu, Slackware
Posts: 2,230

Rep: Reputation: 291Reputation: 291Reputation: 291
Quote:
Originally Posted by BennyLava View Post
I am trying to install some new Nvidia drivers on my Ubuntu 10.04, because the driver I have now, may be causing some kind of problem. I am running Dungeons and Dragons Online in Wine ...
First off, running Windows games using Wine is problematic at best. I doubt that using a newer nvidia driver would make a Windows game run better from Wine.
Quote:
Originally Posted by BennyLava View Post
The "Nvidia X Server Settings" (under System>Administration) in ubuntu, says that the current driver is version 195.36.24.
The 195 driver is the most recent nvidia driver available in the Ubuntu repos.
If you really want to install the driver from nvidia.com you will first have to remove the driver you installed from the Ubuntu repos. Having the nvidia driver from the Ubuntu repos and the driver from nvidia.com both installed on your system will cause problems.
See this for installing the driver from nvidia.com on Ubuntu 10.04:
http://www.ubuntugeek.com/howto-inst...ucid-lynx.html
In previous versions of Ubuntu you had to first install the build-essential package and the linux-headers for the kernel you were running before installing the nvidia driver from nvidia.com. Apparently this is no longer necessary.
Also, the command to stop X in Ubuntu 10.04 is:
Code:
sudo service gdm stop
Just run that from a virtual terminal (ctrl + alt + F2) to stop X
And to restart X:
Code:
sudo service gdm start
The driver from nvidia.com may need to be reinstalled when there are kernel updates for Ubuntu.

Last edited by tommcd; 08-17-2010 at 04:33 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Need newer a,v,w drivers eag2000 Linux - Hardware 1 02-12-2007 03:28 PM
cant install nvidia drivers... Virtuality Linux - Newbie 4 01-24-2007 01:19 AM
Can't install nvidia drivers.. porrblomman Linux - Newbie 1 12-20-2004 12:59 PM
can't install nvidia drivers s2k Linux - Software 1 08-12-2003 09:34 AM
Nvidia Drivers and newer kernals Evilone Linux - Software 1 03-31-2003 07:53 AM


All times are GMT -5. The time now is 06:22 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration