LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-22-2004, 03:20 PM   #1
twitch88
LQ Newbie
 
Registered: Jul 2004
Posts: 2

Rep: Reputation: 0
How do I install programs??


I just installed Xandros 2.0 Linux which is a Debian 4.0 (sarge) distribution with version of KDE 3.1.4.
I downloaded and installed Return to Castle Wolfenstien and it works. But i can't figure out how to install the Nvidia drivers, i can't shut down the x server. I am also having trouble installing the new kopete 8.4. If anyone could give me some pointers on how to get up and running I would be most appreciative.
 
Old 07-22-2004, 03:40 PM   #2
darkleaf
Senior Member
 
Registered: Jun 2004
Location: the Netherlands
Distribution: debian SID
Posts: 2,170

Rep: Reputation: 45
Re: How do I install programs??

Quote:
Originally posted by twitch88
I just installed Xandros 2.0 Linux which is a Debian 4.0 (sarge) distribution with version of KDE 3.1.4.
I downloaded and installed Return to Castle Wolfenstien and it works. But i can't figure out how to install the Nvidia drivers, i can't shut down the x server. I am also having trouble installing the new kopete 8.4. If anyone could give me some pointers on how to get up and running I would be most appreciative.
You can shutdown the x-server with CTRL-ALT-BACKSPACE or you can logout and in the login screen there's a list box in which you can choose to login on the command line.

If you have the NVIdia drivers from their site you go into the command line just open Konsole and you're there. Then do su if you aren't on your root account yet. cd into the folder you downloaded the NVidia drivers in and do

Code:
./"name of the driver without quotation marks"
edit to get kopete upgraded:

go into the commandline as root and use apt:

Code:
apt-get install kopete
that'll download the latest version

Last edited by darkleaf; 07-22-2004 at 03:41 PM.
 
Old 07-22-2004, 04:22 PM   #3
twitch88
LQ Newbie
 
Registered: Jul 2004
Posts: 2

Original Poster
Rep: Reputation: 0
I did ctrl+alt+backspace to shut down the xserver, and when i ran the ./"driver name" i got this message.

bash: ./NVIDIA-pkg1.run: permission denied

I am logged in as root, not sure if that effects it or not.

Has for the Kopete problem, I ran the code that you suggested, it said:

already have newest version
you might want to run 'apt-get -f install' to correct these:
the following packages have unmet dependincies:
ymessenger: Depends: libsss0.9.6 but it is not installable.

so i ran what it said and it uninstalled ymessenger from kopete or so it said.
 
Old 07-22-2004, 04:53 PM   #4
darkleaf
Senior Member
 
Registered: Jun 2004
Location: the Netherlands
Distribution: debian SID
Posts: 2,170

Rep: Reputation: 45
Can you run the driver if you do the following as root:

Code:
chmod +x NVIDIA-pkg1.run
It allows the file to execute. If it doesn't work what does

Code:
ls -l NVIDIA-pkg1.run
give?

Your kopete installation was already at the newest release so you didn't have to install a new version. I don't use kopete myself, so did it say it uninstalled ymessenger from kopete or just that it uninstalled ymessenger. If you want ymessenger back you need to get libsss0.9.6 installed. I'm not sure how or where to get it though. My apt can't find that package either :S.
 
Old 07-22-2004, 05:02 PM   #5
Komakino
Senior Member
 
Registered: Feb 2004
Location: Somerset, England
Distribution: Slackware 10.2, Slackware 10.0, Ubuntu 9.10
Posts: 1,938

Rep: Reputation: 55
Once you have the nvidia drivers installed, edit your /etc/X11/xorg.conf or /etc/X11/XF86Config file (you'll only have one of them) and find the bit that says:
Code:
Section "Device"
and change the line containing "Driver" so that it says:
Code:
Driver "nvidia"
Then save and reboot. You'll need to be root for the editting, by the way.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
can't install g++ so I can't compile and install any programs musicmaniac414 Linux - Software 12 02-06-2008 10:31 PM
How to install programs ??????? antisocialiting Linux - Newbie 6 08-15-2005 03:03 AM
How do I install programs? Le Beastie Linux - Newbie 3 03-23-2005 04:37 PM
Programs Won't Install dumbsheep Linux - Newbie 9 01-11-2005 01:39 PM
Can't install programs tagbre Linux - Newbie 5 12-30-2003 07:28 AM


All times are GMT -5. The time now is 03:49 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration