LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-21-2012, 02:04 AM   #1
volt220
LQ Newbie
 
Registered: Jan 2011
Posts: 5

Rep: Reputation: 2
How do I install Nvidia latest driver on Ubuntu 10.10?


Think I have tried every suggestion out there, I'm totally lost now!
Any one who knows how to install the latest Nvidia driver on Ubuntu 10.10?
Below you find the step by step.
The problem are always that the PC doesn't start to graphical mode.
Too recover I have to remove /etc/X11/xorg.conf that's created by the
installation. (xorg.conf doesn't exists from the beginning).

Neetbook Asus U31S
CPU i3
GPU Nvidia GT520M

Step by step:
1. Install Ubuntu 10.10 (64bit)
http://releases.ubuntu.com/10.10/ubu...ktop-amd64.iso

2. When the installation completed, install all updates.
Kernel 2.6.35-31-generic (uname -r)

3. Open synaptec and uninstall all Nvidia stuff (remove complete)

4. Download the latest Nvidia driver (GT520M), currently 285.05.09
http://www.nvidia.com/content/Driver...s&type=GeForce

5. chmod +x NVIDIA-Linux-x86_64-285.05.09.run

6. Install compiling tool
sudo apt-get install linux-headers-$(uname -r) build-essential

7. Edit grub so we boot without x-server
edit /etc/default/grub
change this line
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
to
GRUB_CMDLINE_LINUX_DEFAULT="text"

8. Update grub
sudo update-grub

9. Reboot computer

10. Install driver
sudo ./NVIDIA-Linux-x86_64-190.42-pkg2.run
(also 32bit openGL compatibility)

11. Restore grub
Change back to GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
Update grub
sudo update-grub

12. Reboot computer

13. It fails here...
Only boots to a terminal
It doesn't boot to desktop until I remove /etc/X11/xorg.conf

Any ideas?
 
Old 01-21-2012, 06:36 AM   #2
Satyaveer Arya
Senior Member
 
Registered: May 2010
Location: Palm Island
Distribution: RHEL, CentOS, Debian, Oracle Solaris 10
Posts: 1,415

Rep: Reputation: 305Reputation: 305Reputation: 305Reputation: 305
I think you have to install current modalliases and nvidia_settings also along with the driver. And try creating new xorg.conf file and place the file in it's original path...
 
Old 02-05-2012, 02:38 AM   #3
volt220
LQ Newbie
 
Registered: Jan 2011
Posts: 5

Original Poster
Rep: Reputation: 2
Finally I understood what I really was looking for... OPTIMUS!

The main reason why I needed the a latest nvidia driver was to extend battery time.
On my Asus U31S I was promised 10h and ubuntus battery indicator told me 5.5h, almost the half!

Basically I installed bumblebee and the latest nvidia driver and now the battery indicator tells me 10h
(it was really close I switched to windows) Not very scientic values but at least I don't have to charge the computer 2 times a day.

For fun you can check the battery, before and after
watch grep rate /proc/acpi/battery/BAT0/state
My new rate after: 7546 mW
Before I had a rate approx 14000 mW

Here is the step by step, some steps my not be neede.d I just made some guessing as the guide didn't fit exactly.
The original guide is found here: http://www.ivegotavirus.com/blog/201...11-10-oneiric/
(for ubuntu 11.01 but works for 10.10 as well):

1. You need to install the latest graphics drivers:
sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get upgrade

2. Enable active-state power management by adding pcie_aspm=force to the grub command:
Open the grub config file
sudo gedit /etc/default/grub

Find this line
GRUB_CMDLINE_LINUX_DEFAULT=”quiet splash"

Insert pcie_aspm=force inside the quotes so it looks like this
GRUB_CMDLINE_LINUX_DEFAULT=”quiet splash pcie_aspm=force”

Update grub to make the changes
sudo update-grub

3. Install and configure bumblebee:

sudo add-apt-repository ppa:bumblebee/stable
sudo apt-get update
sudo apt-get install bumblebee
sudo apt-get install acpi-call-tools

After installing bumblebee, you will have to add yourself to the bumblebee user group (change USERNAME to your accounts user name),
sudo usermod -a -G bumblebee YOURUSERNAME

Open your bumblebee.conf
sudo gedit /etc/bumblebee/bumblebee.conf
Find these two lines and make sure they =Y
STOP_SERVICE_ON_EXIT=Y
ENABLE_POWER_MANAGEMENT=Y
** [Volt] Here I couldn't find the above properties so I added them in section [bumblebeed] **

Open your xorg.conf.nvidia
sudo gedit /etc/bumblebee/xorg.conf.nvidia

Make sure it looks like this:

Section "ServerLayout
Identifier "Layout0" **YOUR'S MAYBE DIFFERENT DO NOT CHANGE**
Option "AutoAddDevices" "false"
EndSection

Section "Files"
ModulePath "/usr/lib/nvidia-current/xorg,/usr/lib/xorg/modules"
EndSection

Section "Device"
Identifier "Device1" **YOUR'S MAYBE DIFFERENT DO NOT CHANGE**
Driver "nvidia"
VendorName "NVIDIA Corporation"
BusID "01:00:0" **YOUR'S MAYBE DIFFERENT DO NOT CHANGE**
Option "NoLogo" "true"
Option "UseEDID" "false"
Option "ConnectedMonitor" "DFP-0" **YOUR'S MAYBE DIFFERENT DO NOT CHANGE**
EndSection

** [Volt] lspci shows two vga controllers, a guess and I picked this one...
BusID "PCI:01:00.0"
**

For this next part you are going to have to find the right ‘call off’ and ‘call on’ commands for your card.
Use this website to find them (If you don't have a Asus U31S)
http://hybrid-graphics-linux.tuxfami...tle=ACPI_calls

4. Create and open a ‘cardoff’ file
sudo gedit /etc/bumblebee/cardoff
Copy this into the ‘cardoff’ file and save it

\_SB.PCI0.PEG0.GFX0.DOFF

Create and open a ‘cardon’ file
sudo gedit /etc/bumblebee/cardon
Copy this into the ‘cardon’ and save it

\_SB.PCI0.PEG0.GFX0.DON

Your computer will now be configured for ‘Optimus’, if you want to use the Nvidia chip for any program just run ‘optirun’ before it. For example if you wanted to open gedit with your Nvidia chip you would run. ** [volt] it give's me 10h without to use 'optirun' **


Recommend to install Jupiter to easily change cpu performance modes (gnome applet).
(http://www.webupd8.org/2011/09/jupit...lable-for.html)
sudo add-apt-repository ppa:webupd8team/jupiter
sudo apt-get update
sudo apt-get install jupiter
sudo apt-get install jupiter-support-eee


Hopefully this might help other on the right track?
 
Old 04-24-2012, 12:42 PM   #4
malkavian
LQ Newbie
 
Registered: Jan 2011
Distribution: Debian
Posts: 17

Rep: Reputation: 3
Thank you very much! I have the same laptop and the same problem. I'll try to apply your solution.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: How to install latest Nvidia display driver 260.19.26 in Ubuntu | PPA LXer Syndicated Linux News 0 12-16-2010 11:41 AM
LXer: How To Install Latest Intel Driver 2.12 On Ubuntu 10.04 (Lucid Lynx) LXer Syndicated Linux News 0 07-07-2010 12:50 PM
LXer: Install Beryl with latest nvidia drivers in Ubuntu Feisty Fawn LXer Syndicated Linux News 0 04-25-2007 05:46 PM
Nvidia latest driver doesn't want to install !! - Error log Fear58 Linux - Software 12 12-09-2004 11:16 AM
How do I install the latest Nvidia Driver captaincaveman Linux - Software 2 05-04-2004 12:26 AM


All times are GMT -5. The time now is 12:19 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration