LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-10-2007, 01:47 AM   #16
Ugly_Gaut_Cow
LQ Newbie
 
Registered: Jan 2007
Posts: 22

Original Poster
Rep: Reputation: 15

Quote:
Originally Posted by JimBass
That might be the Xserver half-crashing. There should be white text all over the screen. If that isn't there, try hitting ctrl-alt-F2. That should get you a login prompt.

And you don't need to edit the grub settings at all. It probably is just a half crashed X server. No worries, just try what I suggest and we'll see what we can get happening.

Peace,
JimBass

Nope. Doesn't work.

The only thing I can access is the grub OS menu, and Windows XP from there.

From searching around, this is a common problem but I haven't seen a solution.

And every article I do find is WAY out of league for any individual's first linux "distro" install.

The more I search, the more disenchanted I become. Over all, the Linux community has terribly isoalted itself by not setting standards to be easliy obtained by "lay" folk.

Wow.

Last edited by Ugly_Gaut_Cow; 01-10-2007 at 02:16 AM.
 
Old 01-10-2007, 07:43 AM   #17
Hitboxx
Senior Member
 
Registered: Mar 2006
Location: India
Distribution: Fedora
Posts: 1,562
Blog Entries: 3

Rep: Reputation: 61
Ok lets try a different approach. First up, get your desktop(GUI) working.
Step 1: You get the OS selection screen.
2) Place the selection on Fedora(if not already) and hit 'e'.
3) Again place the selection on 'kernel' line and hit 'e'.
4) At the end of the line type '1' and hit enter. Now press 'b' to boot.
5) You've entered the text mode and '1' is the no for root user mode.
6) Now type
Code:
vi /etc/X11/xorg.conf
at the prompt.
7) Go to the line 'Driver' under 'Section Device'.
8) Delete whatever is there in the " " of the Driver line by pressing Delete key on your keyboard
9) Position the cursor just inside the " ", hit Insert key once and type vesa.
10) Hit 'Escape' key, then ':' key and type 'wq'. [remember its ':' [shift+;]]
11) Type 'reboot' at prompt. Once done, select Fedora and see if GUI gets on.
12) Report Back HERE.

Last edited by Hitboxx; 01-10-2007 at 07:45 AM.
 
Old 01-10-2007, 04:13 PM   #18
Ugly_Gaut_Cow
LQ Newbie
 
Registered: Jan 2007
Posts: 22

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Ugly_Gaut_Cow
Nope. Doesn't work.

The only thing I can access is the grub OS menu, and Windows XP from there.

From searching around, this is a common problem but I haven't seen a solution.

And every article I do find is WAY out of league for any individual's first linux "distro" install.

The more I search, the more disenchanted I become. Over all, the Linux community has terribly isoalted itself by not setting standards to be easliy obtained by "lay" folk.

Wow.
Okay... Actually, it did work. I had no idea it would take so long to load. Ctrl+Atl+F1, F2, F3 etc, and F8 (toggles gui?) all worked.

After some loading time I logged on as root with the follwing password;

Yeah, RIGHT! Like I'm gonna post my password here.

Be back in a bit. Gonna try out the above post. See where that gets me.
 
Old 01-10-2007, 04:18 PM   #19
JimBass
Senior Member
 
Registered: Oct 2003
Location: New York City
Distribution: Debian Sid 2.6.32
Posts: 2,100

Rep: Reputation: 49
Cool. While you're in as root, try to install the ATI drivers as well, and modify the xorg.conf as they suggest you should in the documantation.

Peace,
JimBass
 
Old 01-10-2007, 05:41 PM   #20
Ugly_Gaut_Cow
LQ Newbie
 
Registered: Jan 2007
Posts: 22

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by shrikant.odugoudar
Ok lets try a different approach. First up, get your desktop(GUI) working.
Step 1: You get the OS selection screen.
2) Place the selection on Fedora(if not already) and hit 'e'.
3) Again place the selection on 'kernel' line and hit 'e'.
4) At the end of the line type '1' and hit enter. Now press 'b' to boot.
5) You've entered the text mode and '1' is the no for root user mode.
6) Now type
Code:
vi /etc/X11/xorg.conf
at the prompt.
7) Go to the line 'Driver' under 'Section Device'.
8) Delete whatever is there in the " " of the Driver line by pressing Delete key on your keyboard
9) Position the cursor just inside the " ", hit Insert key once and type vesa.
10) Hit 'Escape' key, then ':' key and type 'wq'. [remember its ':' [shift+;]]
11) Type 'reboot' at prompt. Once done, select Fedora and see if GUI gets on.
12) Report Back HERE.
Okay, when I read this point;

Code:
vi /etc/X11/xorg.conf
The screen shows a verticle line of "~" with "/etc/X11/xorg.conf [NEW DIRECTORY]" at the bottom. Nothing else.
 
Old 01-10-2007, 05:43 PM   #21
Ugly_Gaut_Cow
LQ Newbie
 
Registered: Jan 2007
Posts: 22

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by JimBass
Cool. While you're in as root, try to install the ATI drivers as well, and modify the xorg.conf as they suggest you should in the documantation.

Peace,
JimBass
I have the driver files on CD-ROM.

So, I guess I have to figure out how to mount my ROM drive from root?
 
Old 01-10-2007, 06:01 PM   #22
JimBass
Senior Member
 
Registered: Oct 2003
Location: New York City
Distribution: Debian Sid 2.6.32
Posts: 2,100

Rep: Reputation: 49
If you're root, all it would take to mount would be the command
Code:
mount /dev/hdc                         (or else)
mount /dev/hdd
You also must have mistyped something, as /etc/X11/xorg.conf is an existing file, it shouldn't be new.

Peace,
JimBass
 
Old 01-10-2007, 06:08 PM   #23
Ugly_Gaut_Cow
LQ Newbie
 
Registered: Jan 2007
Posts: 22

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by JimBass
must have mistyped something, as /etc/X11/xorg.conf
Peace,
JimBass
Then that's what happened.
 
Old 01-10-2007, 06:41 PM   #24
Ugly_Gaut_Cow
LQ Newbie
 
Registered: Jan 2007
Posts: 22

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by shrikant.odugoudar
Ok lets try a different approach. First up, get your desktop(GUI) working.
Step 1: You get the OS selection screen.
2) Place the selection on Fedora(if not already) and hit 'e'.
3) Again place the selection on 'kernel' line and hit 'e'.
4) At the end of the line type '1' and hit enter. Now press 'b' to boot.
5) You've entered the text mode and '1' is the no for root user mode.
6) Now type
Code:
vi /etc/X11/xorg.conf
at the prompt.
7) Go to the line 'Driver' under 'Section Device'.
8) Delete whatever is there in the " " of the Driver line by pressing Delete key on your keyboard
9) Position the cursor just inside the " ", hit Insert key once and type vesa.
10) Hit 'Escape' key, then ':' key and type 'wq'. [remember its ':' [shift+;]]
11) Type 'reboot' at prompt. Once done, select Fedora and see if GUI gets on.
12) Report Back HERE.
Okay, when I typed

Code:
vi /etc/X11/xorg.conf
I got an message E325 (I think) warning me about a two identicle files. I continued anyway and then the verticle line of blue "~" showed up. I type :qa! and it brought me back to a prompt. I logged out, and the Fedora began to set up a user account.

It tested my audio card, and it worked, which is good, then the screen just blinked on and off, BUT... I had a mouse pointer.

Looks like progress.

What else?
 
Old 01-10-2007, 06:44 PM   #25
Ugly_Gaut_Cow
LQ Newbie
 
Registered: Jan 2007
Posts: 22

Original Poster
Rep: Reputation: 15
does the X11 of the path "vi /etc/X11/xorg.conf" have to be uppercase?

Probably. Nerdy linux.

I'm going to check it out and I'll be right back.
 
Old 01-10-2007, 07:38 PM   #26
Ugly_Gaut_Cow
LQ Newbie
 
Registered: Jan 2007
Posts: 22

Original Poster
Rep: Reputation: 15
Okay, the vi /etc/X11/xorg.conf thingy I was experiencing was my own typos.

vi = view?

Anywhooo...

Under section device, the driver was set to vesa, to a colour depth of 24 (bit?)

I didn't change anything. (Well, I did to poke around a bit to see if a hunch would work, but I restored the changes I made, back to the way I orginally found them)
 
Old 01-10-2007, 07:46 PM   #27
Ugly_Gaut_Cow
LQ Newbie
 
Registered: Jan 2007
Posts: 22

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by bsmith121
If you can get to a prompt as root and have internet access, here's the easiest way I know of for fedora ....
Code:
rpm -ivh http://rpm.livna.org/livna-release-6.rpm
yum install kmod-fglrx
then reboot and it should work.

You may also want to check out this link if you're getting started with FC6.
http://www.gagme.com/greg/linux/fc6-tips.php
I tried this solution before, but the grub loader added an additonal Fedora to the list with a build number...

Was that supposed to happen?

I'm going to try it again.
 
Old 01-10-2007, 07:51 PM   #28
JimBass
Senior Member
 
Registered: Oct 2003
Location: New York City
Distribution: Debian Sid 2.6.32
Posts: 2,100

Rep: Reputation: 49
Yum probably added a new (updated) kernel through its use. What was written would just help with the graphics.

You need to read the README or INSTALL file that would come with the ATI driver you downloaded. You probably need to change where the xorg.conf file says vesa to say ati, but that is a guess. The correct setting can be found in the download.

Peace,
JimBass
 
Old 01-10-2007, 08:41 PM   #29
Ugly_Gaut_Cow
LQ Newbie
 
Registered: Jan 2007
Posts: 22

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by JimBass
Yum probably added a new (updated) kernel through its use. What was written would just help with the graphics.

You need to read the README or INSTALL file that would come with the ATI driver you downloaded. You probably need to change where the xorg.conf file says vesa to say ati, but that is a guess. The correct setting can be found in the download.

Peace,
JimBass
I tried to mount the CD-ROM but I got a message that the OS couldn't find /dev/hdc or hdd in fstab, or mtab. I opened up both files and sure enough there wasn't a reference to them.
 
Old 01-10-2007, 10:59 PM   #30
JimBass
Senior Member
 
Registered: Oct 2003
Location: New York City
Distribution: Debian Sid 2.6.32
Posts: 2,100

Rep: Reputation: 49
If your Os is on sata or scsi drives, then it could also be hda or hdb. Looking at the /etc/fstab will tell you what drive it is, just look for the cdrom or dvdrom.

Peace,
JimBass
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora Core 3 - ATI 8.18 Drivers Scarfy Linux - Hardware 0 11-08-2005 07:00 AM
Ati drivers and fedora core 3 just_dan Fedora - Installation 3 09-16-2005 01:00 PM
New ati drivers Fedora Core 3 linkin Fedora 7 02-14-2005 07:35 PM
ATI Radeon Drivers For Xorg on Fedora Core 3 sloik2000 Linux - Software 2 12-29-2004 01:10 PM
Fedora Core 2 test2 and ATI 3.7.6 drivers TCUmax Linux - Hardware 0 03-31-2004 04:34 PM


All times are GMT -5. The time now is 08:41 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration