LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-27-2004, 03:07 AM   #1
Wolfy
Member
 
Registered: Jun 2004
Location: WA
Distribution: Slackware 11 Kernel 2.6.20.7-SMP
Posts: 144

Rep: Reputation: 15
Angry How do I input Japanese text????


I have installed Japanese support for my wife but can't figure out how she can write in Japanese.

Windows has IME an input method editor that allows her to input Japanese characters.

HOW DO WE DO IT IN LINUX?????????????????????

Please I am very much in need of help here.
 
Old 07-27-2004, 05:25 AM   #2
chii-chan
Member
 
Registered: Sep 2003
Location: chikyuu (E103N6)
Distribution: Redhat 8.0 (2.4.25-custom), Fedora Core 1 (2.4.30-custom)
Posts: 357

Rep: Reputation: 30
http://www.linuxquestions.org/questi...hreadid=209367
 
Old 07-27-2004, 07:50 PM   #3
Wolfy
Member
 
Registered: Jun 2004
Location: WA
Distribution: Slackware 11 Kernel 2.6.20.7-SMP
Posts: 144

Original Poster
Rep: Reputation: 15
Thank you for the link, (DOMO)
I have both the canna server and freewnn starting at boot, also I have located kinput2.
I will try your editing solution.
Do you have any tips for using kinput2?
 
Old 07-27-2004, 08:33 PM   #4
Wolfy
Member
 
Registered: Jun 2004
Location: WA
Distribution: Slackware 11 Kernel 2.6.20.7-SMP
Posts: 144

Original Poster
Rep: Reputation: 15
Edited files per your example, but cannot start kinput2 or type in Japanese.
Did I miss something?

Woops!
After I rebooted the machine the desktop was in Japanese!
I don't want that!
I want to simply input in Japanese.
Now when I opened OpenOffice and used [ctrl] + [space] I got a strange little symbol underneath cursor but I couldn't read it it was just vertical bars.
Do I need additional language packs for OO to see these things correctly?
Note:
I did install Japanese support for the system when I initially installed the OS.

Last edited by Wolfy; 07-27-2004 at 08:59 PM.
 
Old 07-28-2004, 12:25 AM   #5
chii-chan
Member
 
Registered: Sep 2003
Location: chikyuu (E103N6)
Distribution: Redhat 8.0 (2.4.25-custom), Fedora Core 1 (2.4.30-custom)
Posts: 357

Rep: Reputation: 30
Just put:

export LC_CTYPE=ja_JP

in the end of /etc/profile should be okay. But I don't know why you said that the whole things turn Japanese. Because LC_CTYPE=ja_JP will change the font coding, not the LOCALE!

For oo, you'll need to install font package. Use "ooadmin" or "spadmin" in latest open office. But the box will be empty. I usually type japanese in gedit.

Have you checked that kinput2 was started when you boot your computer? I mean in redhat-config-services.

By the way, it is not ctrl + space, it shift + space. The control + space is for iiimf (i think that's the name), new input method that comes with Fedora Core 2.
 
Old 07-29-2004, 02:18 AM   #6
Wolfy
Member
 
Registered: Jun 2004
Location: WA
Distribution: Slackware 11 Kernel 2.6.20.7-SMP
Posts: 144

Original Poster
Rep: Reputation: 15
redhat-config-services?
Which one? I have alot of them?
When I said it changed the whole desktop to Japanese, I wasn't lying it did!
I only changed what you advised to change.

I can't find a simple Language pack on OO's site for japanese. I found some [.sh] file but I don't know what to do with it. (I downloaded it) but now what?
 
Old 07-29-2004, 05:36 AM   #7
chii-chan
Member
 
Registered: Sep 2003
Location: chikyuu (E103N6)
Distribution: Redhat 8.0 (2.4.25-custom), Fedora Core 1 (2.4.30-custom)
Posts: 357

Rep: Reputation: 30
You open redhat-config-services as root from teminal window. Then, check kinput2 service.

You said that you changed the whole desktop to Japanese? What window manager do you use? And do you login in gui (runlevel 5)? Change the default language to American English. Because for the whole desktop to change to japanese, the LOCALE/LANG should be japanese. Try reverting everything back to normal (english environment), then try again.

And did the shift + space work? If it didn't work then there is no point changing anything.

As for OO I'll need to be at my Linux box as I'm using windows in library.

As for this part in my post:

Quote:
2. /etc/profile

Add the following lines to the end of your file:

#if the locale is not japanese then use japanese font and time settings
if [ "$LANG" != "ja_JP" ]; then
export LC_CTYPE=ja_JP
export LC_TIME=ja_JP
fi
Just export LC_CTYPE=ja_JP will be enough.
 
Old 07-29-2004, 08:18 PM   #8
Wolfy
Member
 
Registered: Jun 2004
Location: WA
Distribution: Slackware 11 Kernel 2.6.20.7-SMP
Posts: 144

Original Poster
Rep: Reputation: 15
I am using the KDE desktop.

kinput2 is not listed as a service.

I have found two kinput2 files on my system though.

1.) usr/X11R6/bin/ size: 243,308
2.) usr/X11R6/lib/X11/app-defaults/ size: 4,087
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Ctrl+Shift Unicode input gone, after installing Japanese Input Methodes polemon Linux - Newbie 1 09-20-2005 06:17 PM
Japanese input? clausawits Fedora 4 08-02-2004 07:59 AM
Japanese Input ertmann|CPH Linux - General 6 11-03-2003 08:13 PM
Japanese text input in Mandrake Linux 9.1 scchicago Linux - Software 0 10-07-2003 07:52 PM
Japanese Input Phil Healey Linux - General 3 07-18-2003 02:10 PM


All times are GMT -5. The time now is 11:47 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration